Skip navigation
This discussion is archived

Disappearing windows in spaces

12041 Views 26 Replies Latest reply: Oct 3, 2008 12:36 PM by Michael Burton RSS
1 2 Previous Next
domix Calculating status...
Currently Being Moderated
Nov 8, 2007 12:43 AM
I'm using spaces and i have from time to time (very irregularly) windows that just disappear. the application is still there but the screen is empty. impossible to get them back (I tried a lot of things: from the dock, applekey+tab, try to relaunch teh application, hide the application and try to get it back, put in the dock, etc). actually i only hve to stop the application and restart it; forunately i have the menu so i can save things

this happens when i enter a space. all the windows in this particular space disappear (not often but at least once or twice a day).

too bad since, having used it under linux for years (i just switched to mac because it's supposed to be unix) i would really miss this feature.

message if apple people are reading: too bad that you cannot assign to a window the property of being present in all spaces. this is working (snce years) in gnome (at least) and is very convenient.

MacBookPro, Mac OS X (10.5)
  • Alexander Meier Calculating status...
    Currently Being Moderated
    Nov 13, 2007 3:27 AM (in response to domix)
    Hi domix

    unfortunately I don't have any idea why your windows do occasionally disappear, but I can answer your 'message if apple people are reading' request:
    in the spaces preference pane you can assign specific applications to a specific space... as well as to 'every space' which makes the application present in all spaces.

  • Brian P. Campbell Calculating status...
    Currently Being Moderated
    Nov 13, 2007 12:13 PM (in response to domix)
    I'm having this problem as well. I don't know what the solution is, though it seems to have stopped happening as much recently.
    MacBook Pro, Mac OS X (10.5)
  • McKinley Media Calculating status...
    Currently Being Moderated
    Nov 13, 2007 2:07 PM (in response to domix)
    I have the same problem. Makes it so you can't use Spaces. In effect, it crashes all the applications and the open docs in a given space. Please let me know if someone has a solution to this issue.
    Mac Pro, Mac OS X (10.5)
  • Brian P. Campbell Level 1 Level 1 (25 points)
    Currently Being Moderated
    Nov 13, 2007 9:40 PM (in response to McKinley Media)
    I've found two workarounds that sometimes work, but don't always work.

    It sometimes works to control-click the application in the dock, choose "Hide" from the menu, and then click again and choose "Show". This will sometimes bring your windows back, but not always.

    When that doesn't work, it sometimes works to select the application, and then choose Window > Minimize (⌘M), then maximize the window from the icon on your dock.

    These don't always get your windows back, but I've found that at least 4 out of 5 times one of them will.
    MacBook Pro, Mac OS X (10.5)
  • DCNY Calculating status...
    Currently Being Moderated
    Nov 15, 2007 10:19 PM (in response to domix)
    I am having this problem too. It's pretty annoying when you work on some important projects.

    People in professional area tend to use space function more than normal users.

    and It's very sad that we have space function but will have disappeared windows all the time.

    Please FIX THIS BUG. I though apple would have fix it in the first update.
    Macbook C2D 1.83Ghz, Mac OS X (10.5)
  • schokonase Calculating status...
    Currently Being Moderated
    Nov 17, 2007 7:30 AM (in response to domix)
    Same here: When coding i switch very much between my spaces. But i had to turn spaces off becoz the disappearing windows became too annoying. I was very disappointed that this bug wasnt fixed with 10.5.1 :-/
    iMac5,1 2.16 GHz, Mac OS X (10.5)
  • Brian P. Campbell Level 1 Level 1 (25 points)
    Currently Being Moderated
    Nov 17, 2007 8:53 AM (in response to DCNY)
    Has everyone who is having this problem filed a bug report on ? I've already filed a bug report, and it was marked as a duplicate, but from what I've heard having many people file a report can help "vote" to have this bug be given higher priority.

    By the way, be careful because there's a bug in Safari on Leopard that causes to eat your cookies, so make sure you either back up your cookies file (Time Machine is your friend) or use Firefox to report the bug.
    MacBook Pro, Mac OS X (10.5)
  • Beeblebrox Calculating status...
    Currently Being Moderated
    Nov 19, 2007 8:46 PM (in response to domix)
    The only workaround that I have found is to go to the spaces sys prefs and just turn spaces off. This seems to return all the windows to visible (but on one screen of course).

    Let's hope that 5.2 fixes this.
    Intel MacBook Core Duo, Mac OS X (10.5)
  • Akiohan Calculating status...
    Currently Being Moderated
    Nov 23, 2007 5:04 AM (in response to domix)
    Hi, there is a workaround for getting your windows back. Go to the Spaces preferences page, and manually assign your missing apps to a Space. The missing window will appear immediately, and you can remove the app from the list again.
    iMac, Mac OS X (10.5.1)
  • mb-xin Calculating status...
    Currently Being Moderated
    Nov 25, 2007 4:11 AM (in response to domix)
    same problem, very irritating, fix it.
  • kambiz.aghaiepour Calculating status...
    Currently Being Moderated
    Jan 26, 2008 5:18 AM (in response to domix)
    Is there a known fix? I've recently upgraded to 10.5 and subsequently 10.5.1 via the automatic updates. It's especially troubling when its that disappears, since typically I'll be ssh-ed into a remote host and possibly have a file open in the vi editor. I lost my edits when Terminal goes to LA LA land. The next time it happens I'll try the suggestion of assigning the apps to specific spaces.
    Macbook Pro, Mac OS X (10.5.1)
  • elaine c. Calculating status...
    Currently Being Moderated
    Feb 5, 2008 9:15 AM (in response to Beeblebrox)
    you may need this extra step, too

    go to spaces, turn it back on, and delete all the programs in the list with the minus sign at the bottom. although my spaces was clicked off, somehow leopard was still putting my apps into other windows, that I could not access. I had trouble with iTunes and iPhoto (the ones I had tried briefly in space 2, before turning off spaces).
    quad G5, Mac OS X (10.5.1)
1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.