1 2 3 4 5 Previous Next 70 Replies Latest reply: Jun 22, 2008 7:18 AM by archigos Go to original post
  • 30. Re: iCal Server error
    DLR Level 3 Level 3 (680 points)
    So does the DNS zones section work in Server Admin or not? I have put in an entry with a reverse entry. I used Terminal on a client machine to test the dns entry and it resolves correctly. However, when I open the hosts file, it does not show anything remotely close to my DNS entries. Does the DNS service in Server Admin use a different file than the hosts?
  • 31. Re: iCal Server error
    Tim_McManus Level 1 Level 1 (105 points)
    Okay, I've been able to fix the 210 issue and get group calendaring to work with Kerberos authentication.

    I stopped the iCal service and restarted it. It at least fixed this issue temporarily for me (I say that because I'm not going to hold my breath).

    It has to do with authentication within the server. The same fix (stopping and restarting the service) can be applied when AFP dies.

    I think this is a bug and it might be a bug in the overall service authentication model in 10.5.x server.
  • 32. Re: iCal Server error
    twood3 Level 1 Level 1 (10 points)
    well i have the same error message. i'll try to restart the service, and if that doesnt work, i'll change it to .local i guess
  • 33. Re: iCal Server error
    Robert Wallis Level 1 Level 1 (0 points)
    I had the exact same sequence - I had calendar services working fine, changed nothing, and all of a sudden started getting the

    sqlite3.DatabaseError: database disk image is malformed

    Error in the calendar server log, and was getting the 210 errors on the web calendar....

    Anybody have any ideas?
  • 34. Re: iCal Server error
    Rob Giseburt Level 1 Level 1 (0 points)
    Hello,

    After fighting this thing I found a solution for the "Error from server: Error processing calendar data (210)" that's consistent for me:

    After creating the group, adding members, and enabling the wiki and web calendar services, save in Workgroup Manager. Then, in Server Admin, restart the iCal Service and then restart the Web Service.

    It appears that the two services don't re-read the group list while they're running. The iCal service won't show a calendar. The web service won't show the group at all. This also goes for making changes to a group, such as enabling the service where it was previously off.

    To check to see if there's a cleander (and to learn a whole lot of other stuff) go to the URL you've given in Server Admin, complete with port:
    http://servername.com:8008/
    or, for SSL:
    https://servername.com:8443/ (<- note the "https" not "http")

    In /principals/groups/groupshortname/ it should show something like this:
    *Calendar homes:*
    *-> /calendars/groups/groupshortname*

    If it doesn't, then you need to make sure that the service is turned on for the group in Workgroup Manager and then restart the iCal service in Server Admin.

    Hope that helps someone,
    -Rob
  • 35. Re: iCal Server error
    Level 6 Level 6 (11,035 points)
    Hi, after following the above good advice from everybody I've solved this problem (by using server.local in the iCal settings) for reading the group calendar and creating new events on webmail, HOWEVER, when I try and edit an event in webmail that was created in iCal (by the same user) I still get the 210 error.

    Is this the same for everybody? Being able to change events in a group calendar by anybody is really quite important... anybody else still having problems...?
  • 36. Re: iCal Server error
    DLR Level 3 Level 3 (680 points)
    I beleive you still have DNS problems. You should (be able to) use server.com (or .net, .org etc). I would go over your DNS server records. You are running DNS service right? You should have forward and reverse pointing. From what I have experienced and sounds like others too, you are best to stop iCal and perhaps web services before you make changes in your DNS settings. I might even stop the DNS service too. Then turn them all back on after you make your changes.
  • 37. Re: iCal Server error
    Level 6 Level 6 (11,035 points)
    Hi DLR, thanks for your quick reply...

    I am running DNS and there is a reverse record. Though I do look in my /etc/hosts file and there is only the 127.0.0.1 localhost loopback entry (?). Like your earlier post, are these records being stored elsewhere? If I run a lookup (I'm using Network Utility) on a client I get a perfect result. Everything resolves and all services are running fine. ICal is running fine, except editing a previously created on the WebCal. I can create on the WebCal and then read these and edit them in iCal, just not the other way round.(???)

    I have tried all option of authentication, toggled SSL, etc etc. I am quite baffled... Have you managed to get this running perfectly?
  • 38. iCal Server error
    Level 6 Level 6 (11,035 points)
    just to add, I have tried reinstalling this time with the simple setup (was admin before), with an FQDN, everything works, again except editing in webmail entries that were made in ical... Curious to know if other people have the same problem...
  • 39. Re: iCal Server error
    Jan Anderson Level 1 Level 1 (30 points)
    Another report of:

    "Error from server: Error processing calendar data (210)"

    I have a calendar in Ical client that writes to the wikicalendar - works
    Adding new events in wikicalendar from webbrowser - works
    Editing anything from web after it has been touched by ical - Does Not work

    Editing events created on web works UNTIL it has been edited by iCal client.
    The we get the dreaded: "Error from server: Error processing calendar data (210)"

    Where do I look to resolve this, please?

    TIA and regards
    Janne A.
  • 40. Re: iCal Server error
    Jan Anderson Level 1 Level 1 (30 points)
    Serverlog:

    From Ical, works:

    IP - me [06/Dec/2007:12:07:08 +0200] "PUT /calendars/groups/mygroup/calendar/AEFA4421-38B8-4F17-9608-A60B7F173ECD.ics HTTP/1.1" 204 0 "-" "DAVKit/2.0 (10.5.1; wrbt) iCal 3.0.1" [242.1 ms]

    From Safari wikicalendaredit , does not work:

    172.16.0.40 - - [06/Dec/2007:12:07:21 +0200] "GET /calendars/groups/mygroup/calendar/AEFA4421-38B8-4F17-9608-A60B7F173ECD.ics HTTP/1.1" 401 141 "-" "-" [10.6 ms]
    172.16.0.40 - "(sudoers)wikiserver as (groups)mygroup" [06/Dec/2007:12:07:21 +0200] "GET /calendars/groups/mygroup/calendar/AEFA4421-38B8-4F17-9608-A60B7F173ECD.ics HTTP/1.1" 200 313 "-" "-" [69.4 ms]

    It seems to be editing different calendars but I might be missing something??

    Message was edited by: Jan Anderson
  • 41. Re: iCal Server error
    DLR Level 3 Level 3 (680 points)
    I will have to check on this later this afternoon. My memory is fuzzy and it wasn't very scientific-2am after hours of trying this and that. It finally worked and I can't remember completely what I did, but....I remember logging in as root and changing the permissions on the group calendar. I think owner was root r/w and group was admin r only. I changed admin to r/w.

    I would investigate permissions
  • 42. Re: iCal Server error
    Jan Anderson Level 1 Level 1 (30 points)
    Permissions on the .ics files are
    user: _calendar rw
    group _calendar rw
    others none

    Is that not right?

    I tried setting group as the usergroup of the wiki, same error.
    (Restarted the ical and web services after)

    Guess I am stuck for now...

    TIA and regards
    Janne A.
  • 43. Re: iCal Server error
    Tim_McManus Level 1 Level 1 (105 points)
    Shut down he iCal Server service and then the Web service. Restart the Web service and then the iCal service.

    That might fix it.
  • 44. Re: iCal Server error
    Jan Anderson Level 1 Level 1 (30 points)
    Thank you Tim,

    No such luck though I'm afraid.
    What should permissions be for .ics files?

    best
    jtm