1 2 3 Previous Next 35 Replies Latest reply: Apr 10, 2008 5:09 AM by nmonkee
George Munson Level 1 Level 1 (20 points)
After installing Leopard in my office I can no longer connect to any of the SMB network drives at work. This worked perfectly under 10.4 and still works on other Macs on the network running 10.4. Unlike some of the other posts on this site, my username and password have no special characters so none of the posted fixes/hacks work for me.

Intel iMac, Mac OS X (10.5)
  • 1. Re: SMB connections broken in Leopard
    George Greene1 Level 1 Level 1 (40 points)
    hum,
    System Preferences > Network > whatever connection type (Ethernet Connected) > Advance (button) > WINS (tab) > MSHOME (or whatever the name of the workgroup is)
  • 2. Re: SMB connections broken in Leopard
    dchao99 Level 4 Level 4 (2,040 points)
    Yep, the Leopard upgrade scripting on the install DVD has bugs. The install DVD messes up the NetBIOS workgroup name and computer name.

    Delete the "automatic" network profile and set up a new location, then you will be able to enter the correct names, and they will stick.

    Message was edited by: dchao99
  • 3. Re: SMB connections broken in Leopard
    George Munson Level 1 Level 1 (20 points)
    Thanks for the advice but I should have been more specific.

    The SMB connection fails from Go>Connect to Server. The upgrade to Leopard retained my path under Favorite Servers but some of the SMB servers fail to mount. Oddly one SMB has no problem and connects as under 10.4. Deleting the Favorites and/or manually entering the path does not help with the problemative SMBs. The problem seems to be inconsistent in its behaviour. At least once I was able to connect to a problematic SMB drive but the directory showed no files even though it has hundreds.

    And another odd behaviour: I found an alias to one of the SMB and I can mount the drive by double clicking the alias but it will still not mount via Connect to Server. Luckily I had the alias, otherwise I would have to wipe Leopard and revert to 10.4
  • 4. Re: SMB connections broken in Leopard - possible fix if you use Open DNS
    Jonathan Payne1 Level 1 Level 1 (40 points)
    I just noticed this problem myself, the Finder hangs trying to connect to my Windows shares.

    I did a ping "sharename" and it came back so I knew it was able to find the host. But then I noticed that it was not an address on my local network!! It was inf act an open dns server!

    So I removed Open DNS as my DNS servers (under network settings) and everything works like a charm!

    Open DNS returns itself when you resolve hosts that don't exist ... why that has changed under Leopard I don't know.
  • 5. Re: SMB connections broken in Leopard
    deanr Level 1 Level 1 (15 points)
    I can connect to smb shares on a Windows server with no problem. I cannot connect to smb shares on a Linux server. I get a -43 error every time. The Linux shares work fine on 10.4.
  • 6. Re: SMB connections broken in Leopard
    LoganGreer Level 1 Level 1 (0 points)
    I am having sorta the opposite problem. The issue is that even though I have set up sharing correctly, the Windows computers on my network cannot connect to me with r/w access. They can "read only". No matter what I do.

    Any help?
  • 7. Re: SMB connections broken in Leopard
    soerenkroeger Level 1 Level 1 (0 points)
    Hi

    i have exactly the same issue here - this is really annoying.
    It works fine when i use smbclient from command line, but mount_smbfs and mounting from finder doesn't work:

    When i try in Finder, i get the following error:
    "The Finder cannot complete the operation because some data in "smb://server/share" could not be read or written (Error code -36)"
    There's no log entry in /var/log/system.log

    When i try with mount_smbfs i always get:
    mount_smbfs: server rejected the connection: Socket is not connected
    (no matter how i use the syntax, with domain or without, wrong password, makes no difference)

    I have entered the domain name in the network settings, without luck.
    I have also updated to 10.5.1 - but still...
    I have made a clean Mac OS reinstall - no luck.

    Am I the only one? Has someone find a solution? Is Apple reading this?

    Thanks

    Regards,
    Søren
  • 8. Re: SMB connections broken in Leopard
    Drnkusv Level 1 Level 1 (0 points)
    I have the same problem -- and it has not been fixed by 10.5.1. Usually, I can mount my Windows shares fine using Apple-K and putting in the local IP address of the windows machine. Every couple of says or so, however, it simply refuses to connect -- giving me the Error 36. I can always connect using smbclient -- and I can transfer files using smbclient -- but it still refuses to mount the drive in Finder.

    This is very strange behavior -- obviously something is seriously wrong with Leopard, because the shares exist and are available -- and can even be fully accessed in terminal using smbclient.

    (I should add that I have the same spotty results using the name of the windows machine rather than the IP address. Sometimes it works and sometimes it does not. All of this was fine in Tiger.)

    Anyone have any success in figuring out how to resolve this?
  • 9. Re: SMB connections broken in Leopard
    DaveIsDaddio Level 1 Level 1 (0 points)
    I have the same problem. Prior to installing 10.5.1, I was able to turn "File Sharing" off and was then could see and use all of my Windows PCs, shares and printers. When I first installed 10.5.1 and turned "File Sharing" back on, I still saw my Windows shares and printers so I thought Apple had fixed the problems.

    But when I next rebooted my 10.5.1 iMac, I can no longer can see ANY of my Windows PCs, shares OR printers and turning "File Sharing" off again no longer serves as a workaround. So I'm hosed! This is really an unacceptable situation!
  • 10. Re: SMB connections broken in Leopard
    edward4130 Level 1 Level 1 (0 points)
    same issue here, i can get to the server and desktop linux boxes via terminal but nothing in the finder. My Finder in 10.5 sees the shares but I can't connect to them regardless of how I share them, I tried SMB NFS and no luck, meanwhile i know i have the correct user/pass, I use them from other linux systems to log into every day.

    Hard to believe that this is happening to so many, must be a bug. I currently am doing everything backwards. I am mounting the mac onto a linux system to move files!!!!!! this is crazy!!!!

    edward4130
  • 11. Re: SMB connections broken in Leopard
    Trouille2 Level 1 Level 1 (0 points)
    Ok, just to be part and try to make this topic a priority to Apple. I have the same problem, I tried to connect to my external SATA drive with SMB (I get a connection but no file visible) and with AFP (I can see the files but when I try to open one, I loose the connection).
  • 12. Re: SMB connections broken in Leopard
    Drnkusv Level 1 Level 1 (0 points)
    If it is possible to get to a network drive through terminal (as I can do with smbclient) and transfer files then how hard could it be for Apple to fix whatever the problem is with Finder? This seems like there should be a pretty simple solution, given that the networking is working; it is just Finder that is the problem.
  • 13. Re: SMB connections broken in Leopard
    Scott Kroeger Level 1 Level 1 (0 points)
    My new MacBook pro (shipped with 10.4 and updated with 10.5 in the box and then to 10.5.1 via Software Update) does not recognized any of my SMB servers or Windows Machines. A clean re-install didn't help. This is a pretty big problem to have slipped past Apple QA.
  • 14. Re: SMB connections broken in Leopard
    deanr Level 1 Level 1 (15 points)
    I had the same problem here at the university. We have Windows shares which work fine. Our Linux samba shares gave us connection problems after upgrading to Leopard.

    This suggestion fixed our connection problems: http://www.macosxhints.com/article.php?story=20071110042328748

    Good luck
1 2 3 Previous Next