Skip navigation
This discussion is archived

FileVault and Launch Services

23647 Views 77 Replies Latest reply: Sep 8, 2009 3:26 AM by Michael Kuck RSS
1 2 3 ... 6 Previous Next
thirteen37 Calculating status...
Currently Being Moderated
Nov 12, 2007 8:39 PM
I seem to have a conflict between FileVault and Launch Services. Whenever I assign a custom URL handler or file extension, the settings are forgotten on a reboot.

Can someone please verify if this happens with their set up too? It's exceptionally annoying for me, even though I don't reboot that often.

To duplicate:
1) Create a new account
2) Log in to the new account.
3) Enable FileVault
4) Modify Launch Services settings. I usually start Firefox and set it as the default browser when prompted. Changing assignments for file extensions (using Finder or RCDefaultApp) will also exhibit the same issue.
5) Reboot (don't just log out) and, if necessary, log into the new account.
6) Check Launch Services settings again. In my case, I start Firefox again. It will prompt to be set as the default browser again, indicating that the previous settings were not retained.

Some cases, it seems the settings seem to be retained over one reboot, but will be lost the next. Settings will be preserved when only logging in and out without a reboot.

The problems go away when I disable FileVault. I've checked ~/Library/Preferences/ and it's fine across reboots. It seems that LaunchServices itself isn't reading the file when its in FileVault.

This a a clean installation of Leopard, not an upgrade of any sort.

Thanks in advance.
MacBook, Mac OS X (10.5)
  • Terry Reeves Calculating status...
    Currently Being Moderated
    Nov 19, 2007 6:35 AM (in response to thirteen37)
    Yes I see it too. In my case it seems is resetting with every boot. I typically change various video types from quicktime to vlc among other things. I'm plaaning on seeing if I can work around this with a login script.
    In addition to this behavior I cannot get launch services to truly respect file extensions. My primary example: I have digital comics. These are typically zipped or rared sets of jpegs, using zip/rar purely for packaging purposes not compression. The extensions are then standardly set to cbz or cbr (comic book zip/rar). If I assign these to the comic reader, it works until reboot, but .zip and. rar extensions are also mapped to the reader. The opposite problem occurs if I set the zip/rar to something , The plist file does not record the extensions at all in in some cases, going strictly by the type of file, which actually are not different. This was no problem in 10.4.
    MacBook Pro Core 2 Duo, Mac OS X (10.5.1)
  • Austin Jackson Calculating status...
    Currently Being Moderated
    Nov 25, 2007 1:42 PM (in response to thirteen37)
    I can confirm this. Same exact problem.
    MacBook Pro, Mac OS X (10.5.1)
  • Austin Jackson Level 1 Level 1 (5 points)
    Currently Being Moderated
    Nov 25, 2007 5:07 PM (in response to thirteen37)
    Just to extend thirteen37's suggestions,

    I created an Automator workflow that runs the shell command

    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchSe rvices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user

    I saved it as an application in my home directory and set that application to run at login through System Preferences. It is still not a fix, but it at least automates the work around.
    MacBook Pro, Mac OS X (10.5.1)
  • GunnarSchroeder Calculating status...
    Currently Being Moderated
    Nov 28, 2007 10:52 AM (in response to thirteen37)
    Hits me, too. I use my profile from 10.4.x from an upgrade install.

    Message was edited by: GunnarSchroeder
    MacBook Pro C2D 2.33, 3 GB RAM, Mac OS X (10.5.1), Dual G5 1.8
  • Pascal Pfiffner Level 1 Level 1 (25 points)
    Currently Being Moderated
    Nov 28, 2007 11:28 AM (in response to thirteen37)
    Same problem here. Thanks for the hints, I hope this helps.
    MacBook Pro 2.33 GhZ, Mac OS X (10.5)
  • GunnarSchroeder Level 4 Level 4 (1,140 points)
    Currently Being Moderated
    Dec 5, 2007 6:05 AM (in response to thirteen37)
    I count us lucky if it gets fixed with 10.5.2.
    MacBook Pro C2D 2.33, 3 GB RAM, Mac OS X (10.5.1), Dual G5 1.8
  • jakaj Calculating status...
    Currently Being Moderated
    Dec 6, 2007 9:35 AM (in response to thirteen37)
    I have this problem too. In addition to that, firewall rules are also lost on every reboot (I use "Set access for specific services and applications").
    Mac OS X (10.5)
  • loniux Calculating status...
    Currently Being Moderated
    Dec 10, 2007 12:48 AM (in response to thirteen37)

    I opened the bug 5575270 almost one year ago with Tiger. They Ignore it and think Leopard solved it. No way!
    It also causes not only the LaunchServices Alzheimer, but also you cannot install WOW or update Adobe Reader.

    Bye all.
    10.4 and 10.5 - MBP, Mac OS X (10.4.11)
  • loniux Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 13, 2007 1:19 PM (in response to thirteen37)
    - Sometimes, menuitems do not start with session login. Have to restore all manually.
    - World of Warcraft expansion and big patches not installable (identifies a file part of the install as corrupt)
    - Launch services forget selected applications and fall back to default (will open safari instead of firefox, preview instead of adobe reader, etc.)

    Apart from the launchservices configuration loss, I have also lost twice the mouse buttons configuration for expose and dashboard.

    - the Wow game itself wo'n install
    - the expose mouse button configuration is sometimes lost, and must be re-assigned

    The bug is: Problem ID: 5575270
    The bug was:
    01-Nov-2007 04:34 PM Cloned from problemID rdar://problem/5165891 by: SABRINA FULLHART.

    The first answer from apple to the bug was:

    Engineering has requested the following information in order to further investigate this issue:

    Please know that we have been able to get the same behavior in our everyday usage of the system. If possible, could you supply detailed steps that cause these problems to happen consistently and repeatedly?

    MBP C2D, Mac OS X (10.4)
  • MarkDouma® Level 6 Level 6 (9,845 points)
    Currently Being Moderated
    Dec 13, 2007 2:37 PM (in response to Austin Jackson)
    There is really no need to do that. "lsregister" is automatically run when you startup anyway, and running a secondary instance is only likely to cause problems. See Launch Services Programming Guide: Application Registration:

    All applications available on the user’s system must be registered to make them known to Launch Services and copy their document binding and other information into its database. It isn’t ordinarily necessary to perform this task explicitly, since a variety of utilities and services built into the Mac OS X system software take care of it automatically:

    •A built-in background tool (lsregister), run whenever the system is booted or a new user logs in, automatically searches the Applications folders in the system, network, local, and user domains and registers any new applications it finds there. (This operation is analogous to “rebuilding the desktop” in earlier versions of Mac OS.)

    Hope this helps....

    Message was edited by: MarkDouma®
    Dual 2.7GHz PowerPC G5 w/ 2.5 GB RAM; 17" MacBook Pro w/ 2 GB RAM -, Mac OS X (10.5.1)
1 2 3 ... 6 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.