Skip navigation
This discussion is archived

iCal Server error

18122 Views 70 Replies Latest reply: Jun 22, 2008 7:18 AM by archigos RSS
  • Tim_McManus Level 1 Level 1 (105 points)
    Currently Being Moderated
    Dec 6, 2007 11:03 AM (in response to Jan Anderson)
    One last thing to try: Have you run a repair permissions from Disk Utility?

    You could 777 the permissions and see if it works. If it doesn't, then it's not a directory permissions-related error.
    Dual-1.25GHz G4, Mac OS X (10.5.1)
  • Rob Giseburt Calculating status...
    Currently Being Moderated
    Dec 6, 2007 12:02 PM (in response to Nnooo)
    To force the group to be able to edit the calendar, the only way I have found is to resort to the command line.

    First, you need the GUID of the group:
    Visit https://serverdomain:8443/principals/groups/

    Or, if SSL is off, make that:
    http://serverdomain:8008/principals/groups/

    Make sure the group's short name is in the list. Click on the group's short name.

    You should see something like this:
    *Principal Information*
    ---------------------
    *GUID: C0CE9370-DD45-4263-AC18-E20F4444474A*

    Note the GUID value, we'll need it in a second.

    Now, open Terminal either on the server or ssh into the server as a admin, and run the following commands (each line is a command):

    *cd /Library/CalendarServer/Documents*
    sudo sqlite3 -line /Library/CalendarServer/Documents/principals/.db.calendaruserproxy 'select * from groups;'

    You might see results like:
    +GROUPNAME = C0CE9570-DD45-4263-AC18-E20F4444474A#calendar-proxy-write+
    +MEMBER = D872BAB5-6512-4688-A1E8-B7144449F07A+

    If you get nothing, that's fine too. You just want to make sure that what you're about to add isn't already there.

    Ok, to delegate any group or user to be able to read/write any other group or user's calendars (all of them) then you run:
    *sudo sqlite3 -line /Library/CalendarServer/Documents/principals/.db.calendaruserproxy 'INSERT INTO "GROUPS" VALUES('OWNERGUID#calendar-proxy-write','OTHERGUID');'*

    You must change OWNERGUID to the GUID of the user or group (or location or resource, I suppose) that you located in the web browser for the owner of the calendar(s).
    You must change OTHERGUID to the GUID of the user or group that you wish to be able to access the calendars owned by OWNERGUID.
    You can change calendar-proxy-write to calendar-proxy-read if you want to only allow read access.

    Now, to how this pertains to this specific thread: You must enter the GUID of the group for both OWNERGUID and OTHERGUID. This allows anyone in the group to read/write any of the group's calendars. I don't know why this doesn't happen automatically.

    Here's an example:
    At https://server.domain.com:8443/principals/groups/testgroup/ If found that testgroup's GUID is C0CE9570-DD45-4263-AC18-E20F4444574A, so I run:

    *sudo sqlite3 -line /Library/CalendarServer/Documents/principals/.db.calendaruserproxy 'INSERT INTO "GROUPS" VALUES('C0CE9570-DD45-4263-AC18-E20F4444574A#calendar-proxy-write','C0CE9570-DD45-4263-AC18-E20F4444574A');'*

    Hope that helps,
    -Rob
    MacBook Pro, Mac OS X (10.5.1)
  • Jan Anderson Level 1 Level 1 (30 points)
    Currently Being Moderated
    Dec 6, 2007 12:43 PM (in response to Rob Giseburt)
    Thanx Rob,

    That's some serious info, a little bit beyond me though...
    I fin more and more that I need to use the terminal...
    Perhaps time to get a book and learn it for real...

    When I start doing this, the commandline asks me if I know what I am doing
    and I would have to say not really ... ,-)

    Appreciated though..
    just need a n espresson and some time to dig into it...

    Anybody has a basic beginner's guide to the terminal ?

    TIA and regards
    Janne A:

    Message was edited by: Jan Anderson
  • nino zeke Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 10, 2007 7:44 AM (in response to Rob Giseburt)
    all this information has been really helpfull! thanks to all of you guys. it's kinda running now.

    i was even able to conect to my webcal from my ical but its declared as a read only source? hmm.. trying to fix this, but not getting anywhere.

    if i try robs mod i get this error: (and since i don't really know what i'm doing excatly i have no clue how to solve this.. )

    SQL error: unrecognized token: "1C3F"

    1C3F is the second part of my GUID.
    apple
  • Lydie CAMPAN Calculating status...
    Currently Being Moderated
    Dec 13, 2007 6:46 AM (in response to Nnooo)
    Ok,

    Same 210 error. iCal service works fine for users, not for groups.

    My guess : Here is the sequence I used to make it work AT LAST !

    1 - Turn off both ical service and web service
    2 - Deleted the group that is unable to connect to it's calendar with error 210
    3 - Create another group with a different name (and different UID don't come back to it), you can add your members and wiki and calendar service, and ther save.
    4 - Turn ON ical service first and Web service second.

    It worked for me connecting via my web browser with the credentials of one of the members of the new group I created.

    Before doing that I could see in the log pbs with principals not existing for my group. I previously had the same problem with users.

    It seems ical service has difficulties refreshing and creating principals when running.

    Voila... Hope it helps.

    Hubert
    MacMini, Mac OS X (10.5)
  • Ted Dively Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 13, 2007 10:57 PM (in response to Rob Giseburt)
    Actcually, Robert Giseburt was very close to having it correct, but in order to make it work, I had to change the single quotes around the values to be inserted to double quotes, then it worked like a charm for me. Example:

    sudo sqlite3 -line /Library/CalendarServer/Documents/principals/.db.calendaruserproxy 'INSERT INTO "GROUPS" VALUES("C0CE9570-DD45-4263-AC18-E20F4444574A#calendar-proxy-write","C0CE9570-DD 45-4263-AC18-E20F4444574A");'

    As always, your mileage may vary.

    Ted
    PowerBook G4 1.67Ghz, Mac OS X (10.5.1)
  • ClarkDV Calculating status...
    Currently Being Moderated
    Dec 15, 2007 11:35 PM (in response to Lydie CAMPAN)
    I followed your steps exactly and still get the 210 error.

    Frustrating!
    1GHz Tibook, Mac OS X (10.5.1)
  • Peter Glock Level 1 Level 1 (45 points)
    Currently Being Moderated
    Dec 26, 2007 3:39 AM (in response to Lydie CAMPAN)
    This worked for me. Thank you.

    Just a thought. I built my 10.5 server from a clean install but imported users and groups from a 10.4 server. Could this be part of the problem? In which case, it's probably best to only import users but then create new groups on the 10.5 server. As always, YMMV.
    MacBook Pro, PowerMac g5, 2 x iMac g5, g4 Quicksilver, 2 x mac mini, iBook G4..., Mac OS X (10.5.1), Infrant readyNAS 600 (2TB)
  • sandraval Calculating status...
    Currently Being Moderated
    Jan 2, 2008 3:28 AM (in response to Laz the Wiz)
    I had the same problem. I followed this istructions and now it's working.
    http://macresearch.org/lab-journal-group-collaboration#comment-13035
    UPDATE: Fixed Web Calendar Problem

    Just pick a certificate. The default certificate was not the default choice.

    Hope it will help
    Sandra.
    imac, Mac OS X (10.5.1)
  • glenstorey Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 12, 2008 5:57 PM (in response to Nnooo)
    Same problem as you guys, but to fix mine I had to turn on webDav in the apache options of the web service (in server admin), and chose my server's ip address in the general tab of the web service (rather than 'other' which it defaulting to).

    Hope this helps.
    Macbook Pro, Mac OS X (10.5.1), Nice Shade of Gray
  • ClarkDV Level 2 Level 2 (175 points)
    Currently Being Moderated
    Jan 12, 2008 6:15 PM (in response to glenstorey)
    Didn't fix mine. <sigh>
    1GHz Tibook, Mac OS X (10.5.1)
  • James Hadd Level 1 Level 1 (10 points)
    Currently Being Moderated
    Jan 16, 2008 12:20 PM (in response to Nnooo)
    here is my 2 cents worth

    i tried everything on this and the other thread. did not help me at all. kept getting the same errors as described above. so i put everything back to the way it was before and RESTARTED the server. everything now works perfect. so i am not going to touch a thing. looks to me like just stopping and starting web and ical services doesn't reboot all services needed for the changes to take effect. try to reboot the server after trying changes, and/or restart the server first then try some of the above steps.
    MacBookPro 15" 2.6ghz, Mac OS X (10.5.1)
  • art on Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 21, 2008 12:21 PM (in response to Nnooo)
    I've had a lot of problems with this.
    It seems like it even caused Open Directory corruption once, which was very strange.
    I've since rebuilt the server from scratch since I didn't backup the OD database.
    After rebuilding, I started having the same problems using a group wiki web calendar. I would either get the 210 error, or when using the web calendar, it would say the event was created, only to have the event disappear a second later, beautifully fading away into the ether.
    I've got it working, for now at least.

    I followed the advice of stopping ical server and web service.
    Then I deleted the group, and created a new one with a different name.
    I started up ical then web service.
    This worked.

    I then stopped everything, deleted that group, and looked in Library/CalendarServe/Documents/Groups and deleted both group folders.
    (I used batchmod to change permissions to look in this folder)

    I then started over using the original group name, and it seems to be working.

    In short, I think stopping the calendar service, and deleting the folder for the group, then restarting the service will work to fix some of these problems.

    Now I wish I could migrate over the blog that was backed up from the earlier install.
    Xserve G5, Mac OS X (10.5.1)
  • kmarkevich Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 22, 2008 12:51 PM (in response to art on)
    Thanks for the tips. I too had the error but it is now corrected. Actually, it was a little different as out of two groups, one group calender gave the error--the other didn't. After reading all posts, I thought I would try your solution. But before I deleted the group, I thought I would try to just delete the folder.

    I made sure the iCal server Host Name was the same as the Web Site I was using. I corrected permissions (Disk Utility). Then in Workgroup Manager Group, unchecked all references to Web calendar. Same with Server Admin Web sites - Web Services. Then turned down iCal server. Deleted the group folder from /Library/CalendarServer/Documents/calendars/groups/groupname. I then restarted the box.

    Once it was up, I started iCal server (Web services was already running), checked Server Admin Web services Web calendar, the went over to Workgroup Manager and started Web calendaring for the group. Gave it a few moments, and can now login from a client machine and access the calendar without the error.

    Of interest, I was also getting "principal not found" messages in iCal server error logs when trying to access the calendar. I think this all has to do with the group permissions or authentication. I notice Kerberos doesn't seem to like the iCal server and perhaps something got messed up there for the group. Anyways, thanks for the tip and it seems to have got it working for me (for now).
    iMac alu, Xserve, Mac OS X (10.5.1), Leopard Server
  • Turtle_FR Calculating status...
    Currently Being Moderated
    Feb 3, 2008 4:08 AM (in response to Picoscope)
    Hello

    I have the same error on my Leopard Server 10.5.1 :
    sqlite3.OperationalError: SQL logic error or missing database

    I tryed to modify the DNS and the name of local server but whitout success


    Do you have a solution?
    Thanks.
    MacBook Pro 2.4Ghz, Mac OS X (10.5.1)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.