Skip navigation
This discussion is archived

Error -10810: what's that?

22204 Views 22 Replies Latest reply: Dec 26, 2007 1:36 PM by illy5603 RSS
  • reneooms Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 11, 2007 12:29 AM (in response to N45800)
    That's a goog hint. One of the programms that's causing the error is HamachiX. Every second it starts a new thread. At 250 threads it crashes
    Macbook Pro 17", Mac OS X (10.5.1), 2GB, 2.2Ghz, X1600, OSX10.5.1
  • MarkDouma┬« Level 6 Level 6 (9,845 points)
    Currently Being Moderated
    Dec 11, 2007 1:30 AM (in response to donazipe)
    donazipe,

    The following file defines the error -10810:

    /System/Library/Frameworks/CoreServices.framework/... /Frameworks/LaunchServices.framework/... /Headers/LSInfo.h

    as:

    /* ======================================================== */

    /* LaunchServices Type & Constants */

    /* ======================================================== */

    enum {

    kLSUnknownErr = -10810, /* Unexpected internal error*/

    };

    Basically, it means that the Launch Services framework is misbehaving and is encountering errors when trying to launch an application. This is fairly rare, as I've only seen a few other people in these forums have this error in the last several years.

    When you encounter this error message, it is probably best to restart the machine (as I can't think of any other easy way out of this, since it's a catch-22 situation: if there was an app that could fix the problem you still wouldn't be able to launch it).

    There could be a potential problem with the Launch Services database cache file, which is a file that OS X uses to store information about what applications are installed and the types of documents they can open, etc. You could try rebuilding this database as a step to troubleshoot the issue. I've written a small application that can do this: http://homepage.mac.com/mdouma46/images/LaunchServicesDatabaseRebuildApp.zip (.zip, ~60 KB). (Yes, there are literally hundreds of other third-party utilities that offer to basically accomplish this same thing, but none that I've seen follow the advice given to a developer friend of mine several years ago in a Developer Technical Support Incident (not customer support, developer support, normally these are $200/problem where you get help from an actual Apple engineer on a specific problem). That advice is to quit the Finder during the rebuild and to restart afterward). Obviously, if you're encountering the launch error, you'll need to run this after you restart, but it should hopefully prevent the problem from occurring in the future.

    Sorry, I'm not sure about the Trash errors...

    Hope this helps....
    Dual 2.7GHz PowerPC G5 w/ 2.5 GB RAM; 17" MacBook Pro w/ 2 GB RAM -, Mac OS X (10.5.1)
  • planoBob Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 11, 2007 3:15 AM (in response to donazipe)
    While you are correct in finding the result, the problem is that some process is running multiple copies of itself and sucking up the all of the per user process ids that are permitted. In my case, it is "always" airport. Everyone else might be identifying the "symptom" when they try to start a process and get the error, but the error is with the process that is found in the process list 25+ times. Logging out and back in will work for a few days, but the problem will come back. Anyone who comes across this again should quit something, and quickly open a shell and type 'ps -ax' and post the results. You might have to quit two or three apps.

    Once we have that data, then we can make a guess.

    I did notice that my ISP was having DNS errors last night (slow actually) and this preceded the problem. the DNS resolution library on Unix is the most nasty piece of business I have worked with since you can't timeout or abort with out using a setjump/longjump setup and that is evil stuff. This might be a hint.

    Robert
    Mac Pro, Mac OS X (10.4.10)
  • planoBob Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 12, 2007 7:36 PM (in response to donazipe)
    It happened again, but this time I found the criminal. The "(airport)" process was launched through the dashboard and there was an active dashboard widget named "Air Traffic Control" that watched for wireless signal strength. I had wireless turned off, but the widget was active. It looks like it spawns a child process on every activation of the widget desktop and since there was no wireless interface active, it hangs that process. Nothing wrong with Apple's launch process, just a bad widget.

    Like any process that spawns a child process, they must ensure they reap the dead child processes and make sure the child's life time is controlled!
    Mac Pro, Mac OS X (10.4.10)
  • mariomunoz Calculating status...
    Currently Being Moderated
    Dec 22, 2007 7:58 AM (in response to donazipe)
    I was getting the same message (-10810) when using iTunes, and sometimes Itunes shows as not responding in the "Activity Monitor". Looking at the Console's logs for iTunes I realize that an error was occurring when trying to open a Xvid codec (r58), so I deleted the codec, and the problem seem to be gone. The codec was dated back to 2006....
    Imac, Mac OS X (10.5.1)
  • planoBob Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 22, 2007 2:32 PM (in response to mariomunoz)
    Check to see if you have an airport widget and then remove it ....

    At the least, close one or more applications, start up the terminal and the do "ps -alx" and post the output here. I bet you have a runaway spawn.

    Robert
    Mac Pro, Mac OS X (10.4.10)
  • illy5603 Calculating status...
    Currently Being Moderated
    Dec 26, 2007 1:36 PM (in response to reneooms)
    Turns out it was Hamachi-X for me too... I don't think there is anything apple needs to do about this if the problem is with a 3rd party application that is not up to date...
    Intel 24" alu iMac, Mac OS X (10.5.1)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.