Skip navigation
This discussion is archived

Maps - Directions to my house no longer works

2507 Views 9 Replies Latest reply: Feb 19, 2008 7:24 AM by chuckstr89134 RSS
Jeff Zacharias Calculating status...
Currently Being Moderated
Dec 11, 2007 4:56 AM
I can use google maps to show my house and used to be able to get directions to/from my house. However, since about a month ago if I try to get directions to/from my house it says "Driving directions could not be received". All other directions work and I can map my address, just not get directions. If I remove my street number, name, and town, leaving just the zip code, the directions will work. If I go to the google maps web site, directions work fine for my address so it seems to be just the iPhone Google Maps. I have tried another another iPhone and my address doesn't work either for directions.

Can anybody suggest how I can get directions working for my address or how to report this error ?
iMac G5, Mac OS X (10.4)
  • Goshia Level 4 Level 4 (1,400 points)
    Currently Being Moderated
    Dec 11, 2007 5:45 AM (in response to Jeff Zacharias)
    Move?

    No trying contacting Apple Support or Feedback. They do look at the feedback but don't think that their are going to drop everything to solve your issue. It could take up to 6 months to get resolved.
    MacBookPro(2x) and iMac 20" iPhone 8G, Mac OS X (10.5)
  • John Pietrzak Calculating status...
    Currently Being Moderated
    Dec 11, 2007 10:41 AM (in response to Jeff Zacharias)
    Jeff, I've discovered that my parent's address does exist on maps.google.com, but apparently does not exist for the iPhone Google Maps app. It would seem that the iPhone app only has access to a subset of the entire database of addresses available on Google's main site... Otherwise, driving directions are working fine for me.

    I don't know where you would report the error. For myself, I get around the problem by just using an address that is near my folks that the iPhone app accepts. (Or, of course, just bring up maps.google.com in the Safari app.)

    --John
    Mac Mini, Mac OS X (10.4.11)
  • DaVBMan Level 6 Level 6 (9,265 points)
    Currently Being Moderated
    Dec 11, 2007 10:50 AM (in response to John Pietrzak)
    Yes, I have discovered a while ago, the Google App (on iPhone or on other phones) hits a different data source (or engine or whatever) than what the web version uses. I have had places not found in one but in the other, different directions, etc. Really not sure why Google would have it that way but I am sure there is a reason. I orginally saw issues like this when I used Google Maps on my old RAZR.

    The best bet is to send a feedback to Google (as they are the ones that programmed and maintain the App found on the iPhone, not Apple). I am sure they are working to make it all one in sync system, but a nudge may help them focus.
    Windows XP Pro
  • pilotattitude Level 1 Level 1 (0 points)
    Currently Being Moderated
    Dec 11, 2007 10:53 AM (in response to Jeff Zacharias)
    I too, have been noticing that I cannot get directions from a number of locations including from my home. I thought it might have been just me or the "EDGE" connection, but unless the destination was down the block, I was getting the block.
    Iphone 8gb & Macbook, Mac OS X (10.5.1)
  • kward5046 Calculating status...
    Currently Being Moderated
    Jan 12, 2008 7:21 PM (in response to Jeff Zacharias)
    The issue for me is not the fact that google maps can't find certain address's it is that it will not give me driving directions. I have found two locations that google maps can plot and tell me everything about the locations but it can not receive driving directions for those two locations. I tried the reset and it found directions one time and then would not again even for the same two locations as it had just worked on.
    power book g4, Mac OS X (10.4.7)
  • trepess Calculating status...
    Currently Being Moderated
    Feb 6, 2008 6:56 AM (in response to kward5046)
    same issue for me. locations can be found, but driving direction between them "can't be found".
    iphone, Windows XP
  • MobileDev Level 3 Level 3 (565 points)
    Currently Being Moderated
    Feb 6, 2008 9:52 AM (in response to DaVBMan)
    Really not sure why Google would have it that way but I am sure there is a reason.


    Good question. Supposedly the answer goes like this:

    Google has a deal with NavTeq for the use of their data and routing whenever you request a map or driving instructions from Google Maps web version. (Might even be paying them.) However, NavTeq doesn't like the idea of any end user doing this directly. It would "drop" the value of their product.

    Enter TeleAtlas, who is okay with individual devices making API requests via Google for data. Thus they are the provider for client map programs such as are found on PDAs.
    Touchscreen laptop and industrial handhelds, Other OS
  • david_w_hutton Calculating status...
    I just noticed that I could not get directions when my start was the "current location" (as determined by cell and wifi nodes). But, when I switched the start location, it worked fine. So, I guess sometimes the "current location" may not be "precise" enough to work for the driving directions.
  • chuckstr89134 Calculating status...
    Currently Being Moderated
    Feb 19, 2008 7:24 AM (in response to david_w_hutton)
    I noticed this problem also and I have almost 500 business contacts in my iPhone contacts. I found the maps feature very handy when traveling from one customer to another and miss it very much now.

    I noticed the problem just after upgradeing to the 1.1.3 version of the iPhone software and I wonder if that is the problem. I have tried every fix I could find in several forums and nothinf helps. The only thing I have not tried is going back to the old iPhone software because I haven't found a way to do that. I did find one method but it said the phone would not function afterward so I didn't even consider that a viable option.

    Any further ideas would be greatly appreciated.

    Chuck Strickland
    Strickland Computer Services
    las Vegas, NV 89134
    iPhone, Wish I could afford a Mac

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.