10 Replies Latest reply: Feb 7, 2008 6:44 PM by Rev Ric
ernie goldstein Level 1 Level 1 (80 points)
not sure if this is the right board but for some reason i can not edit or add names to my address book anymore

imac, Mac OS X (10.5)
  • 1. Re: address book
    Topher Kessler Level 6 Level 6 (9,340 points)
    Try using "Disk Utility" (in the Utilities folder) to repair permissions on your boot drive. That might help. If not, try closing address book and moving the files "com.apple.AddressBook.abd.plist" and "com.apple.AddressBook.plist" from your home directory's ~/Library/Preferences/ to the desktop (to temporarily get it out of the way) and try again.
  • 2. Re: address book
    McDomi Level 1 Level 1 (10 points)
    I have the same problem and tried both of your suggestions. Unfortunately they didn't solve the problem.

    Any other ideas?
  • 3. Re: address book
    gunther95 Level 1 Level 1 (0 points)
    I am having the same problems with address book, amongst a myriad of others with leopard...ah reminds me of the days with windows...I won't jump on board so soon next time Mr. Jobs...
  • 4. Re: address book
    Gijs Level 1 Level 1 (25 points)
    Same here. All menu-items for adding new addresses are also greyed out. Tried restoring from Tiger-version, but that didn't help.
  • 5. Re: address book
    Gijs Level 1 Level 1 (25 points)
    To update on this topic. I tried re-installing Address Book with Pacifist: no success.

    Re-installing Leopard (Archive & Install) did the trick. Maybe I have to add that I first saved the folder Address Book in Library>Application Support in order to save my addresses and put that folder back after the re-installation of Leopard (replacing the newly installed version).

    Archive & Install is really fast and virutally risk-free, so fear of losing anything is not necessary. Of course you must have a recent backup for just in case. And don't forget to update tot 10.5.1 afterwards.
  • 6. Re: address book
    dingdangdawg Level 2 Level 2 (455 points)
    Yep, broken here too. Tried every fix suggested, and still cannot edit or add cards. Bummer.
  • 7. Re: address book
    gowry Level 1 Level 1 (0 points)
    Hello,

    I have the same problem on a g4/Powerbook with Leopard and latest patches installed. (10.5.1, upgraded from Tiger and everything worked while it was 10.5.0!)

    I found some strange behaviour on the system, though.

    After upgrading to 10.5.1 the following is one of the nasty bugs:

    - If I start the Addressbook.app from the Dock or Finder, it runs as user root and I can't edit or add new contacts. This is because of the permissions of the library files in ~/Library/Application Support/AddressBook/. They're user:user and mostly 0600, so no user, but only the owning user can read it.

    - If I start the Addressbook.app from the Terminal everything works fine and the process runs under the user uid, as it should.

    And somehow this happens to a lot of Applications. Hello Apple? Where's the magic in here?

    Cheers,
    Gowry.
  • 8. Re: address book
    nsmithcorp Level 1 Level 1 (0 points)
    I was able to use what you had mentioned to get the address book up and running again. I had to go in through terminal and manually change the permissions on the application preferences folder for address book. Once I did this launching from any location still allowed me to edit/add contacts. Hope this helps.
  • 9. Re: address book
    art2know Level 1 Level 1 (0 points)
    I'm having the same issue too. Running 10.5.1 on a MacBook Pro.

    The weird thing is that it happened all of a sudden. I thought I had tweaked a setting wrong, but it just came out of nowhere. Leopard has been buggy for me on this machine and my iMac G5.

    Here's hoping that 10.5.2 will take care of stuff like this.
  • 10. Re: address book
    Rev Ric Level 1 Level 1 (0 points)
    I'm new to apple...
    I'm having the same issues (not being able to edit address book on my iMac).
    What is go in through "Terminal"? I've tried from the dock and from apps... no luck.
    i don't have any problems on my MacBook Pro. Thanks for your time.