9 Replies Latest reply: Jan 14, 2008 5:30 PM by lamsdale
jhutch38 Level 1 Level 1 (0 points)
I just updated to iMovie '08 7.1 (506) and now I don't see any video in the viewer. I can hear the audio in the project, but the viewer remains blank. When I try to preview in Fullscreen it is blank as well, with the audio playing. I tried exporting the video, but what came up in the exported video looked like a capture from the top of the iMovie window. Does anyone know how to fix this?

Mac Mini, Mac OS X (10.4.10), iLife '08
  • 1. Re: No video in Viewer
    LensOne Level 1 Level 1 (0 points)
    Same problem here. I have a Mac Pro w/6GB RAM

    I have three events. The first two are working just fine which I imported a few weeks ago. I can still view the video with no problem.

    Today I imported a new event using the same video camera. Everything was working fine and I even exported a clip. Now I tried exporting another clip and all I get is a black video with audio playing using quicktime. This also happens in iMovie if I try to do any playback. Again this only happens with this event. The first two are still ok.

    What is going on with iMovie... I'm getting really frustrated.
  • 2. Re: No video in Viewer
    Bruno Lapeyre Level 1 Level 1 (0 points)
    Same strange issues on my side.
    Nothing in the viewer when I try to run a clip from the Project area... except when I am trimming a clip...
    The viewer is displaying correctly any clip found within the Library area...
    Full screen is displaying correctly both Project and Library clips.

    Clips were imported from some iMovie HD project to iMovie '08. Trashing iMovie preferences and the iMovie folder from my ~/Library + importing again the iMovie HD project + trying "Complete" and "Large" to import the iMovie HD project didn't help...
  • 3. Re: No video in Viewer
    LensOne Level 1 Level 1 (0 points)
    Well... I have been preparing for Leopard so I created a backup of all my files using BACKUP 3.0. I did a clean restore of the drive. Restored all my files and the video back to the drive. The video plays back now. It better not be an ongoing thing once I install Leopard.

    not sure what caused the problem... if someone figures it out let me know.
  • 4. Re: No video in Viewer
    seppl2008 Level 1 Level 1 (0 points)
    Same effect - no preview in viewer - just a blank screen no matter what the format of the input is.
    What does apple says to this a few month after the problem is publicly known and has shown here in the forum quite a few times?
  • 5. Re: No video in Viewer
    Jon Walker Level 6 Level 6 (17,630 points)
    Does anyone know how to fix this?



    I have experienced this is in two different situations. The first is when the "reference" media files become corrupt for some reason (i.e., source data frames are basically "indexed" by the creation of a number of "reference" movie files that provide a method for indirect addressing of the source data). In this case, deleting the thumbnail files and forcing iMovie '08 to re-generate them seemed to rectify the problem. The other problem I've had was the use of an event clip or project which contained a PSD (PhotoShop) compression format layer. In this case I simply switched to JPEG and PNG layers and the media would display properly.



  • 6. Re: Solution No video in Viewer
    jbraswell Level 1 Level 1 (0 points)
    Possible solution

    Go To HD > Library > Quicktime > Remove all non Apple Components (especially Perian)
    Restart computer

    It worked for me.
    Good Luck
  • 7. Re: Solution No video in Viewer
    Graham Lucas Level 1 Level 1 (45 points)
    I can confirm that just removing HD > Library > Quicktime > perian.component worked for me. Thanks jbraswell for the hint.
  • 8. Re: Solution No video in Viewer
    Matt C. Level 1 Level 1 (60 points)
    I don't see any perian components in my QT Library .... I have a couple Apple comp., some Flip4Mac, and 4 DVCPROHD, 1 1 DesktopVideo OUt and 1 FCP Uncompressed.

    Any thoughts?
  • 9. Re: Solution No video in Viewer
    lamsdale Level 1 Level 1 (0 points)
    Just removing the Perian component worked for me as well. Thanks for the tip jbraswell - saved me a lot of headaches.