Skip navigation
This discussion is archived

Macbook wont connect or detect my wireless internet no matter what i do

5404 Views 22 Replies Latest reply: Feb 21, 2008 8:23 AM by Sharp-man RSS
  • John Harkins Level 1 Level 1 (85 points)
    Hi Mike,

    I read the blog but still don't see why I should suspect the modem in this case. The symptoms the blogger was experiencing don't at all match what I am seeing. Again, all other laptops tested connect to this device without this trouble. Only the MacBook running Leopard fails and it just never connects at all. Hopefully my nephew will get the opportunity to try a few more access points in the coming days which may help establish a pattern.

    One other piece of info regarding this issue - the DSL service my nephew uses is 700Kb service and his line signal (not wireless signal) quality tends to be poor which results in pretty slow speeds at times. The reason I point this out is because Leopard always reports connection timeout as the problem. Since the modem provides an IP regardless of WAN connectivity issues, this shouldn't matter as far as establishing a LAN connection. But I wonder if Leopard is trying to talk on the WAN and not getting a reply before the network service is fully functioning and the error is somehow preempting the network configuration from finishing? Unfortunately, I don't have much time to work on this until possibly next week.
    MacBook, 2.2GHz Core 2 Duo, Mac OS X (10.5.1)
  • Victoria Moore Calculating status...
    John-

    I have the same "connection timed out" issue and I have the business-level high speed DSL - so it probably isn't it. I'm beginning to suspect the new Macbook itself, combined with Leopard, may be the issue. A friend of mine has an older Macbook that she upgraded to Leopard and does not have an issue connecting to password protected networks. I have tried resetting the router like others and this does no good. All other devices connect just fine (2 G4 powerbooks, airport extreme card in G5, IBM laptop, iPhone, Tivo).

    I'm still not getting any luck with answers, and I've been consulting with the best macheads I know. Argh!
  • John Harkins Level 1 Level 1 (85 points)
    I'm working on this right now. I just tried all 11 channels on the modem and reset the modem - still no success. The system log file reveals the following error messages:

    ... airportd[388]: Error: Apple80211Associate() failed -6
    ... SystemUIServer[89]: Error: airportd MIG failed = -6 ((null)) (port = 57231)
    ... SystemUIServer[89]: Error joining <network ssid>: Connection timeout (-6 timeout connecting)

    Earlier, when I tunred off the WEP password, it doesn't fail with connection timeout - but rather it just doesn't connect. In this case, the system log shows the same first two lines as above but the connection timeout line (third of above) doesn't print. Also, when I tried entering the WEP password incorrectly, the log correctly indicates that the password was invalid:

    ... airportd[384]: Error: Apple80211Associate() failed -11
    ... SystemUIServer[89]: Error: airportd MIG failed = -11 ((null)) (port = 57231)
    ... SystemUIServer[89]: Error joining <network ssid>: Invalid password (-11 unknown authentication)

    Very frustrating - but I see there are many new posts with similar problems. Still looking like a Leopard issue to me.

    Oh - and I was able to set up a computer to computer network between this MacBook and an older G4 iBook over wifi except I was only able to connect to the iBook from the MacBook and not the other way around. However, I didn't spend a lot of time trying to debug that. Just thought I'd mention this.
    MacBook 2.2 GHz, Mac OS X (10.5.1)
  • John Harkins Level 1 Level 1 (85 points)
    I found a fix for the problem with my nephew's MacBook and it turns out that Mike S. was partially right. The Westell 327 DSL modem that he has is quite old and there is a firmware update available for it. Note that although I had used the check for firmware updates in the modem settings before - apparently the web update feature in the modem was broken so it didn't find anything. However, I found this link:

    http://netservices.verizon.net/portal/site/msa/?epi_menuItemID=c567d167631f69212 4525d7253295c48&bookmark=helpitem&case=VersaLinkFix

    in the following forum:

    http://forums.macrumors.com/showthread.php?t=239062

    Note that you have to sign in to the verizon site first before the link above will work - then you can paste it into your browsers url field. If you're a long-time verizon customer experiencing similar problems - you may want to look for a firmware update to your modem - the link above may be a good starting point.

    So, it seems that something about the way wireless networking is done has changed over the years and that this MacBook does "new" wireless in such a way as to not play nicely with old WAPs. This may not be Apple's fault but I guess it's causing them (and some of their users) some headaches at the moment. I suggest those of you having similar problems check to see if your WAPs have a firmware update available to see if that fixes your problems. Remember to make a note of the original settings before updating your firmware (including DSL user names and passwords.)

    Good Luck.
    MacBook, 2.2GHz Core 2 Duo, Mac OS X (10.5.1)
  • acoaxet Calculating status...
    I am having the same issue. I have two separate MacBooks. Each machine is the same and runs OS 10.5.1. One machine connects flawlessly; the other will connect only intermittently. I brought the suspect machine to the Apple Genius and they replaced the airport card. Of course, the machine connected perfectly in the Apple Store. This did not fix the problem. They recommended reinstalling the Mac OS 10.5.1 which we have done and this has not fixed the issue. Both machines are configured identically and are using the same network which is an open, non-password protected WIFI.
    MacBook, Mac OS X (10.5.1)
  • grueda Calculating status...
    I think I solved, I've just received my new imac. Same problem, it doesn't recognize my wep password and then timeout. Solution: Go into network preferences, advanced, and in the airport tab I add my network and password configuration, in my case is WEP. And voilá! is working without problems!
    iMac 20. 2,4Ghz, Mac OS X (10.5.1)
  • Bonetorrent Calculating status...
    tried the above and it didn't work for me.

    this is for all of you with an actiontec router from verizon and a macbook that won't connect. after many hours, i am up an running.

    1. type http://192.168.1.1 into your base computer
    2. sign into your router. factory settings signin/pass are admin/password. some of the verizon techs set the password to password1
    3. go to wireless settings advanced
    4. select wpa and use an ascii password
    5. apply changes
    6. log on with mac to network and select personal WPA as network security

    this should get you up an running. just to keep my neighbors from trying to get onto my network, i also shut off the ssid.

    Message was edited by: Bonetorrent
    macbook black, Mac OS X (10.0.x), none
  • Sharp-man Level 1 Level 1 (55 points)
    I had just the opposite experience with my ActionTec MI424-WR router (firmware 4.0.16.1.56.0.10.7) on Verizon FiOS. My MacBook Pro (10.5.2), MacBook (10.5.2) and iPhone (1.1.3) would not connect using WPA on the ActionTec router. Once I changed it to WEP 64-bit, everything finally worked. I got the same "Connection timed out" messages under WPA.

    I guess I'll leave the router on WEP until I can save for a new Time Capsule...
    MacBook Pro Core 2 Duo, 2.16GHz, 3GB RAM, 120GB HDD, Mac OS X (10.5.2)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.