Skip navigation
This discussion is archived

Automator and Aperture in Leopard

5403 Views 22 Replies Latest reply: Jan 19, 2008 7:43 PM by Kerry M RSS
  • megalodon Calculating status...
    Currently Being Moderated
    Dec 14, 2007 4:57 PM (in response to palessi)
    My workflow also quit working with Leopard. And I also sent feedback to Apple. I was using a workflow to export metadata to a text file. I can use the export metadata function of Aperture in a pinch, but I'd rather not have to fix up the individual files long term.

    I was just looking into applescript as a workaround. I don't see a metadata export function supported at first glance. And of course with Applescript, there's never much in the way of documentation. I also don't know yet whether the Applescript will even work.

    At least I'm not alone with this problem.
    Macbook Pro, Mac OS X (10.5.1)
  • Malcolm Page Calculating status...
    Currently Being Moderated
    Dec 15, 2007 3:31 AM (in response to comfact)
    I also have this bug on my Intel mini, but not on my G4 PowerBook. I've reported it, but no response.
    Intel mini & G4 PowerBook, Mac OS X (10.5.1)
  • Adsy Calculating status...
    Currently Being Moderated
    Jan 3, 2008 11:44 PM (in response to Aaron Perry-Zucker)
    The automator actions are missing in Leopard for some reason, leading to the Null value problem. The actions are all located in the Automator installer. If you open the package, you can find the actions and copy them all to /Library/Automator. Most things then work, although I still have a problem with 'Choose Album' and with the naming profiles.
    MacBook C2D 2.0GHz, Mac OS X (10.5.1), 2GB/120
  • Kerry M Calculating status...
    Currently Being Moderated
    Jan 16, 2008 12:10 PM (in response to Adsy)
    Thanks, but where is the "Automator installer"? I don't see that on my Leopard DVD.
    MacBook Pro, 2.33 GHz, Mac OS X (10.5.1)
  • bhh48 Calculating status...
    Currently Being Moderated
    Jan 18, 2008 2:58 AM (in response to Kerry M)
    What has happened is that the Aperture Automator actions have been removed from /System/Library/Automator on installing Leopard (probably with Archive and Install).

    I've been having this same issue and couldn't for the life of me figure out what was wrong.
    The hint provided by the previous poster put me on the right track.

    The Aperture Automator actions are located in the the Aperture application.

    Steps to take for repairing the situation:

    1. Open a Finder window and navigate to /System/Library/Automator
    2. Open a second Finder window and navigate to /Applications/Aperture
    3. Execute a Show package Contents of Aperture (you should get a third Finder window).
    4. Now navigate to Contents/Library/Automator
    5. Select everything (.definition and .action) in that folder
    6. Copy with option drag to the folder in the window created in step 1.
    You will be asked for the administrator password.
    7. Close superfluous windows.
    8. Start Automator and enjoy.

    In short: copy the contents of /Applications/Aperture.app/Contents/Library/Automator to
    /System/Library/Automator

    I've done this and no longer get the NS Null error messages. I can now access the actions and will see if they actually work some time in the next few days.

    Cause: Apple Leopard Installer.
    Remedy: Apple should have warned beforehand that something like this would happen and should have provided the solution.

    happy automating

    Berend
    iMac 2.16Ghz Intel Core 2 Duo 20", Mac OS X (10.5.1), 3Gb
  • Janet Taylor Level 2 Level 2 (155 points)
    Currently Being Moderated
    Jan 18, 2008 6:21 AM (in response to bhh48)
    thank you!
    MBP Core 2 Duo 2.33 GHz 3GB RAM, Cintiq 21, Mac OS X (10.5.1)
  • comfact Calculating status...
    Currently Being Moderated
    Jan 19, 2008 1:03 PM (in response to bhh48)
    Thanks for that relatively easy and painless fix to this problem that has been going on for months. Apple's silence on this one has been very frustrating. Makes me think their feedback form is tied straight to a spam filter.
    Mac OS X (10.4.8)
  • Kerry M Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jan 19, 2008 7:43 PM (in response to bhh48)
    Thank you very much! This worked for me. I have a multistep import action that adds boilerplate text in various metadata fields, names the files sequentially, moves them to a different hard drive, and imports them by reference. It's now working perfectly! Thank you!
    MacBook Pro, 2.33 GHz, Mac OS X (10.4.10)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.