Skip navigation
This discussion is archived

Indented Contacts

2077 Views 6 Replies Latest reply: Jan 31, 2008 3:35 PM by Tom Lambotte RSS
paulmanke Calculating status...
Currently Being Moderated
Jan 14, 2008 4:53 PM
Any reason why some of my contacts are indented a space or so? Im just wondering why.
MacPro, Mac OS X (10.5.1)
  • NickWillSava Calculating status...
    Currently Being Moderated
    Jan 14, 2008 5:24 PM (in response to paulmanke)
    Probably just mis-entering some as:

    John Doe

    instead of:

    John Doe.

    Check your contact's name for accidentally unnecessary spaces.
    Macbook Pro, Mac OS X (10.5.1)
  • phatduckk Calculating status...
    Currently Being Moderated
    Jan 23, 2008 2:51 PM (in response to paulmanke)
    I have the exact same issue.... Some of my contacts are indented and some are not. I looked thru all my contacts in Address Book last night and ensured that there's no leading whitespace in any first or last names.

    even on the phone itself I'll go over to edit an indented contact and in the contact's edit screen neither the first or last name's have a leading space character.

    On the phone itself I even cleared (deleted) an indented contact's first and last name, retyped it & saved it to no avail.

    I don't get it... i'm gonna have to do thru my address book DB and see if there's any random characters.

    This has me pretty stumped
    MacBook, Mac OS X (10.5.1)
  • phatduckk Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 23, 2008 4:52 PM (in response to paulmanke)
    OK i figured this out. my solution is not elegant or quick but it worked for me.

    I'm not at my main machine so i did all this on my iPhone so I'm guessing it took longer than if i would have done this on my laptop.

    From my experience it looks like the problem was with the "prefix" field in my Address Book (Contact List). On my Mac ALL of my contacts' prefixes looked like they were blank. The prefixes on ALL my contacts looked blank on my iPhone as well. On the iPhone all the prefix fields had the little muted, grey "prefix" label. so to the naked eye, the were blank.

    In a nutshell the solution was: add a prefix to an indented contact, save contact, edit same contact to remove the prefix, save the contact again...

    The step by step process looks like:

    1) goto your Contact List on your iPhone
    2) find an entry that is indented
    3) now, go to edit the entry's name

    note) the "prefix" field looked blank on my iPhone...

    4) enter something, anything into the prefix field
    5) save the contact with this BS prefix in it
    6) edit the contact's name again
    7) delete the BS you just entered in prefix field
    8) save the contact again

    repeat this for every contact that looks indented.

    Please note: my contacts on the iPhone are listed by First Name Last Name. I believe using this this non-default setting helped me notice this issue.

    My guess is that somehow during syncing addresses from Yahoo or Plaxo one of these 3rd parties shoved some strange character into the prefix field that Address Book on the Mac ignores but the iPhone displays it as a space character.

    Hopefully syncing my iPhone to my Mac does not re-introduce the "indent".
    MacBook, Mac OS X (10.5.1)
  • Jay Batson Calculating status...
    Currently Being Moderated
    Jan 24, 2008 2:42 PM (in response to paulmanke)
    I've got this problem in spades. I have 1,500 (exactly, today) contacts in my address book, and a substantial quantity (probably in excess of 20%) of them show up as indented on my iPhone. And the problem gets worse daily. I suspect that within a month, nearly all contacts will have this problem.

    I find the latest discussion (by phatduckk) interesting as to what the actual data is that causes the indent to appear. This doesn't, however, explain how contacts get this way.

    I have a workaround that's different than his, which is slightly quicker if you want to go and fix a whole bunch of them. (In fact, I can't get his to work.) (I'm a Mac user; I don't know if my workaround works on Win/Outlook):
    - Export the contact to a vCard file
    - Delete the old contact in Address Book
    - (re-)Import all the new contacts into Address Book

    The newly imported contact will appear correct.

    I note, however, that these things re-appear. It must have something to do with some sort of sync activity, e.g. either sync to .mac, or sync to Plaxo, or sync between the iPhone and my Mac.

    I really like my Plaxo, but for testing purposes, I'm going to turn off Plaxo sync for a little while, fix as many of my contacts as I can, and see if they re-break. I'll come back and update this discussion posting if I see any change.
    8GB iPhone, MacBook Pro 2.6GHz, 4GB memory, Mac OS X (10.5.1)
  • Tom Lambotte Calculating status...
    Currently Being Moderated
    Jan 31, 2008 3:35 PM (in response to paulmanke)
    A client of mine just had the same issue with his Mac and iPhone. On his iPhone random contacts are slightly indented. On his Mac, in his Address Book, there is afiled called maiden name, which is not used at all, but is there. If we edit the card and remove the maiden name filed, the first phone number is deleted!?

    Any ideas on this?
    MacBook, Mac OS X (10.5.1)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.