Skip navigation
This discussion is archived

Firewire Drives Won't Mount Under 10.5

2713 Views 10 Replies Latest reply: Feb 18, 2009 10:32 AM by DavidSteward RSS
DavidSteward Level 1 Level 1 (0 points)
Currently Being Moderated
Dec 6, 2007 8:31 AM
Not sure if this is the correct section. If not, where should I post it?

I have a four bay firewire box, it is divided into two sections each with a master and a slave. I have a DVD burner as a master with a hard disk as a slave and a CD burner with a hard disk as the slave. When these are connected to my 24” iMac I can only see the CD or DVD burners, but the hard disks fail to mount. They worked, but not perfectly, under 10.4.10 on my G4 mac.So is this a Leopard problem.

I have reset the PRAM, switched off unplugged and waited before trying again and tried alternative cables. Can I get firmware updates anywhere? Any other suggestions would be welcome.

System profiler gives the following info

911G:

Manufacturer: Oxford
Model: 0x0
GUID: 0xD04B4450142409
Maximum Speed: Up to 400 Mb/sec
Connection Speed: Up to 400 Mb/sec
Sub-units:
911G Unit:
Unit Software Version: 0x10483
Unit Spec ID: 0x609E
Firmware Revision: 0x137
Product Revision Level: QSG9
Sub-units:
911G SBP-LUN:
Capacity: 584.2 MB
Removable Media: Yes
BSD Name: disk1
Mac OS 9 Drivers: No
Partition Map Type: Unknown
S.M.A.R.T. status: Not Supported
Volumes:

Thanks
David
Mac G4, PowerBook G3, iSight iMac G5 & 24" iMac, Mac OS X (10.5)
  • glassfish Calculating status...
    Currently Being Moderated
    Feb 10, 2008 2:02 PM (in response to DavidSteward)
    In preparation for Leopard, I reformatted my laptop's hard drive and installed Mac OS X 10.5.1 fresh. As soon as I plugged in my trusty 500GB external WD MyBook Pro (trying both Firewire 400 and 800 on my MacBook Pro 17"), I get the following alert:

    "Disk Repair
    The disk "500GB" was not repairable by this computer. It is being made available to you with limited functionality. you must back up your data and reformat the disk as soon as possible. OK"

    Keep in mind, I run Disk Utility and "Repair Disk" and "Repair Permissions" religiously every week and have had no issues while running under Mac OS X 10.4.11. My other laptop running the 10.4.11 doesn't report any issues with the drive at all - only when I plug it into this one running 10.5.1.

    Is there a firmware update for this drive? Is this Apple's issue? I have another LaCie Firewire drive and it works flawlessly even under 10.5.1.

    Right now, I can't even use the drive as it's Read Only (due to the error).

    In system logs:

    Feb 9 19:02:59 Cam diskarbitrationd69: unable to repair /dev/disk4s3 (status code 0x00000008).

    /dev/rdisk4s3: fsck_hfs run at Sat Feb 9 19:00:41 2008
    /dev/rdisk4s3: ** /dev/rdisk4s3 (NO WRITE)
    /dev/rdisk4s3: QUICKCHECK ONLY; FILESYSTEM DIRTY

    /dev/rdisk4s3: fsck_hfs run at Sat Feb 9 19:00:41 2008
    /dev/rdisk4s3: ** /dev/rdisk4s3
    /dev/rdisk4s3: ** Checking Journaled HFS Plus volume.
    /dev/rdisk4s3: ** Checking Extents Overflow file.
    /dev/rdisk4s3: ** Checking Catalog file.
    /dev/rdisk4s3: Incorrect number of file hard links
    /dev/rdisk4s3: ** Checking multi-linked files.
    /dev/rdisk4s3: ** Checking Catalog hierarchy.
    /dev/rdisk4s3: ** Checking Extended Attributes file.
    /dev/rdisk4s3: ** Checking volume bitmap.
    /dev/rdisk4s3: ** Checking volume information.
    /dev/rdisk4s3: ** Repairing volume.
    /dev/rdisk4s3: ** The volume 500GB could not be repaired.

    The drive is reported to be "Ok" when running Disk Repair on other machines not running Leopard. As a test, I just "upgraded" my wife's laptop to Leopard and now I have the same issue on that machine.

    Help.
    MacBook Pro, Mac OS X (10.5.1)
  • skiphunt Level 1 Level 1 (10 points)
    Currently Being Moderated
    Feb 14, 2008 7:21 AM (in response to glassfish)
    I'm having this exact same problem. It started right after an upgrade to Leopard on a 2GHz DP desktop. My Lacie said this same thing.. that it wasn't repairable. So, I started copying to my 750GB Maxtor.. backed everything up to it. NOW it says it's non-repairable TOO!!!! My freakin' backup. My MacBookPro upgrade went somewhat smooth.... but it's an Intel Dual core. My G5 has been a three day nightmare so far. I can't tell how ****** I am at Apple right now. I thought this would happen with the first version of Leopard.. so I waited for the first couple of updates.

    BIG mistake. EVERYTHING was working perfectly under Tiger and now I'm looking at loosing MOST of my data and my Samsung display is now having intermittent corruption with checkboard patterns, etc. What did I do to deserve this Apple?!!!!
    2Ghz DP G5, Mac OS X (10.5.2)
  • jeffreykeen Calculating status...
    Currently Being Moderated
    Feb 16, 2008 9:29 PM (in response to skiphunt)
    I'm having this same problem on a 15" Powerbook running 10.5.1, but not on a 15" Mac Book Pro running 10.5.1. There is nothing wrong with the firewire drives, really, it's just the faulty computer thinks there's something wrong. Whatever I do, they won't mount using that setup.

    To make sure the firewire port wasn't messed, I booted the Powerbook off of a Tiger install disc, and made sure (through disk utility) that the drives were functioning correctly. They were. It's definitely something screwy with that Leopard install. It's weird, too, because for me it just happened out of nowhere.

    No idea what the solution is, I've tried everything -- resetting NVRAM, PRAM, doing reset-all in open firmware, repairing disk permissions, resetting the PMU... I'm out of options. I think I might just have to reinstall.
    MacBook Pro, Mac OS X (10.5.1)
  • D. Fraser Level 3 Level 3 (560 points)
    Currently Being Moderated
    Feb 16, 2008 10:09 PM (in response to DavidSteward)
    Try putting the HDDs in the master bays and the CD/DVDs in the slave bays and see if that mounts them.

    D.
    3 MacPros (06,07), MBP, TiBook, G4/Intel Minis, iPods/iPhone, Mac OS X (10.5.2)
  • D. Fraser Level 3 Level 3 (560 points)
    Currently Being Moderated
    Feb 16, 2008 10:18 PM (in response to glassfish)
    There might be an incompatible firmware chipset with the WD and Leopard. Leopard changed alot of things dealing with FireWire and USB. This is more of a problem for WD than Apple. The only thing I would suggest to you is to copy everything off of that drive to another drive and then re-partition/zero-out erase of the WD (GUID partition scheme).
    3 MacPros (06,07), MBP, TiBook, G4/Intel Minis, iPods/iPhone, Mac OS X (10.5.2)
  • norbertm Level 1 Level 1 (0 points)
    Currently Being Moderated
    Feb 17, 2008 9:36 AM (in response to DavidSteward)
    I have a maybe related problem with multiple firewire drives (an which cost me the bigger part of this weekend after trying to migrate to Leopard):

    The following setup worked under Tiger:
    iMac G5 (1.8 G) with 2 firewire drives on each of the two firewire (400) ports. (total of 4 fw drives)
    One drive has an oxford 911 chipset
    one has an Assmann AB-PENR chipset
    two have (identical) initio board.

    The problem: Only one of the initio drives (the one powered up first) mounts.

    As soon as I have both of them online System Profile can no longer display the FW information

    However if I disconnect the invisible drive I get the message that a device was not properly unmounted.

    Changing the configuration (e.g. daisychaining all 4 drives) does not help, although the daisy chain works well on a MacBook Pro (Tiger 10.4.11).

    Connecting one of the initio drives via USB allows me to mount both.
    When only the two initio drives are connected (via firewire) they mount Ok.

    In case it matters:
    The oxford, assman and one initio FW disks have APM partition schemes.
    The other initio disk has an MBR scheme. (I`m going to fix this ASAP)


    Since I rely a lot on these external drives, I cannot move to Leopard before that issue is resolved.

    Hope someone can track down the problem based on this information.

    Thanks

    Norbert
    MacBook Pro 2.33, Mac OS X (10.4.10)
  • MysticMaven Calculating status...
    Currently Being Moderated
    Mar 19, 2008 2:48 PM (in response to DavidSteward)
    I am so tired of this problem. A few years ago I had an external firewire enclosure that stopped mounting via firewire. Then I got a WD Mybook. Eventually it stopped mounting (Both of these on a Powerbook). I got the Mybook replaced, and I now have a 24" iMac with 10.5 on it.

    Time Machine has been working fine with it, up until a few days ago. Now all of a sudden IT WON'T MOUNT!!!!

    Throught 3 HDDS and 2 Macs, I think the core of this problem is OSX and it's not being fixed!
    24" iMac 2.8Ghz, Mac OS X (10.5.2)
  • strawberrius Calculating status...
    Currently Being Moderated
    Apr 5, 2008 6:02 PM (in response to MysticMaven)
    same issue here.
    ever since i upgraded to 10.5.2 all of my firewire drive are intermittent.

    bumski.
    has anyone figured out the deal yet?
    macpro 3.0 quad
  • myaka Level 4 Level 4 (2,450 points)
    Currently Being Moderated
    May 10, 2008 12:21 PM (in response to DavidSteward)
    FWIW -- the text of an OS X problem report sent to Apple:

    I am currently, successfully, burning data to a DVD-RAM disk in an Optiarc AD7170A burner mounted in an EZQuest BOA firewire enclosure on my Quicksilver (2002) Dual 1GHz G4. The burner connects to a powered firewire hub which is the only firewire device connected directly to the computer. Other firewire devices connected to the hub are powered down.

    The point is that I am successfully burning data in Tiger 10.4.11; and I have had to boot into Tiger because Leopard 10.5.2 tells me that the device I am trying to mount is damaged and is being provided with limited functionality -- that I should copy data from it and repair it. The problem is that neither DiskUtility (in Leopard) nor the very latest Diskwarrior (4.1) can effect a repair in Leopard (even when the machine is booted from the DiskWarrior disk). Reformatting the disk and attempting to reuse it offers the same result: the same message about a damaged disk that needs to be repaired.

    I have tried other disks -- same result. I have connected the burner directly to the computer -- as the only firewire device. I have removed all other (USB) peripherals. I have started in Open Firmware to reset NVRAM. I have updated the Optiarc burner's firmware to its latest official iteration (1.04). I have placed DVD-RAM disks in the Pioneer DVR-107D drive mounted internally to the native ATA bus in the computer; they read just fine there (that drive cannot burn DVD-RAM, alas). But the same disks are reported as defective when mounted in the external enclosure. Only booting into Tiger enables the use of DVD-RAM disks in the external drive.

    I have read, on Apple's Discussion Boards, of others with firewire issues in Leopard that are cured by booting into Tiger. It sounds like something has changed in Leopard that affects firewire functionality.

    I can add that, in Leopard, when using this firewire device, I must frequently force-quit DiskUtility or DiskWarrior and other open apps -- subsequently often finding myself forcing a shutdown of the computer and restart in order to obtain a working finder and other applications. Then I restart from DiskWarrior and repair the drive to make sure the filesystem on my startup drive has not been damaged, and repeat the entire process again. I repeated the process many times before trying Tiger, which I am booted into at the moment, now 1.84GB into 2.92GB worth of file copying to a DVD-RAM disk that I have been unable to copy to in Leopard.
    Quicksilver 1GHz x2, Mac OS X (10.5.2)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.