Skip navigation
This discussion is archived

Installed Tiger... all but Mail ok.... no accounts show up?

655 Views 5 Replies Latest reply: Nov 6, 2005 8:25 AM by Douglas Gerull RSS
Douglas Gerull Calculating status...
Currently Being Moderated
Nov 6, 2005 8:25 AM
I bit the bullet after my last database path wipeout on 10.3 and just installed my Tiger OS X Server. Websites (2) work fine! AFP lets my accounts log on fine. WHen I send mail to my local server from my .mac account it gets returned (reason: 550 5.7.1 No such recipient).

I notice that there are no accounts in teh Mail -> Maintenance -> Accounts list, used to be in 10.3 when you enabled Mail in Workgroup manager the accounts "showed up" in the mail server list.... I am thinking I do not understand a lot but perhaps the missing account names and paths and/or my lack of certainty where my two domain names should go for mail purposes are a specific hint as to my hangup(s)?

Any help much appreciated I have (had) a very simple little system and run OS X server nicely for over two years but it is obvious I was just lucky and this is beyond me at the moment...
  • Alan Sill Calculating status...
    You ned to check the /etc/imapd.conf file and make sure that the admin user is specified as cyrusimap instead of cyrus there. Then stop and start mail again.

    If that doesn't do it, you need to stop mail again reconstruct the /var/imap area by hand as follows;

    cd /var
    sudo mv imap imap.old.(date)
    sudo mkdir imap
    sudo /usr/bin/cyrus/tools/mkimap
    sudo chown -R cyrusimap:mail imap
    sudo -u cyrusimap /usr/bin/cyrus/bin/reconstruct -i

    You should see the accounts start to populate within Server Admin even before the last step above finishes, while it is in progress, and should also see lots of messages indicating that the individual folders for your users have been found and repopulated.

    Once this is done, start mail. The only side effect of this fairly extreme step is that all messages will be flagged as unread., a fairly minor price to pay for not losing the messages.
  • Alan Sill Level 1 Level 1 (0 points)
    For incoming mail: make sure your IMAP or POP boxes are checked in Server Admin under "Settings - General" and that if you use IMAP, there is a non-zero number of connections allowed.

    For outgoing mail: in Server Admin, have you checked the "Enable SMTP" and "Allow incoming mail" buttons? The domain name there should be the part after the "@" in your e-mail address for which you want to receive mail. The host name is the host for your SMTP server (most likely the fully-qualified name of the computer hosting your OS X server).

    Not sure why you are getting a "No such recipient" message. You might check that mail is enabled under Workgroup Manager for your account, but if it were not, I don't think your account infor woudl appear in teh Server Admin "Maintenance" window.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.