1 2 3 Previous Next 34 Replies Latest reply: Apr 25, 2008 4:43 AM by Matthew St Go to original post
  • 15. Re: Spotlight died on me
    BlackNTan Level 1 Level 1 (0 points)
    I've had this exact same issue... icon is still there, turns blue, but the menu doesn't drop down .... found that a quick 'killall Dock' does the trick for this issue (from Terminal).
  • 16. Re: Spotlight died on me
    zimon Level 1 Level 1 (0 points)
    had the same issue, but there was no .metadataneverindex file on my drive. so i deleted the .Spotlight-V100 file only and it worked fine. (the control panel privacy thing didn't work)

    thanks to all of you, eureka, indexing right now!
  • 17. Re: Spotlight died on me
    Terrell Smith Level 4 Level 4 (3,010 points)
    Thanks, GW! I have had the same trouble, so I tried your steps in your post above
    http://discussions.apple.com/mailpost.jspa?messageID=6063604
    and it looks like Spotlight is re-indexing again.

    Terrell
  • 18. Re: Spotlight died on me
    Terrell Smith Level 4 Level 4 (3,010 points)
    OK, here's the story. I tried your suggestions, Spotlight indexed for a while, but never picked up my Mail folders. They do not show up in any search, even though they are checked in Spotlight Preferences.

    Then I went to an Apple Store and talked with a genius. He spent _2 hours_ trying to make it work. Here's some of the things he tried:
    checked the whole HD for errors using Diskwarrior
    dragged the whole HD to Spotlight's Privacy window and out again
    re-installed OS X 10.5.1
    used Terminal to turn off indexing, then turn it back on
    In Terminal, deleted the Spotlight index, then re-indexed
    He did the same things in Terminal you suggested

    NOTHING worked.

    He finally gave up, and asked another genius. They conferred for a while, then we tried the following:

    In Terminal, type:
    mdimport /Users/yourusername/Library/Mail (yourusername is whatever it is on your machine - an easy way to do this is first type "mdimport" (without the quotes), then drag the Mail folder from your user Library onto the Terminal Window.

    The mdimport command adds whatever you add to the index.

    Then wait while Spotlight indexes the Mail folder.

    Now Mail is able to search if I search on "Entire Message" in "All Mailboxes" - but still not individual mailboxes.

    The genius told me I need to do the same thing with each of my mailboxes to get the index up to date (even though we dragged the whole Mail folder over, so I'm not sure why that is, but I'll try it anyway). They are Users/yourusername/Library/Mail/Mailboxes

    There seems to be a bug in Spotlight (which is what Mail uses to do its search), which does not allow Spotlight to add content properly.

    If you are having the same problem, please contact Apple and let them know:
    http://www.apple.com/feedback/macosx.html
  • 19. Re: Spotlight died on me
    John H Level 3 Level 3 (845 points)
    running in terminal


    sudo mdutil -i off /

    then

    sudo mdutil -i on /

    which turns off and on again index got things going
  • 20. Re: Spotlight died on me
    Terrell Smith Level 4 Level 4 (3,010 points)
    John, I'm glad it worked for you, unfortunately, it did not work for me. I tried it several times, Spotlight runs for a little while, but still does not pick up my Mail messages.

    After spending two hours with a genius at the Apple Store, we were able to get it to pick up a few more things in Mail, but it still does not find anything at all when searching "Entire Message" in any mailbox.

    What it does do now is find a few things when searching "Entire Contents" in "Every Mailbox."

    There is something seriously wrong with Spotlight for me.
  • 21. Re: Spotlight died on me
    John H Level 3 Level 3 (845 points)
    Might want to hold the horses until 10.5.2 comes out
  • 22. Re: Spotlight died on me
    Terrell Smith Level 4 Level 4 (3,010 points)
    Hi John,

    Everyone is putting so much hope in 10.5.2 for fixing things, I'm sure there will be disappointment.

    Yes, I hope it will fix things, but I doubt if it will. Although there seem to be others who are having the same Spotlight problems I'm having, it doesn't seem to be an avalanche of people. My guess is that 10.5.2 will fix things most people have been complaining about. But we'll see. Can't speculate, just hope.
  • 23. Re: Spotlight died on me
    Mark Jenkinson Level 2 Level 2 (285 points)
    Thanks for the help with this one everyone. I had the same problem and even spoke to a Apple Tech Support guy who after trying a few basic tests told me I had to do an "Archive and Install". I wasn't in the mood for that, so I kept looking.

    Basically, the key for me was:

    sudo rm .metadataneverindex

    For some reason, even though there were no locations indicated in the "Privacy" tab of the Spotlight preferences, this .metadataneverindex file remained on the drive, and prevented Spotlight from working. And no matter how many time I reset spotlight, or told it to force re-index, or used Spotless to disable and then enable Spotlight... nothing worked. It took me a while before I noticed this invisible file, and finally, after deleting it, Spotlight worked again.

    Message was edited by: Mark Jenkinson
  • 24. Re: Spotlight died on me
    Terrell Smith Level 4 Level 4 (3,010 points)
    When I try that, I get "No such file or directory"
  • 25. Re: Spotlight died on me
    Terrell Smith Level 4 Level 4 (3,010 points)
    Unfortunately, 10.5.2 did not change anything. Even did a re-install from the combo-updater.
  • 26. Re: Spotlight died on me
    Urs Gruetzner Level 1 Level 1 (0 points)
    Same Problem here: Spotlight does not search, no spinning wheel nothing. Tried the hints here with mdutil on/off, trashing the Spotlight file. Spotlight seems to have reindexed (V100 File was again here, aftere a while) but Spotlight refuses to work. I did this on X.5.2

    As I had freshly installed I made a complete reinstall and tried Spotlight before doing any updating to X.5.2.

    Same mess, Spotlight is dead
  • 27. PLEASE SEND FEEDBACK TO APPLE
    Terrell Smith Level 4 Level 4 (3,010 points)
    You are not alone. Spotlight is broken. It won't search Mail messages correctly.

    So far, nothing I've tried has given me the ability to search Mail messages under "Entire Message" for any mailboxes.

    "From," "To," and "Subject" searches work, but not "Entire Message."

    Doing *mdimport ~/Library/Mail* in Terminal adds current messages to an "Entire Message" search for "All Mailboxes" but does not help an individual mailbox search, nor search any new messages.

    _Here's what I've tried:_

    Fixed permissions with Disk Utility

    Re-booted (many times)

    Dragged the hard drive icon to Spotlight's Privacy window, then off again

    Installed 10.5.2 from Software Update

    Re-installed OS X 10.5.2 from the combo update

    Ran Diskwarrior 4.1 Rev. 42, did both a rebuild of the startup HD, and Files

    _In Terminal:_

    Turned off indexing, then back on again
    sudo mdutil -i off /
    sudo mdutil -i on /

    Turned off indexing, deleated the Spotlight index, turned indexing back on again
    sudo mdutil -i off /
    sudo rm -r .Spotlight-V100
    sudo mdutil -i on /

    Deleated the never index file (there was none)
    sudo rm .metadataneverindex

    Tried to rebuild the index
    sudo mdutil -E /

    Added Mail to the index
    mdimport ~/Library/Mail
    Received an error message: mdimport[188:807] * Failed to decode 8bit data, treating as binary

    Doing mdimport ~/Library/Mail adds messages to the "Entire Message" "All Mailboxes" search, but no new messages get indexed.

    _Genius at Apple Store:_

    I spent two hours with a Genius at an Apple Store, he tried everything he knew, plus all of the above, plus asked another Genius for help. They were unable to fix Spotlight's search.

    _Apple Discussions:_

    I have asked this question on Apple Discussions. Several others are experiencing the same problem. So far no one has been able to come up with a solution. The number of people with this problem is growing:

    Topic : Spotlight does not search Mail messages
    http://discussions.apple.com/thread.jspa?threadID=1366101
    Topic : Search "Entire Message" returns "0 Found" in mailboxes
    http://discussions.apple.com/thread.jspa?threadID=1341832
    Topic : Spotlight died on me
    http://discussions.apple.com/thread.jspa?threadID=1226645
    Topic : I can't search through my inbox!
    http://discussions.apple.com/thread.jspa?threadID=1387827
    Topic : Leopard's Spotlight doesn't search Mail messages
    http://discussions.apple.com/thread.jspa?threadID=1219030
    Topic : Mail Search
    http://discussions.apple.com/thread.jspa?threadID=1347387
    Topic : Mail Won't Search
    http://discussions.apple.com/thread.jspa?threadID=1204827
    Topic : Search does not work
    http://discussions.apple.com/thread.jspa?threadID=1254966
    Topic : Mail search not working
    http://discussions.apple.com/thread.jspa?threadID=1289253
    Topic : Unable to Search Mailbox
    http://discussions.apple.com/thread.jspa?threadID=1232504
    Topic : Why is Search in Mail.app busted?
    http://discussions.apple.com/thread.jspa?threadID=1403758
    Topic : Mail Search comes up empty
    http://discussions.apple.com/thread.jspa?threadID=1378473
    Topic : Search "Entire Message" not working with Smart Mailboxes?
    http://discussions.apple.com/thread.jspa?messageID=6548355&#6548355
    Topic : Mail searches yield no results! Smart mailboxes also yield no results!
    http://discussions.apple.com/thread.jspa?threadID=1395508
    Topic : 10.5.2 Mail.app search still not working (Entire Message)
    http://discussions.apple.com/thread.jspa?threadID=1389466


    Obviously, something is broken.

    *PLEASE SEND FEEDBACK TO APPLE:*
    In Mail, under Mail in the Menu, use "Provide Mail Feedback" to send your feedback to Apple. This sends general information to Apple about your Mail set-up, which should help them get this resolved.

    If you do not wish to send them general info from Mail, you can use this link to send feedback:
    http://www.apple.com/feedback/mail.html

    Terrell
  • 28. Re: PLEASE SEND FEEDBACK TO APPLE
    David Branner Level 1 Level 1 (5 points)
    Was there ever a solution found to this? I, too, have tried every solution proposed in this thread (although I'm in 10.4.11, not 10.5).

    I had this problem a couple of months ago, and then (overnight) it "magically" fixed itself. I thought perhaps the change of date had something to do with it.

    Today, suddenly, I find I have the same problem. I'm not happy about the fact that it's 1 April - someone's joke? Thinking that the change of date might have something to do with /etc/daily , I've run that but had no luck. I've also set the date ahead manually but it makes no difference.
  • 29. Re: PLEASE SEND FEEDBACK TO APPLE
    Terrell Smith Level 4 Level 4 (3,010 points)
    Hi David,

    Many things have been tried, some solutions seem to work for some people some of the time. But the one which seem to actually fix the problem are an "archive and restore," or a complete restore of your hard drive from backup.