Skip navigation
This discussion is archived

Search in iCal in 10.5.2 Not Working?

7434 Views 23 Replies Latest reply: Mar 3, 2009 4:48 PM by hellyski RSS
1 2 Previous Next
Dave Marsh Level 2 Level 2 (325 points)
Currently Being Moderated
Feb 16, 2008 2:14 PM
I upgraded to 10.5.2 this week and was posting a future event in iCal (several years out) and wanted to see if it posted correctly. So, I clicked in the search field in the upper right corner of the window and typed in the text I entered for the event. The columnar listing area appeared at the bottom of the window, but displayed no contents. I then manually went to the future date and found the event just fine.

In Tiger when I entered text in the search field, the columnar area at the bottom of the screen actually listed the results of my search, but I can get no results in Leopard.

I searched this forum for comments on this issue and found a similar thread from last fall, but none of the suggestions made at that time work for me in 10.5.2.

Can anyone here confirm that iCal is not displaying search results for them? I'd like to know if it's my system, or the application itself.

I find it's working on my upgraded G5 iMac, but not on this new Intel iMac.

Thanks for listening...
2.8GHz 24" iMac w/4GB RAM/750GB HD, Mac OS X (10.5.2)
  • Ferd II Level 7 Level 7 (23,235 points)
    Currently Being Moderated
    Feb 16, 2008 2:48 PM (in response to Dave Marsh)
    Dave,

    Find works for me in iCal 3.0.2.

    Try refreshing the iCal plist file.

    Quit iCal and find the com.apple.iCal.plist file in your Macintosh HD/Users/yourusername/Library/Preferences Folder. Drag the file to your Desktop, log out/in or restart and check iCal for normal behavior.

    Another troubleshooting step which has been successful for many users has been to quit iCal and drag Macintosh HD/Users/yourusername/Library/Application Support/iCal/Sources Folder to the desktop. Once again restart iCal and check for normal behavior. I removed this file from my system because I found that it only contains remnants of iCal 2.0.X.

    Additionally, you may try deleting any cache files in your Macintosh HD/Users/yourusername/Library/Calendars Folder.

    If iCal works properly after either step you can discard the files/folders on the Desktop.

    ;~)

    IMac 24"/2.4GHZ/320GB/SD/AP/BT; iMac G4 17 80 GB 1.25GHZ; iMac DV SE Graphite, Mac OS X (10.5.2), 20GB iPod Color, iPod shuffle, iPhone
  • Jorn Ake Calculating status...
    Currently Being Moderated
    Feb 25, 2008 6:46 PM (in response to Dave Marsh)
    Dave Marsh:

    Thanks for following through with this thread and giving your final solution. It cured my 10.5.2 iCal ills as well. Saved me a lot of hair pulling. iCal is only my life blood. So thanks again.
    IMac 24" 2.8Ghz, Mac OS X (10.5.2)
  • nigbo Calculating status...
    Currently Being Moderated
    Mar 15, 2008 5:42 PM (in response to Dave Marsh)
    It sounded great: I had (have) the same problem and trief your solution: no change, still the same problem. Did I forget something? Did you restart your computer at any point? Some other idea?
    HN.
    MBP17, Mac OS X (10.5.2)
  • Hendo08 Calculating status...
    Currently Being Moderated
    Mar 16, 2008 3:32 AM (in response to Dave Marsh)
    All very good stuff and I've tried everything I can, but Spotlight (and the search on ICAL itself) still refuses to show any results. MY Macbook, also running 10.5.2 has no problems at all. Anybody got any other ideas?
    Thanks.
    Imac 24, Mac OS X (10.5.2)
  • Thierry Rayna Calculating status...
    Currently Being Moderated
    May 15, 2008 4:04 AM (in response to Dave Marsh)
    I had a similar problem. The symptoms were:
    - Search in iCal did not work at all (no result, what so ever, returned)
    - Search in Spotlight worked (the same search that did not return anything in iCal would return To-Dos and events in Spotlight)

    I started by backing up and restoring, but this did not work.

    I then read a lot about potential solutions involving quite extreme things (such as reinstalling Leopard). I then found out that I could solve this issue by simply exporting each calendar and then reimporting them without deleting anything.

    For example, I had a "Home" calendar that I exported. I then chose "Import" then picked the exported "Home" calendar and chose my "Home" calendar in iCal as destination calendar. I feared that I would end up with duplicate events and to-dos, but no, iCal is smart.

    Once this is done, my search in iCal started to work again and searching items on this calendar would return correct results (as did spotlight).

    I then did the same with all my other calendars, and voilà!

    Hope this helps
    MacBook Pro 2.4 GHz, Mac OS X (10.5.2)
  • Michel_IT Calculating status...
    Currently Being Moderated
    Jul 2, 2008 2:27 PM (in response to Thierry Rayna)
    My iCal search doesn't work.
    10.5.4 (but also previously).
    None of these techniques worked out.
    I confirm that creating a new account from scratch (admin)does not resolve the problem. So it is really at root level.
    Destroying the spotlight index folder (root level), thus forcing full reindexing, doesn't resolve the problem either.

    Hope someone can help.
    I really hope Apple will enhance iCal on many aspects(the version 2 was much better).

    Michel
    MacAir, Mac OS X (10.5.4)
  • lubner Calculating status...
    Currently Being Moderated
    Jul 9, 2008 4:57 AM (in response to Dave Marsh)
    I'm having the same problem. I just updated my OS to 10.5.4 on an Intel MacBook Pro. I can look at my current calendar and type titles of items in view and nothing shows up in the search column. Let's hope for a remedy soon.
    MacBook Pro 17", Mac OS X (10.5.4)
  • Easyofff Calculating status...
    Currently Being Moderated
    Jul 13, 2008 11:17 AM (in response to lubner)
    Just go to system preference, spotlight and uncheck ical, quit ical and restart ical.
    Imac 24, Mac OS X (10.5.4)
  • lsnewton Calculating status...
    Currently Being Moderated
    Aug 4, 2008 7:55 PM (in response to Easyofff)
    Thank you, Easyofff

    More simple then that is impossible. And it works!!!
    Mac OS X (10.5.4)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.