Skip navigation
This discussion is archived

X11 fails to start, enters an infinite failure lop

2622 Views 9 Replies Latest reply: Jun 5, 2008 2:56 PM by Conor Hughes RSS
vrai Calculating status...
Currently Being Moderated
Feb 18, 2008 12:49 PM
Hi, I've been trying to get X11 to work with various applications (such as NX machine) but I cannot get the X11 server to start. I'm using the X11 package off the Leopard install disk but it seems to be missing support for a required switch "-launchd". Whenever I try to start the process the Console gets spammed with a never ending procession of the following error ...

18/02/2008 20:22:40 org.x.X11[[211]] X11.app = /usr/X11/X11.app/Contents/MacOS/X11
18/02/2008 20:22:40 org.x.X11[[211]] Unrecognized option: -launchd
18/02/2008 20:22:40 org.x.X11[[211]] use: X [:<display>] [option]
18/02/2008 20:22:40 org.x.X11[[211]] -a # mouse acceleration (pixels)
18/02/2008 20:22:40 org.x.X11[[211]] -ac disable access control restrictions
18/02/2008 20:22:40 org.x.X11[[211]] -audit int set audit trail level
[[snipped]]
18/02/2008 20:22:40 org.x.X11[[211]] -version : show the server version.
18/02/2008 20:22:40 org.x.X11[[211]] Quartz modes:
18/02/2008 20:22:40 org.x.X11[[211]] -fullscreen : run full screen in parallel with Mac OS X window server.
18/02/2008 20:22:40 org.x.X11[[211]] -rootless : run rootless inside Mac OS X window server.
18/02/2008 20:22:40 org.x.X11[[211]] -quartz : use default Mac OS X window server mode
18/02/2008 20:22:40 org.x.X11[[211]] Options ignored in rootless mode:
18/02/2008 20:22:40 org.x.X11[[211]] -size <height> <width> : use a screen resolution of <height> x <width>.
18/02/2008 20:22:40 org.x.X11[[211]] -depth <8,15,24> : use this bit depth.
18/02/2008 20:22:40 org.x.X11[[211]] -refresh <rate> : use a monitor refresh rate of <rate> Hz.
18/02/2008 20:22:40 org.x.X11[[211]] Fatal server error:
18/02/2008 20:22:40 org.x.X11[[211]] Unrecognized option: -launchd
18/02/2008 20:22:40 org.x.X11[[211]] AbortDDX
18/02/2008 20:22:40 org.x.X11[[211]] Quitting Xquartz...
18/02/2008 20:22:52 com.apple.launchd[[89]] (org.x.X11[[211]]) Exited with exit code: 1

I wasn't expecting the Apple version of X11 to cause problems so I'm somewhat confused by the whole thing. Has anyone encountered this before or have any ideas of what I can do to fix the problem? One of the main reasons I bought a Mac was because of the X11 support and its disappointing that it's so buggy.
Mac Pro, Mac OS X (10.5.2)
  • W.J. Llope Level 4 Level 4 (3,270 points)
    Currently Being Moderated
    Feb 18, 2008 12:55 PM (in response to vrai)
    in the new X11, 'launchd' support is built-in.
    you do not want a DISPLAY environment variable set anywhere (in your e.g. .cshrc)
    you should not need to start X11 manually (from your applications/utilities folder or the dock) either.

    not sure if that helps, but the leopard X11 is quite different than tiger's.... cheers
    MBP 17/2GB/7200/matte, dualG51.8, G4 450, TiBook, some G3s, & a Quadra!, Mac OS X (10.4.8)
  • W.J. Llope Level 4 Level 4 (3,270 points)
    Currently Being Moderated
    Feb 18, 2008 12:57 PM (in response to vrai)
    other things to try...

    try running /usr/X11/X11.app instead of /Applications/Utilities/X11.app. that should remove the launchd functionality...

    to prevent X11 from setting $DISPLAY, you could try
    sudo launchctl unload -w /System/Library/LaunchAgents/org.x.X11.plist

    cheers
    MBP 17/2GB/7200/matte, dualG51.8, G4 450, TiBook, some G3s, & a Quadra!, Mac OS X (10.4.8)
  • baltwo Level 9 Level 9 (59,145 points)
    Currently Being Moderated
    Feb 18, 2008 12:58 PM (in response to vrai)
    You might want to post to or peruse the Unix forum under OS X Technologies where X11 gurus hang out.
    G4 450 MP Gigabit 1.5 GB RAM/17" Flat-panel 1GHz iMac, Mac OS X (10.5.2), (also 10.4.11/9.2.2)
  • Karlsbakk Calculating status...
    Currently Being Moderated
    Feb 19, 2008 5:02 AM (in response to baltwo)
    I keep seeing the same with 10.5.2. All installed from scratch, no upgrades. I've tried the hints I've found but still no luck
    PowerBook G4 1.33, Mac OS X (10.5.2)
  • Pickle_Man Calculating status...
    Currently Being Moderated
    Feb 19, 2008 9:13 PM (in response to vrai)
    I had this same issue and solved it by installing this update:

    http://trac.macosforge.org/projects/xquartz/wiki/X112.1.4

    -PM
    Mac OS X (10.5)
  • Paul Bernard Walp Calculating status...
    Currently Being Moderated
    Mar 24, 2008 12:36 PM (in response to Pickle_Man)
    Thanks, Pickle_Man, I installed that up-date and now X11 works.
  • cthulhu11 Calculating status...
    Man, this has been frustrating:

    My MBP was running 10.4.latest, then I installed 10.5.1. Utilities/X11 launched and worked as usual. Applied 10.5.2 - same. Applied 10.5.3, and launching Utilities/X11 continues to work great there.

    Feeling secure in the workitude of 10.5.3, I upgraded my G5 to 10.5.1 via the same media, and Utilities/X11 worked as usual. I let Software Update install everything available, taking it to 10.5.3, and I got the X11 launch failures described here. See the bit about not explicitly starting the server first, I tried just firing up a client, which hung indefinitely as launchd tried to invoke the server, which logged the familiar complaint about not knowing the -launchd switch. The server X11.app package reported being 2.0. I did an archive+install back to 10.5.1, and Utilities/X11 worked as before, let SU have its way with the G5, and had the same failures.

    I had a legacy bit in .cshrc

    if ( ! $?DISPLAY ) then
    setenv DISPLAY
    endif

    that I commented out, with no improvement. Moved .cshrc out of the way altogether, no improvement.

    I applied the abovementioned unofficial Xquartz 2.1.4 server update package, and now the X11 server starts automagically when I invoke a client -- a local client at least.

    I was about to try going back to 10.5.1 again and looking for offline installers to go to 10.5.2 then 10.5.3 incrementally instead, to better duplicate the path that the MBP took, when I decided to try the above package instead. Now that I go back and look at the MBP, I see that X11 reports version 2.1.1, not the 2.0 that I had on my G5. I know that sometimes version numbers for PPC and x86 aren't always in sync (I've seen that with Mail.app) but this seems really fishy to me. My best guess is that something is awry in Apple's 10.5.3 combo installer, and that going to 10.5.2 first then 10.5.3 might well work as expected. Those of you who've also experienced these problems: which exact release of 10.5 were you running, and how did you get there? PPC or x86?

    But, I got it working and xv seems happy (I've yet to find a native equivalent that's anywhere near as efficient to use) so I'm calling it good for now.

    I initially tried calling Apple and as expected got a tech who was friendly but who didn't really grok X. She had me repairing disk permissions in Disk Utility, booting in safe mode, trashing my Caches directory, etc, but never got close to something that would actually work.
    MBP2.2, G51.6, Mac OS X (10.5.3), I want my PDP
  • Conor Hughes Calculating status...
    I have all but confirmed that this is an issue with the 10.5.3 combo updater. I have a MacBook Pro that I was trying to Erase & Install 10.5 from. On updating from Software Update from 10.5.1 to 10.5.3, X11.app failed just like it did for you folks. This happened for several attempts to reinstall. However, after reading this thread I reinstalled again and used the standalone updaters to upgrade manually from 10.5.1 to 10.5.2 and then to 10.5.3 and X11 works fine.

    Here are the links to the updaters I used:

    10.5.x to 10.5.2: http://www.apple.com/downloads/macosx/apple/macosx_updates/macosx1052comboupdate .html
    10.5.2 to 10.5.3: http://www.apple.com/downloads/macosx/apple/macosx_updates/macosx1053update.html

    Note that the updater from 10.5.2 to 10.5.3 is the "delta" one, not the combo updater.
    Macbook Pro, Mac OS X (10.5.3)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.