Skip navigation
This discussion is archived

Camera will not save pictures to phone after snapping photo

81187 Views 117 Replies Latest reply: Sep 8, 2008 4:11 AM by dellthecomputer RSS
  • brettpeters Calculating status...
    This option worked for me. I was surprised to see the exact file you deleted -- f1b43d3b3ecf259a3626c13a8b0cebd8ba513117.mdbackup -- listed, but removing it and restoring made everything work again.

    Thanks for the solution - while I'm not happy that this happened, at least there is a workaround.
    PowerBook G4 17" 1.67, Mac OS X (10.4.11), 2GB RAM, 100 GB 5400 internal, oodles of FW 400 external
  • drixll Calculating status...
    this solution worked until i went to update my phone with my prior settings.

    now no more camera roll photos saving again.

    itunes is updating now, but it didn't say anything about a fix for the photos - just more ways to buy music and video.


    way to go on ignoring the issues and seeing how many dollars you can lure out of my pocket.
    Windows XP
  • cinemaone Calculating status...
    I too now have this problem after upgrading to 1.1.3

    I took it to the SF flagship and the guy said that I probably just didn't do it right, he even looked at my phone and said I was still on 1.1.2.
    I said, NO, I'm not. and showed him the problem. He said, ohh you should just re-install it. "How do I do that?" I asked.
    He said he'd been working all day and hadn't had a chance to upgrade himself so he wasn't sure. I said, ok, bye. And then he said try setting an appointment up at the Genius Bar, but after looking at comments on this board, I'm a little afraid of losing all my information.

    I tried solution one and it worked until I restored the phone.
    Now onto solution, something else or another.
    iBook, Mac OS X (10.4.11)
  • RobKapteyn Calculating status...
    When I did a backup and restore on 1.1.2 -- it temporarily fixed this problem, until I downloaded the next set of photos from my phone.
    I then upgraded to 1.1.3, hoping that it would fix the problem -- it did NOT.

    Now, with 1.1.3, even the backup and restore does not give a temporary fix !
    iPhone/PowerbookG4, Mac OS X (10.5.1)
  • Rsturg Level 1 Level 1 (0 points)
    I keep seeing posts where people are trying backup and restore. I don't beleive this will solve this problem, UNLESS you can go in and delete some files in the backups before you restore. As I stated before, this problem is or was quite easy for me to solve, I just didnt restore from backup, I treated it as a new phone. The only thing I lost was my prefs (there arent but about 10 of them really), and I don't use notes, but you would loose them. (one of the reason I dont use them is becasue they don't sync, and I cant get them off the phone)
    iphone, Windows XP
  • ohnmeiss Calculating status...
    This worked: jkeegan, thanks!

    The file named f1b43d3b3ecf259a3626c13a8b0cebd8ba513117.mdbackup seems to be the key, removing it (after backing up the entire directory) - and resetting the iPhone as in Method #2. The last step is to restore through iTunes. No loss of contact pics, etc.
    PowerMac MDD (Dual 1.0 Ghz), Mac OS X (10.4.11), iPhone 1.1.3
  • sln100508 Calculating status...
    Thank you tons, my friend. Your method was both painless and successful. Your instructions were clear, concise and accurate. There was no data loss and I'm up and shooting again. Thanks for your help!
    iphone, Other OS
  • Ed Gonzales2 Calculating status...
    Thanks...#2 worked for me

    I just have to remember not to delete my photos after i upload them to iphoto
    Mac mini, Mac OS X (10.4.10)
  • Malama Pono Calculating status...
    Thank you. Your Option 4 worked for me. It appears that the camera does not like to have the photos removed from the camera roll. Keep at least one in there when transferring out the pictures from the iPhone. Why? I don't know.
    Dell Inspiron 700m, Windows XP Pro, 8 GB iPhone, 1 GB Shuffle, iPod Nano, iPod
  • Mattdaddy71 Calculating status...
    I can't believe I just manually deleted all the photos I took over the weekend, 1 by 1 because I was scared to death that I'd have to go through all this restoring / backing up / synchronizing crapola again! Yikes! Please fix with a new update asap! I'm BEGGING !!!
    MacBook Pro, Mac OS X (10.5.1), FRUSTRATED iPHONE USER !!!
  • Raquel M. Calculating status...
    I had this problem for the first time today after having used my iphone camera without any issues since the day the iphone was launched. While the work-arounds suggested here work (at least two of them did for me and now just to be on the safe side I will always leave one picture in the iphone roll), it is unacceptable that Apple would let this go on for this long without so much as acknowledging it. Is there any way we can file a formal complaint with Apple or is blowing the whistle our only option?
    iMac late 2006; MacBookPro Late 2007; iPhone, Mac OS X (10.5.2)
  • Daniel Drysdale Calculating status...
    I recently updated to 1.1.3 (unlocked, jailbreak) and started experiencing the same problem. I rarely ever used the camera so I don't know if it just started in 1.1.3.

    Anyway it was really annoying me so I started poking around via ssh and found that if I ran the camera application manually as root then it seemed to work just fine.

    /Applications/ --launchedFromSB --role Camera

    I could take photos and look at them, they wouldn't appear in iPhoto though. If I ran the camera as the "mobile" user which is the normal setting the problem would occur and I would see an error message each time I took a photo

    /Applications/ --launchedFromSB --role Camera
    CGImageDestinationCreate destination parameter is nil

    This lead me to think that the problem is related to permissions as the behavior differed depending on the logged in user.

    using the "find" command to see what files were changed today...

    find / -mtime -0

    I found that there were what looked to be photo files in the directory


    Now the camera preferences file has a reference to "DCFLastDirectoryNumber" and a value of "100", looking at the Media directory for the mobile user showed no "100APPLE" directory so I created the following directory


    mkdir /private/var/mobile/Media/DCIM/100APPLE

    and changed the ownership to the mobile user

    chown mobile:wheel /private/var/mobile/Media/DCIM/100APPLE

    and now the camera is working again.....

    I also noticed that the parent directory


    was not writeable by the mobile user so if the directory was deleted then the problem would occur again so I made in writeable by all

    chmod 777 /private/var/mobile/Media/DCIM

    Yes I know this poses a security risk, but then the only users on the system are root and mobile and I want them both to be able to write to the DCIM directory.

    After the fix I was able to take photos, import them into iPhoto and delete the originals with no problems.

    Note: This fix is maybe 10 minutes old so no guarantees. Also you need ssh access to the phone so only people with hacked phones can use this fix....

    I hope it works for some of you at least...

    Macbook Pro, Mac OS X (10.5.2)
  • Malama Pono Level 1 Level 1 (10 points)
    I thought my problem was solved but my camera roll crashed again a week later. I went and got a replacement phone from Apple. I sync' d everything except the photos for fear of losing my camera again.
    Dell Inspiron 700m, Windows XP Pro, 8 GB iPhone, 1 GB Shuffle, iPod Nano, iPod
  • davrauch Calculating status...
    your technique TOTALLY worked for me. just deleted that **** file from the directory that you meantioned, resynced and my camera works again!

    its magic.
    thanks much,

    dell craptop, Windows XP Pro
  • Joseph Warfield Calculating status...
    I just started having the same problem- I snap a picture on my iPhone- it makes the snap sound- recedes to the album in the lower left corner and when I go to the pictures taken in the album- just an outline of the picture is there and it is blank. No NEW photos exist... Additionally, I have tried to restore from iTunes but it did not work or fix the problem rather. Any help would be appreciated. I use the camera feature all of the time and could really use some help. Thanks very much! Joe W.
    iPhone 8GB, Mac OS X (10.4.11)
1 2 3 4 5 ... 8 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (2)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.