5 Replies Latest reply: Feb 28, 2008 10:41 AM by Mark Kujawinski
MyMac.cc Level 1 Level 1 (0 points)
I cannot transfer my photos via Wifi from my Nikon P3 to my Mac with Leopard.
But the worst thing is that the USB transfer don't work either.

Any idea to fix it?

PD : All Nikon soft is up to date and the transfer (via wifi and USB), before install Leopard, worked perfectly.

Several, Mac OS X (10.5), G5 PPC, iMac 2gen, MacBook Pro, iBook
  • 1. Re: Nikon P3 WiFI Don't  work
    dobree Level 1 Level 1 (0 points)
    I have had the same problem transfering photos from my d70 using usb. I get the message that jpg are not recognised. I can however drag them across but it is very slow. I have not yet found a software update to sort this out.
  • 2. Re: Nikon P3 WiFI Don't  work
    Ekapon Level 1 Level 1 (35 points)
    My Nikon Coolpix S7c can't connect through the WiFi to my PowerBook too. Luckily there's no problem with the USB and Image Capture.

    Message was edited by: Ekapon
  • 3. Some suggestions with Image Capture
    Dr. Smoke Level 9 Level 9 (56,585 points)
    I've run into this problem with my Nikon Coolpix 880 and Image Capture under Leopard on my Power Mac G5. I've not tested it on my MacBook.

    Symptoms: I connect the camera via its USB cable to my Apple Pro keyboard. I connect the camera to its AC charger (I have the Nikon EH-21 charger for their EN-EL1 rechargeable batteries). I then turn on the camera. Image Capture launches. If I select the Download All button, the images take forever to download and are usually corrupted. Under Tiger and earlier, the images downloaded immediately and without fault.

    I've been able to work-around the problem by changing the procedure above as follows:

    1. Delete all existing preferences related to Image Capture and the camera. You'll find these in your Home > Library > Preferences folder and your Home > Library > Preferences > ByHost folder. Examples of some of the file names I deleted include:

    com.apple.ImageCapture2.xxx.plist
    com.apple.ImageCaptureApp.xxx.plist
    com.apple.ImageCaptureApp.plist
    com.apple.ImageCaptureCamera.xxx.plist
    com.apple.ImageCaptureExtension2.xxx.plist
    com.apple.Type3Camera.plist

    where xxx is an alphanumeric string. Some of these are obsolete preferences for prior versions of Image Capture.

    2. Connect the camera to the USB port on the computer instead of the keyboard.

    3. Instead of Download All, select the Download Some… button. Put the resulting window in List view and wait until all of the fields — except Date — are populated. This can take a long time. Date sometimes populates, sometimes doesn't, but be sure you see the preview image and the other data for all the images in the camera. When the list is complete, Select All, then click Download.

    Even with the changes above, I sometimes have to try it a couple of times to get it to work. This includes deleting the current Image Capture preferences. I'll quit Image Capture, turn off the camera, wait a short while, turn the camera on again, and it will work. Go figure.

    There are no clues I can find in Console to help.

    I suspect this is a bug in Image Capture and plan to file an Apple Bug Report. I'll cite this topic in my bug report so they can see the other reports y'all have filed.

    I'm also planning to:

    • Buy a CF Card Reader. I've read good reviews of the Sandisk Extreme USB 2.0 Reader on Amazon, including reviews from Mac users, so I'll probably buy it. Mounting the card as a disk vs. from within the camera (which has never appeared on the desktop) may be the best bet in the near term.

    • Update the firmware in my camera. There's a firmware update available from Nikon, but as I'd never encountered the problems it addresses, and the camera has always worked flawlessly — both as a camera and with Image Capture in Tiger and earlier versions of Mac OS X — I'd taken a "if it ain't broke…" approach to the firmware update.

    Hope this helps. Good luck!

    Dr. Smoke
    Author: Troubleshooting Mac® OS X
  • 4. Re: Some suggestions with Image Capture
    markymark557 Level 1 Level 1 (0 points)
    DR smoke, you are pretty smart can you help my G4 ?
  • 5. Re: Nikon P3 WiFI Don't  work
    Mark Kujawinski Level 1 Level 1 (0 points)
    ?