Skip navigation
This discussion is archived

Phantom non existent external monitor on Mac book pro

11235 Views 16 Replies Latest reply: May 29, 2010 9:56 AM by monogodo RSS
1 2 Previous Next
Ian J Grant Level 1 Level 1 (5 points)
Currently Being Moderated
Mar 6, 2008 2:45 PM
Hi all, whenever I open my mac book pro, or wake it from sleep, the screen turns blue and it auto-detects a monitor that is not attached - a generic VGA display - the image at the following URL displays when an external monitor is NOT attached:

http://ellington.tvu.ac.uk/images/displays.png

I have to click 'detect displays' between 8 and 14 (sometimes more) times to trigger another detect routine that always changes to reflect the actual state of monitors.

I have a cinema display and when connected to the MBP - on start-up or awaking from sleep, the MBP often fails to detect the connected monitor and yet displays the same display status as above a generic VGA display - click 'detect displays' 8-14 times and it detects the cinema display. Whenever the machine / display sleeps, it seems to be a lottery as to whether the true display status is retained or whether the MBP detects the phantom monitor, blackens the cinema display and requires the (getting very tedious now) detection routine to get back to what's expect. At that point, all windows have resized and shifted position. I've described the problem to several in-store genius's with no obvious answer. I did not do a clean install from Tiger, but wonder if it would've helped.
What do you reckon? Hardware failing or some strange software problem?
Thanks in advance, Ian Grant
Mac Book Pro, Mac OS X (10.5.2), 2.16 ghz
  • neuroanatomist Level 7 Level 7 (31,685 points)
    17" CD MBP, iPodTouch, Mac OS X (10.4.11),  since the ][e
  • Kidde Calculating status...
    Same problem on my MacBook Pro (10.5.2).

    Also tryed to reset PRAM, didn't help.

    Best regards, Fredrik
    MacBook Pro, Mac OS X (10.5.2)
  • dprado Calculating status...
    Currently Being Moderated
    Mar 18, 2008 5:44 AM (in response to Kidde)
    Same here with a MBP 10.5.2. No matter how many times I click on "detect Displays" nothing changes. If I attach an external monitor, it is not detected, since the phantom monitor is there. Removing the external monitor makes the screen go blue as if it detected the change, but the phantom monitor is still there on the display list. Never seen it happen on Tiger
    MBP, Mac OS X (10.5.2)
  • cal6n Calculating status...
    Same problem here. I'm on a 1st gen 2 GHz MBP with a 256 MB ATI X1600. I get it with a 19" widescreen LCD using the Apple DVI/d-sub; my InFocus projector or my Edirol V4 using the Apple DVI/video adapter.

    I can usually solve the issue with a combination of "detect displays"; "gather windows" & "turn on/off mirroring".

    I've tried trashing preferences, reinstalling Tiger and Leopard and, even though I know it's largely voodoo, repairing permissions. Nothing has helped, except only sleeping my machine, not turning it off, and only plugging and unplugging my adapter when my machine is fully awake.
    Mac Pro 2.66 Octo, 15" 2.0 MBP, 15" 1.67 G4 PB, 1.4 G4 Cube (tri-boot), Mac OS X (10.5.2)
  • Soonerprod Calculating status...
    Currently Being Moderated
    Apr 24, 2008 9:26 PM (in response to cal6n)
    The only solution that I have found is to shut down the computer, connect the display, power up the display, press the power key and close the MBP before the chime. This will cause the computer to start up with the external monitor as the main screen.

    Hopefully Apple will come up with a more elegant solution to this problem.
    15"MBP 2.4ghz, Mac OS X (10.5.2)
  • cal6n Level 2 Level 2 (265 points)
    Not really a solution as I generally need to use both screens.

    When I'm using a projector, I need the desktop on the MBP screen but, when I'm using an external monitor, I want my desktop on that.

    It must be said, however, that I haven't seen a phantom monitor since 10.5.3 was released a couple of days ago. It's early days yet, though...
    Mac Pro 2.66 Octo, 15" 2.0 MBP, 15" 1.67 G4 PB, 1.4 G4 Cube (tri-boot), Mac OS X (10.5.2)
  • cal6n Level 2 Level 2 (265 points)
    Currently Being Moderated
    May 31, 2008 12:57 PM (in response to cal6n)
    Scratch that last observation. It's just as bad as ever. Maybe even worse...
    Mac Pro 2.66 Octo, 15" 2.0 MBP, 15" 1.67 G4 PB, 1.4 G4 Cube (tri-boot), Mac OS X (10.5.2)
  • Matt 32E Calculating status...
    Just piling on with the same issue - just started this morning, with my most recent update being the MobileMe installation for 10.5.4. For what it's worth, the phantom display ("VGA Display") indicated has never been connected to this computer, and an external display hasn't been used in over a year. (It was a Sony LCD Panel connected via a DVI connection.)

    Macbook Pro 15.4-inch, 1.83GHz, 1 GB RAM
    MacBook Pro, Mac OS X (10.5.4)
  • MNield Calculating status...
    Hello,

    Did you ever resolve this issue? I have precisely the same problem; I connected an external display once, about six months back and now my Powerbook (10.5.6) detects the phantom monitor every time. Like you I have tried trashing every related plist file, reset PRAM, NVRAM, OPen Firmware, deleted AppleDisplay.monitorPanels directory and rebooted.

    It is so annoying having the mouse disappear off whatever edge of the screen I configure the phantom monitor to reside.

    Input much appreciated if indeed you fixed it.

    Marc
    Powerbook G4 1.67, Mac OS X (10.5.6)
  • Antonius Gan Calculating status...
    Currently Being Moderated
    Mar 27, 2009 3:00 PM (in response to MNield)
    Has anyone ever resolved this problem?

    Ran into this problem last week, and still haven't been able to find out what happened and how to get rid of the extra "VGA Display".

    I've tried trashing com.apple.preference.displays*.plist, and all the windowserver.plist files, but still the extra monitor is there.

    Message was edited by: Antonius Gan
    MacBook Pro, 2.2 GHz, Mac OS X (10.5.6)
  • chip.r Level 1 Level 1 (30 points)
    You can add me to the list of people having the problem. I've had it for some time on my first generation MBP with intermittent frequency. I've searched from time to time to see if there is a solution but no luck. It looks like I'm not alone and this problem seems to be persistent.

    Any thoughts? Is it hardware? Software? I've started to think it may be a hardware short inducing a false detection on the external port.

    Chip
    iMac G5, MacBook Pro, 30GB iPod, 8GB iPhone, Mac OS X (10.5.6), .Mac
  • mike_lyman Calculating status...
    Currently Being Moderated
    Feb 24, 2010 8:22 PM (in response to chip.r)
    Yesterday I found the same problem. I disconnected from a Dell Projector and then later that night I noticed that my computer still showed two monitors. I'm still able to connect to an external monitor and it will detect it. However, immediately after disconnect the phantom display is back.

    A little annoying because I'm always having application windows open on that phantom display.

    Also I noticed that when I plugged into the projector the color was off significantly, as if there was a bad connection. I tried a variety of connectors and connected my laptop to a variety of different external monitors and all of them work flawless except for the Dell Projector. (I didn't try it on another projector because I only have the one.)

    My conclusion is somehow when I disconnected from the projector I hadn't fully shut down or gone to sleep or my computer was in the middle of a disconnect when I closed the lid and this interruption as my computer transitioned from 2 displays to 1 created the phantom display. Hope to see a solution to this.

    Thanks
    MBP 2.4 GHz Intel Core 2 Duo, Mac OS X (10.6.2), 4 GB 667 MHz DDR2 SDRAM
  • John Heffernan Level 1 Level 1 (0 points)
    Seems like a hardware issue. I just started to have it on an iMAC G5, like many others.
    MacBook Pro, Mac OS X (10.6.2)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.