Skip navigation
This discussion is archived

iMac: Random waking from sleep

3152 Views 8 Replies Latest reply: Mar 20, 2008 11:13 AM by JPM-PL RSS
Brad Hagen Calculating status...
Currently Being Moderated
Jan 6, 2008 3:12 PM
I have a new 2.4 Ghz 20" iMac with Leopard installed. Lately my computer has been waking from sleep at random intervals throughout the day, even when the computer is not touched. I have an especially difficult time at night because the bright screen wakes me up. Most of the time it will wake up when I enter the room, almost like there is some sort of motion detector in the iMac.

I went into the system preferences and the only related thing I could find was "Wake for Ethernet network administrator access" which does nothing for my problem.

Am I just crazy or is there some way to make it less "sensitive" from waking from its sleep mode?

Thanks!
20" iMac 2.4 Ghz, Mac OS X (10.5.1)
  • CLpwner Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jan 6, 2008 3:33 PM (in response to Brad Hagen)
    I'm not positive about this but here is my experience:

    When I had my Dell I would walk into the room and the mouse sensitivity was set very sensitive and my bouncing of the floor just by walking would wake it up. Check to see if your mouse settings for the sensitivity.

    Hope this helps
    iMac aluminum, Mac OS X (10.5.1), 20" 2.0Ghz, 1GB of memory, 250GB HD
  • Edward NC Level 1 Level 1 (105 points)
    Currently Being Moderated
    Feb 19, 2008 1:36 PM (in response to Brad Hagen)
    I've got the same issue. Except my iMac won't automatically go to sleep, either.
    iMac 24" (2008) 2GHz / 2Gb / 500 Gb, Mac OS X (10.5.2)
  • JPM-PL Level 1 Level 1 (40 points)
    Currently Being Moderated
    Feb 26, 2008 1:45 PM (in response to Brad Hagen)
    My iMac has the same symptoms.

    here are some entries from the system log

    26/2/08 12:48:17 AM kernel System Sleep +(I put it to sleep manually)+
    26/2/08 1:00:08 AM kernel System Wake +(woke up unexpectedly without any reason)+
    26/2/08 1:00:08 AM kernel AirPort: Link Up on en1
    26/2/08 1:00:08 AM kernel AppleYukon2: 00000000,00000000 sk98osx_dnet - recovering from missed interrupt
    26/2/08 1:00:14 AM kernel AppleYukon2: 00000000,00000000 sk98osx_dnet - recovering from missed interrupt
    26/2/08 1:00:32 AM kernel System Sleep +(I put it to sleep manually)+
    26/2/08 8:22:45 AM kernel System Wake +(I woke it manually by pushing the USB mouse)+
    26/2/08 8:22:45 AM kernel USB caused wake event (EHCI)
    26/2/08 8:22:45 AM kernel AirPort: Link Up on en1
    26/2/08 8:22:45 AM kernel AppleYukon2: 00000000,00000000 sk98osx_dnet - recovering from missed interrupt
    26/2/08 8:22:50 AM /System/Library/CoreServices/loginwindow.app/Contents/MacOS/loginwindow[725] Login Window Application Started
    26/2/08 8:22:51 AM kernel AppleYukon2: 00000000,00000000 sk98osx_dnet - recovering from missed interrupt

    I can't find any rational reason.

    1. I've checked "System Preferences / Energy Saver" "Schedule..." - no schedule
    2. No wake on LAN selected.

    3.
    HD/Library/Preferences/SystemConfiguration/com.apple.AutoWake.plist
    and
    HD/Library/Preferences/SystemConfiguration/com.apple.PowerManagement.plist
    deleted and automatically recreated.

    4. crontab checked - no scheduled tasks.

    No other ideas.

    Today I set the automatic wake to 8AM. Tomorrow I'll disable it. I will report results.

    regards
    iMac, Mac OS X (10.5.2), Intel 2.8
  • JPM-PL Level 1 Level 1 (40 points)
    Currently Being Moderated
    Mar 2, 2008 12:15 AM (in response to JPM-PL)
    Did not help. After disabling auto wake / sleep iMac woke up at 1:00 himself. The problem is not solved yet.
    iMac, Mac OS X (10.5.2), Intel 2.8
  • CodLBi Level 3 Level 3 (720 points)
    Currently Being Moderated
    Mar 6, 2008 11:33 AM (in response to JPM-PL)
    Have you tried to deselect t Ante and Post Meridian (AM-PM)?

    Apple Menu>System Preferences>Time and Date.

    The energy settings use 24 hour annotation.

    (There is no need to run the crons in Leopard I believe)
    MBP C2D 15" 2.33, Mac OS X (10.5.2)
  • JPM-PL Level 1 Level 1 (40 points)
    Currently Being Moderated
    Mar 10, 2008 12:33 PM (in response to CodLBi)
    I disabled AM/PM settings.
    last night my iMac did not wake himself up.
    The solution you provided seems to work. I'll wait several days to make sure.

    Anyway the solution is strange.

    Thanks a lot.
    iMac, Mac OS X (10.5.2), Intel 2.8
  • JPM-PL Level 1 Level 1 (40 points)
    Currently Being Moderated
    Mar 11, 2008 12:08 AM (in response to CodLBi)
    It did not help. iMac woke up this night at 01:00 again.

    I have no idea.
    iMac, Mac OS X (10.5.2), Intel 2.8
  • JPM-PL Level 1 Level 1 (40 points)
    Currently Being Moderated
    Mar 20, 2008 11:13 AM (in response to JPM-PL)
    Solved !

    I did SMC reset. It helped. iMac sleeps all night long No more wake ups at 01:00.

    For details how to do that look here --> http://docs.info.apple.com/article.html?artnum=303446

    Regards,
    JM
    iMac, Mac OS X (10.5.2), Intel 2.8

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.