Skip navigation
This discussion is archived

iCal & Group calendar access

10038 Views 23 Replies Latest reply: May 8, 2008 11:55 AM by Andreas Franz. RSS
  • Arcady Calculating status...
    Currently Being Moderated
    Dec 2, 2007 12:56 AM (in response to Jonathan Cipriani)
    Thank you too, Jonathan - this solved exactly the same problem for me!
    G5 X-Serve, Mac OS X (10.5), MacBook Pro 15"
  • mdavis75 Calculating status...
    Currently Being Moderated
    Dec 30, 2007 4:17 AM (in response to Sven-Goran Ljungholm)
    I see the same behaviour. At first I thought it may be some kind of DNS issue, but I guess not.

    So, the choices are:

    1) Create one or more group calendars - all accessible from iCal, with the first one viewable from the wiki. From the wiki you can add new events, which appear in ical, but you cannot touch (edit/delete) an event created/edited in iCal from the wiki.

    2) Subscribe to the one wiki calendar in iCal, and perform all add/edit/deletes via the web.

    Apple has this so close, but seemingly so far.
    iMac, Mac OS X (10.5.1)
  • James Hadd Calculating status...
    Currently Being Moderated
    Jan 16, 2008 12:22 PM (in response to Aaron Scott)
    here is my 2 cents worth

    i tried everything on this and the other thread. did not help me at all. kept getting the same errors as described above. so i put everything back to the way it was before and RESTARTED the server. everything now works perfect. so i am not going to touch a thing. looks to me like just stopping and starting web and ical services doesn't reboot all services needed for the changes to take effect. try to reboot the server after trying changes, and/or restart the server first then try some of the above steps.
    powerbook 15" 2.6ghz, Mac OS X (10.5.1)
  • lukejames1 Calculating status...
    Currently Being Moderated
    Feb 1, 2008 3:31 PM (in response to James Hadd)
    I have had these same errors until today, when I got one user to connect to a calender, but no others. I rebooted, and now no one can connect! Fun! I think Apple has some work to do with this product.
    Mac OS X (10.5.1)
  • Level 6 Level 6 (11,035 points)
    Currently Being Moderated
    Mar 11, 2008 12:27 PM (in response to James Hadd)
    Rebooting also worked for me, yet I still have the same issues as listed above. I can get the Wiki calendar working just fine but I can not Log into the group calendar using iCal. Every time I enter the correct settings in the ACCOUNTS area of iCal Preferences, it says "*Access to http://my.serverss.ip:8008/principals/groups/mygroupname/ is not permitted*"

    After two days of this, I am moving onto my next project until I hear different. This is getting frustrating.
    PowerBook G4, Mac OS X (10.3.x)
  • Cyrus Daboo Level 2 Level 2 (230 points)
    Currently Being Moderated
    Mar 12, 2008 7:19 AM (in response to Merged Content 1)
    Is the user specified in the iCal account enabled for calendaring? i.e. can they access their own personal calendars?
    MacPro, Mac OS X (10.5.2)
  • macpc-advice Calculating status...
    Currently Being Moderated
    Mar 13, 2008 8:28 AM (in response to Jonathan Cipriani)
    Hmm .. if I follow your advice I get the "no valid data" (my translation from danish)
    MacBook Pro, Mac OS X (10.5.1)
  • Level 6 Level 6 (11,035 points)
    Currently Being Moderated
    Mar 27, 2008 2:49 PM (in response to Cyrus Daboo)
    Ok, I figured this one out. What I had to do to make this work is:

    1. On a client computer (not server), in Utilities folder open
    2. Go into Preferences
    3. Change Authentication from Kerberos to Password
    4. Click OK
    5. In, click on "NEW SHARED CONTACT"
    6. Enter in your username and password. I entered ROOT and my password. That is all that seemed to work.
    7. In iCal > Preferences > Accounts
    8. Enter in Description, Username then password of the user that already has permission to access the calendar. This worked for me.
    PowerBook G4, Mac OS X (10.3.x)
  • Andreas Franz. Calculating status...
    Currently Being Moderated
    May 8, 2008 11:55 AM (in response to Jonathan Cipriani)
    Jonathan Cipriani wrote:
    Go to accounts in the preferences of iCal, add a new account, enter a description (your choice), enter a username and password (that has read/write access to the calendar), and enter I could then edit the primary calender from ical and add secondary calendars (though the secondary calendars were not viewable on the website).

    For read only access just subscribe.

    Hello Jonathan.

    maybe you can help me with your expertise. I followed your suggestion and it worked seamlessly, but only as long as I was in the same subnet. When trying to access my calendars from home, verything vanished in to nirvana. No calendars where found what so ever. Is that the was iCl will behave when my mbp is in a different IP range?

    Greetings from Switzerland,
    MacBook Pro 15", Mac OS X (10.5.2)
1 2 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.