Skip navigation
This discussion is archived

FileVault and Launch Services

23660 Views 77 Replies Latest reply: Sep 8, 2009 3:26 AM by Michael Kuck RSS
  • pjuergens Calculating status...
    Currently Being Moderated
    Dec 18, 2007 5:53 PM (in response to thirteen37)
    Add one victim to the list.

    Another observation: there seems to be something fundamentally flawed with Filevault plus Launch Services. Every now and then, Leopard fails to mount my FV sparsebundle correctly. I end up with mangled paths: ~ points to the fake user directory containing the FV image. So I get no lock item for my home directory, the desktop stays empty, and the system fails to load some preferences.

    In sum, FileVault appears to be the opposite of it's function: unreliable, insecure, and a big risk altogehter. And because we're on a half-proprietary OS, we can't even turn on filesystem encryption on the filesystem level.

    Now I only wish the ZFS encryption project were finished and OS X would integrate it fully.
    Macbook Pro 1,8, Mac OS X (10.5.1)
  • zerohalo Calculating status...
    Currently Being Moderated
    Jan 17, 2008 7:37 AM (in response to thirteen37)
    I experience the same problem. I also experienced this when using Tiger (also with FileVault). It affects all my file type associations (.doc, .avi, .rtf, etc.) Extremely annoying!
    macbook, Mac OS X (10.5.1)
  • jakaj Calculating status...
    Currently Being Moderated
    Feb 11, 2008 11:49 PM (in response to thirteen37)
    Can anyone who had this issue verify if it's fixed by 10.5.2?
    Mac OS X (10.5)
  • Atrocity Calculating status...
    Currently Being Moderated
    Feb 12, 2008 12:07 AM (in response to thirteen37)
    Nope, Bug is still there in 10.5.2 ... that was (IS!) my only problem on Leopard. Pleas Apple, fix that censored
    Mac OS X (10.5)
  • foxxx Calculating status...
    Currently Being Moderated
    Feb 13, 2008 9:14 AM (in response to thirteen37)
    i have the same annoying problem on 10.5.2 with Intel IMAC and MBP since i turned on FileVault 2 weeks ago
    iMac, 2.0 GHz, 20", 1GB, 250 GB / MacBook Pro 1.83 GHz, 15.4", 1.5GB, 80GB /, Mac OS X (10.5.2)
  • Alex Hutton Calculating status...
    Currently Being Moderated
    Feb 15, 2008 8:46 AM (in response to thirteen37)
    Same bug. Not fixed in 10.5.2. It may be related, but JungleDisk (for Amazon S3) "forgets" it's configuration, as well.
    Macbook 1.83, iPhone, iPod, g4s, apple stuff and stuff, Mac OS X (10.5.2)
  • Joris Witteman Calculating status...
    Currently Being Moderated
    Feb 19, 2008 2:09 AM (in response to thirteen37)
    Same problem here. 10.5.2 didn't fix it.
    MacBook 13.3" 2.2 GHz, Mac OS X (10.5.2), 2 GB RAM
  • Andy_M Calculating status...
    Currently Being Moderated
    Feb 20, 2008 4:57 AM (in response to Joris Witteman)
    same bug here too!
    2,16 Macbook, Mac OS X (10.5.2)
  • x2on Calculating status...
    Currently Being Moderated
    Feb 21, 2008 8:23 AM (in response to thirteen37)
    same Problem here... Apple please fix this!!!
    MacBook Pro 2,2Ghz, Mac OS X (10.5.2)
  • ruebezahl Level 1 Level 1 (20 points)
    Currently Being Moderated
    Feb 26, 2008 5:27 AM (in response to thirteen37)
    same thing here, deactivating filevault and reactivating did not help
    MBP 15" C2D, Imac 20" 2GHZ, Mac OS X (10.5)
  • gordon142 Level 1 Level 1 (15 points)
    Currently Being Moderated
    Mar 12, 2008 12:22 PM (in response to thirteen37)
    OK, it is very important for everyone to go to http://www.apple.com/feedback/macosx.html/ and report this bug to Apple immediately - this is the only way it will get fixed. This is a major issue and there is no excuse for it having not having been fixed by now.
    MacBook Pro 15 2.33 C2D, Mac OS X (10.5.2)
  • x2on Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 21, 2008 3:23 AM (in response to thirteen37)
    is there a possibility to write a workaround script for the default file/program association?
    MacBook Pro 2,2Ghz, Mac OS X (10.5.2)
  • ruebezahl Level 1 Level 1 (20 points)
    Currently Being Moderated
    Mar 21, 2008 3:41 AM (in response to thirteen37)
    so far there is now workaround i know from, but it's a known bug and they are working on it

    regards

    franz
    MBP 15" C2D, iMac 24" 2,4GHZ, Mac OS X (10.5.2)
  • GrahamIX Calculating status...
    Currently Being Moderated
    Mar 21, 2008 4:23 PM (in response to thirteen37)
    Aha! I wondered why on my MacBook Pro running Leopard and FileVault, it never remembered that I want to use Firefox+Thunderbird rather than Safari+Mail.app. It would also forget Cyberduck and Adium as my preferred apps.

    Running the workaround script has indeed corrected this behaviour - I am currently writing up the bug as instructed
    MacBook Pro, PowerMac G5, Mac Minis, Mac OS X (10.5.2), I have a number of them
  • x2on Level 1 Level 1 (0 points)
    Currently Being Moderated
    Mar 22, 2008 11:44 AM (in response to thirteen37)
    Ok the workaround
    /System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchSe rvices.framework/Versions/A/Support/lsregister -kill -r -domain local -domain system -domain user >/dev/null 2>&1 &
    works for me, with http://lingon.sourceforge.net/ you can easy make a launchd configuration, to execute the workaround after login... (thx to cub from apfeltalk.de for this)
    MacBook Pro 2,2Ghz, Mac OS X (10.5.2)
1 2 3 4 ... 6 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.