1 2 3 4 Previous Next 55 Replies Latest reply: Jun 22, 2008 3:47 PM by Allen Watson1 Go to original post
  • 45. Re: UserEventAgent not responding.
    Pr0xyPunk Level 1 Level 1 (0 points)
    I re-installed my system last week because of a third party software glitch.
    Now all of the sudden the problem is gone, UserEventAgent is acting normal.
    I didn't change a thing about my hardware configuration and i got all the same software installed as before when i did have the problem.

    Perhaps not much of help but i just wanted to let you guys know.
  • 46. Re: UserEventAgent not responding.
    Mike Knowlton1 Level 1 Level 1 (0 points)
    I'm having the same problem with varying issues.

    I get the UserEventAgent (Not Responding), however sometimes it is at 0% CPU usage and sometimes it is using a lot (but never 100%)

    Mac PPC G4 Dual 1.25GHZ 10.5.2

    What's very odd is that once it stops responding, then I get heavy CPU usage from different things. Sometimes its mds (spotlight), most times it's MAMP, sometimes spindump (?? I have no idea), WindowServer.

    This has also caused kernal panics as well and outright freezes w/o any error at all. The frequency of the crashes and the necessity of having to reboot is getting more frequent.
  • 47. Re: UserEventAgent not responding.
    alexss Level 1 Level 1 (0 points)
    On my MacBookPro 2.16 GHz, OSX 10.5.2 I get the same UserEventAgent not responding and I narrowed down the culprit to BluetoothUserAgent-Plugin. I removed it and now my UserEventAgent work fine.

    However, I need the Bluetooth connection from times to times. How to proceed to have it operational. Is this a bug of this Apple plugin or is there some other thing interfering with it ?
  • 48. Re: UserEventAgent not responding.
    koset Level 1 Level 1 (0 points)
    Friends, your posts have helped me. I have a Powermac Dual 1.8GHz with 10.5.2. One CPU was pinned at 100% usage and exhibiting sluggishness. For me, the culprit was a GrandTec Virtually Indistructible Kbd. I switched back to my original Mac kbd and all is swell again. Sigh, I'll miss that GrandTec, because it was silent.

    Hey, Apple! Fix this!
    Koset
  • 49. Re: UserEventAgent not responding.
    Mu5icGlobber Level 1 Level 1 (0 points)
    Turns out that for me the fix was to delete Protools from my system. Seems like some sort of plugin compatibility issue. Dunno, for now I'm not needing protools, I probly just didn't download some updates or something.
  • 50. Re: UserEventAgent not responding.
    Roberto74 Level 1 Level 1 (0 points)
    I had the same problem yesterday on my 12" G4 Alluminium laptop running Leopard 10.5.2 with all
    latest patches and updates applied.

    UserEventAgent process was taking all cpu when i plugged in the X-Arcade double joystick.
    This joystick works actually as an usb keyboard mapping keys to joystick movements.

    I solved the issue following the advices i've found in this forum....
    loggin in as root and moving the AppleHIDMouseAgent.plugin directory out of
    /System/Library/UserEventPlugins and then rebooting.

    Laptop is working fine now even when plugging the X-Arcade.

    Robert
  • 51. Re: UserEventAgent not responding.
    devil0315 Level 1 Level 1 (0 points)
    I am getting the same thing, anybody figure out what s going on. Upgraded to Leopard, CPU overloading... I hope somebody can help because I have to much software to install.
    Thanks.
  • 52. Re: UserEventAgent not responding.
    thegnu Level 1 Level 1 (0 points)
    I was having the same thing until I ran the unload command above and then rebooting, which has a typo, and should be:

    sudo launchctl unload -w /System/Library/LaunchAgents/com.apple.UserEventAgent-Aqua.plist

    Then, reboot afterwards.

    Anyway, I'd been having this issue since I got the Mac (a few weeks), and it would drop Airport connections, and do all sorts of weird stuff. Now, it seems to be fine. But it's only been a couple minutes, and the problem was intermittent to begin with.
  • 53. Re: UserEventAgent not responding.
    jimmykimo Level 1 Level 1 (0 points)
    I have the same problem! It doesn't use up much or any CPU space but it's just red. I'm using a brand new MacBook 2.4GHz 2 GB RAM. I also don't have a UserEventAgent folder in Library, which is strange since that's what is causing the problem. Anyone know how to fix this?
  • 54. Re: UserEventAgent not responding.
    sgginc Level 3 Level 3 (655 points)
    Exactly the same for me.
    Just shows red and not reponding.
    Doesn't take much memory or cpu time.
    Comes right back after quitting.

    UserEventPlugins has several plugins none of which show opened recently.

    Would really like to know what this is.

    Any help is greatly appreciated.

    From Sample in Activity Monitor:

    /
    /usr/sbin/UserEventAgent
    /System/Library/UserEventPlugins/AirPortUserAgent.plugin/Contents/MacOS/AirPortU serAgent
    /System/Library/UserEventPlugins/alfUIplugin.plugin/Contents/MacOS/alfUIplugin
    /System/Library/UserEventPlugins/AppleHIDMouseAgent.plugin/Contents/MacOS/AppleH IDMouseAgent
    /System/Library/PrivateFrameworks/Apple80211.framework/Versions/A/Apple80211
    /System/Library/UserEventPlugins/BluetoothUserAgent-Plugin.plugin/Contents/MacOS /BluetoothUserAgent-Plugin
    /System/Library/Extensions/AudioIPCDriver.kext/Contents/Resources/AudioIPCPlugIn .bundle/Contents/MacOS/AudioIPCPlugIn
    /System/Library/Extensions/IOBluetoothFamily.kext/Contents/PlugIns/IOBluetoothSC OAudioDriver.kext/Contents/Resources/IOBluetoothSCOAudioDriverPlugIn.bundle/Cont ents/MacOS/IOBluetoothSCOAudioDriverPlugIn
    /System/Library/PrivateFrameworks/BezelServices.framework/Versions/A/BezelServic es
    /System/Library/Extensions/AppleHDA.kext/Contents/PlugIns/AppleHDAHALPlugIn.bund le/Contents/MacOS/AppleHDAHALPlugIn
    /Library/Audio/Plug-Ins/HAL/Hear.plugin/Contents/MacOS/Hear
    /Library/Frameworks/ApplicationEnhancer.framework/Versions/A/ApplicationEnhancer
    /System/Library/Frameworks/IOBluetooth.framework/Versions/A/IOBluetooth
    /Users/Kenny/Library/Application Enhancers/FruitMenu.ape/Contents/MacOS/FruitMenu
    /Users/Kenny/Library/Application Enhancers/Smart Scroll.ape/Contents/MacOS/Smart Scroll
    /Users/Kenny/Library/Application Enhancers/WindowShade X.ape/Contents/MacOS/WindowShade X
    /Library/Audio/Plug-Ins/HAL/iWow.plugin/Contents/MacOS/iTea
    /System/Library/UserEventPlugins/BTMMPortInUseAgent.plugin/Contents/MacOS/BTMMPo rtInUseAgent
    /System/Library/UserEventPlugins/iCalAlarmAgent.plugin/Contents/MacOS/iCalAlarmA gent
    /System/Library/UserEventPlugins/ParentalControlsUEAPlugin.plugin/Contents/MacOS /ParentalControlsUEAPlugin
    /System/Library/UserEventPlugins/SCMonitor.plugin/Contents/MacOS/SCMonitor
    /Library/Caches/com.apple.LaunchServices-023503.csstore
    /usr/lib/dyld
    /private/var/db/dyld/dyldshared_cachei386
    /dev/null


    /System/Library/UserEventPlugins
    ->0x52ffc38

    Thanks ... Ken
  • 55. Re: UserEventAgent not responding.
    Allen Watson1 Level 1 Level 1 (15 points)
    The utility "Hear", which enhances audio, can also be at fault here. Its latest version, 1.0.2, lists the following info:

    What's new in this version:
    Fixed problem where Hear was causing 'UserEventAgent' process to show as 'not responding'.
    Fixed problem where Hear was causing 'coreaudiod' process in 10.5.3 to show as 'not responding'.
1 2 3 4 Previous Next