Skip navigation
This discussion is archived

USB Mic Distortion

4091 Views 8 Replies Latest reply: Oct 8, 2008 5:04 PM by yschutzer RSS
sallychi Calculating status...
Currently Being Moderated
Feb 11, 2008 9:54 AM
I recently bought a Samson G-Track USB microphone, to go with my new Macbook (running Leopard), but seem to get intermittent audio distortion when I record. I have been checking the record levels on the mic and garageband and it's not clipping. If anything the signal strength on the Garageband monitor seems low. I can sometimes record a signal ok and then with exactly the same setup next time it distorts. I have tried turning off all effects in case they are causing it. Looking at online discussion forums there seems to be a problem with the Apple USB driver (Audio Codec?).

Anyone else had this problem?
macbook, Mac OS X (10.5.1)
  • isteveus Level 5 Level 5 (4,125 points)
    Currently Being Moderated
    Feb 11, 2008 10:18 AM (in response to sallychi)
    My thoughts is if it was a usb problem it would happen all the time not some of the time. Is the gain adjustable on that mic? If so turn it down just a little and don't get to caught up with the track signal strength reading worry about a clean signal.
    20" iMac 2.4 /  Black Macbook, Mac OS X (10.5)
  • 123aliasalias Calculating status...
    Currently Being Moderated
    Feb 22, 2008 11:51 AM (in response to sallychi)
    I've had a Snowball USB mic for about a year and it sometimes has problems like you describe (basically signal breakup that sounds like clipping, even though the input level is not too high).

    I first used it with a G4 Powerbook, and found that the perfomance depended on which port I used. The differences were dramatic.

    I'm now using a MacBook, and there is variability when I record my band from session to session. I'm getting the feeling it might have to do with how well the power is sent from the USB port to the mic. But I don't have a good diagnostic.

    I plan to sit down and run some trials, and would suggest you do the same. Plug in the mic, do a quick test and listen, then disconnect/reconnect the mic and repeat the test (changing ports or not).

    I read recently that USB power is "dirty" and maybe these mics are very sensitive. If anyone has more info, I'd like to hear it.
    2.2GHz MacBook, Mac OS X (10.5.2)
  • Wingrove Level 1 Level 1 (15 points)
    Currently Being Moderated
    Apr 9, 2008 9:18 PM (in response to sallychi)
    there is defiantley something intermittant about USB audio at the moment, plenty of posts about USB distortion that kicks in 30 mins after start of record or thats there for one take then not the next. theres reported fixes by installing the older version of the USB audio enabler pugins but havent tried it yet
    Macpro 8X 6GB/2TB 2x23" MacBookPro 17", iPod touch 16gb, Mac OS X (10.5)
  • elifazTemanita Calculating status...
    Currently Being Moderated
    Jul 7, 2008 8:36 AM (in response to sallychi)
    iBook G4 Early 2005, Mac OS X (10.4.11)
  • Jason_Mac Calculating status...
    Currently Being Moderated
    Jul 7, 2008 1:43 PM (in response to elifazTemanita)
    Fixed
    MacBook 2.0 (White), Mac OS X (10.4.10)
  • SupaRistopher Calculating status...
    Currently Being Moderated
    Jul 22, 2008 1:33 PM (in response to Jason_Mac)
    How did you fix it! This thing is driving me seriously nuts! I have the G Track too and about every 20 minutes it just goes electrocrap sounding, did you replace the driver? If so, where did you find it? Any help is GREALY appreciated, thanks!
    MacBook Pro, Mac OS X (10.5.4)
  • danny31374 Calculating status...
    Currently Being Moderated
    Sep 13, 2008 3:09 PM (in response to Jason_Mac)
    Yes....PLEEEEEEEEEEEASE tell how you fixed it. This problem is so frustrating!
    Macbook, Mac OS X (10.5.4)
  • yschutzer Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 8, 2008 5:04 PM (in response to sallychi)
    I discovered something important to this thread. I encountered this problem on my MacBook 2g, but not my MacBook Pro 2.4g. To be specific, when I boot my MacBook using my MacBook Pro as the target boot disk, problem continues. But when I boot my MacBook Pro using its own hardware, but exact same disk, the problem never occurs.

    Note I've tried multiple USB mics to recreate the same issue.

    Therefore, it seems it's a firmware or core USB driver issue that only affects certain models. For those still experiencing the problem, try turning your computer into a target disk, then use another computer (preferably a newer Mac bookPro) to see if it bypasses the problem. If so, Apple must issue a new firmware or core USB driver to fix the audio, so they'll need your feedback on this.
    MacBook Pro 2.4g, Mac OS X (10.5.5), 2g ram, Logic 8, Motu 896HD, Apple Certified Support Technician

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.