Skip navigation
This discussion is archived

How do you change the owner of a folder?

2389 Views 6 Replies Latest reply: Apr 16, 2008 5:32 AM by cluelessnewadmin RSS
cluelessnewadmin Calculating status...
Currently Being Moderated
Apr 15, 2008 3:00 PM
Hello,

I'm having a very difficult time finding an answer to this question. I have a brand new xserve (10.5.2) up and running fine with a single web site with wikis and blogs enabled. I can get to the web page and the wikis with no problems.

The problem is, the default folder for the web home page and the wiki information are on the system drive. I need to have those folders on another partition. I created a folder called /Collaboration and one called /Webdocs on the partition on which I need these folders.

When I put a copy of index.html into the webdocs folder, the web site shows up fine in a browser window. Wikis show as being "disabled" though. The folder for the wiki files has me as the owner since I created it. I've read on a few posts in these forums that the owner of that Collaboration folder needs to be "teamserver" however, I am unable to change to that using Get Info, like I could with a Tiger machine.

Could someone please tell me how to do this? Thanks.
Mac OS X (10.5.2)
  • Mike Matthews Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 15, 2008 5:24 PM (in response to cluelessnewadmin)
    I've got a similar problem:

    I'm attempting to follow the directions in the Upgrading and Migrating Guide for Leopard. The Mac has two hard drives in it. Batman contains the active server running 10.4.11. Magic is the hard drive that will run 10.5.2.

    Since I'm moving from one hard disk to another (as opposed to an entirely different Mac), things ought to be fairly easy. But not for me. ;(

    What I'm trying to do: Migrate the mail database. (I have managed to import users and groups; only the mail service will run on this machine.)

    Problem: I can't change the owner and group settings on the various files in the var/imap and var/spool/imap folders (for example, so that they are owned by system or _cyrus, with group wheel or mail and everyone set to read only).

    The owner and/or group often shows up as unknown (which is to be expected with the migration to a different hard drive). But how can I change these permissions?

    Or is there a way to use a command to copy them from one disk to another? I tried ditto, but didn't get the syntax right (the files were copied to the same level as the imap folder rather than within it) and now I have a bunch of files owned by nobody that I can't delete because I can't change the owner.

    TIA,
    mm
    Mac OS X (10.5.2)
  • Niel Level 10 Level 10 (234,755 points)
    Currently Being Moderated
    Apr 15, 2008 5:41 PM (in response to cluelessnewadmin)
    Open the Terminal in the /Applications/Utilities/ folder and enter the following:

    sudo chown username

    followed by a space; next, drag the item from the Finder into the Terminal window, press Enter, and provide your password if prompted. Nothing will appear in the Terminal window while the password is being typed. The command can be adjusted to affect everything inside it by adding -R and a space before the username.

    (31567)
    iMac Late 2007 Core 2 Duo, Mac OS X (10.5.2)
  • Mike Matthews Level 1 Level 1 (10 points)
    Currently Being Moderated
    Apr 15, 2008 10:07 PM (in response to Niel)
    Hi:

    You know, I tried that, but I got an error.:

    sudo chown system /Volumes/Magic/private/var/imap/annotations.db
    Password:
    chown: system: Invalid argument

    I think I could probably delete the files that need deleting by starting up with the 10.4.11 version of the server and also move them to the right place I then might be able to finagle the permissions using either the 10.4.11 version of the server or the 10.5.2 version.

    But it still would be nice to now how to do this purely in Leopard.

    mm
    Mac OS X (10.5.2)
  • Niel Level 10 Level 10 (234,755 points)
    Currently Being Moderated
    Apr 15, 2008 11:41 PM (in response to Mike Matthews)
    You need to use root instead of system.

    (31583)
    iMac Late 2007 Core 2 Duo, Mac OS X (10.5.2)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.