Skip navigation
This discussion is archived

iPhoto 08 and USB Printing not working

1136 Views 4 Replies Latest reply: Jun 10, 2008 8:34 AM by Jasper3 RSS
TempusThales Level 2 Level 2 (165 points)
Currently Being Moderated
Mar 22, 2008 1:21 PM
Is anyone else having an issue printing from iPhoto to a usb printing connected to an Airport Extreme? I have firmware 7.3.1. A Canon ip6600D. 10.5.2. All updates. Printing web pages, e-mail or pretty much any test or simple graphics works fine. I can't print pictures. It starts to print about a 1/4 of the way and then stops and sits there. Heres what I did so far:

1. Removed the Canon folder from /library/printers/ and installed the latest driver from Canon.
2. Put the printer on a USB hub.
3. Tried other Canon drivers.

It prints fine when the printer is connected directly to the iMac.

Any help would be great!!!

Thanks!!!
iMac 17" G5 iSight (1.5GB) and Alum iMac 2.4GHz (4GB); iPod 5G, Mac OS X (10.5.2), Airport Extreme (802.11n) and Airport Express (Used for iTunes)
  • TerryR Calculating status...
    Currently Being Moderated
    May 3, 2008 2:42 AM (in response to TempusThales)
    TT,
    Yes, this just happened to me for the first time last night (actually, it was the first time I've tried to print from iPhoto to the USB printer which is plugged into the USB of my AEBS-Giga). Same symptoms as you, everything else will print except for iPhoto '08: my Canon iP5000 app just started hopping in the dock giving an error like "Can't find printer" or something.
    My only fix was to export the picture and print in another app; though I've never been a big fan of iPhoto printing setup anyway, I'd like to be enlightened as to why this is happening.
    MacPro 2.66GHz/3GbRAM/2x250, 2x320 Seagates/X1900XT/BT/AP/EyeTV250/2407wfp, Mac OS X (10.5.2), iMac 24", 2.33GHz; MBP 2.5GHz, 17" Hi-Res
  • Jasper3 Calculating status...
    Currently Being Moderated
    May 13, 2008 4:22 PM (in response to TempusThales)
    I too have this issue with iPhoto '08 connected to the Canon printer via usb and Airport Express. All updates have been installed including the latest Canon printer update for Leopard. If I try to print via Airport, the printer hangs after a few seconds, having printed less than a third of the photo. There is no problem printing with a direct usb connection to the iMac, or printing from another application via Airport. The problem seems therefore to rest with the iPhoto application. If I make the picture size very small instead of the standard size in the iPhoto print screen it will print completely, but a 6" by 4" or larger will stall. There is no problem printing a Word document or printer test sheet. It is as if there is buffering issue.

    I would be very grateful for any help in resolving this problem.

    With thanks
    iMac intel Core Duo, Mac OS X (10.5.2), Canon Pixma MP800r Driver 4.8.3, Airport Express v6.3, iPhoto v7.1.3.
  • Zabobon Level 1 Level 1 (0 points)
    Currently Being Moderated
    May 22, 2008 6:00 AM (in response to TempusThales)
    Yes, and I'm having the exact same issue, but with a Canon Pixma IP5200R connected to USB of Airport Extreme. I'm running 10.5.2.

    It won't print from iPhoto. All other printing works fine (ie from any other App).

    I have found a workaround: When the printer dialog comes up (the printer dialog for the Canon Printer) click on "Preview", rather than "Print". This opens up the image in Preview (you can tell you're in Preview because the current App changes from iPhoto to Preview in the bold text at the left of the Menu Bar). Then you can simple print from Preview.

    This is not a perfect solution, but it does at least work until a proper fix comes along.
    Mac Pro 2 x 3 Ghz Quad-Core Intel Xeon, Mac OS X (10.5.2)
  • Jasper3 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 10, 2008 8:34 AM (in response to Zabobon)
    Upgraded to Mac 10.5.3 yesterday and the printing problem has gone away. Large photographs now print out completely within iPhoto, without stalling and hanging after several seconds. I understand from another forum discussion (Topic : Does 10.5.3 fix any printing issues) on a similar issue, that this upgrade has addressed some printing difficulties, which seem to have hit the spot for my problem. Hope that it sorts it all out for the rest of you.

    Message was edited by: Jasper3
    iMac intel Core Duo, Mac OS X (10.5.2)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.