Skip navigation
This discussion is archived

mdnsresponder and configd

99767 Views 90 Replies Latest reply: Aug 19, 2010 7:19 AM by Jay Bullock RSS
  • Michael St. Calculating status...
    Currently Being Moderated
    May 16, 2008 9:38 PM (in response to Michael St.)
    Well, success was short-lived.

    After putting the PowerBook to sleep for a day and waking it up, DHCP does no longer work - Airport gets a self-assigned IP, and only if the firewall is opened temporarily will it work.

    Apparently, there's some sort of timeout active. After I applied the PMU reset, DHCP worked after sleep/wake and after reboot. But not after more than, say, 20 hours.

    Back to square one. miffed.
    iMac 24", 2.4GHz, 2GB; PowerBook G4, 1.67GHz, 2GB;, Mac OS X (10.5.2)
  • JasLau Calculating status...
    Currently Being Moderated
    May 17, 2008 6:37 AM (in response to Michael St.)
    I have gotten all back to normal (by "normal" I mean my wireless works upon restart and wake from sleep without having to manipulate the firewall settings in order for wireless to actually have internet access) although not sure what actually did it.

    One thing I did do which seems to have been a positive step was to repair the permissions in Disk Utility. I first verified disk permissions and then did the repair disk permissions. I have heard/read differing reports on the effectiveness of repairing disk permissions, but this seems to have done something which was/is positive.
    MacBook (black), Mac OS X (10.5.2)
  • interconnect Calculating status...
    Currently Being Moderated
    May 28, 2008 3:33 PM (in response to SolRayz)
    this appears to be fixed in 10.5.3... atleast for me.
    Macbook Pro, C2D, 15", 2.33GHz, 3GB RAM, 160GB HD, Mac OS X (10.5.1)
  • lstnmysphr Level 1 Level 1 (5 points)
    Currently Being Moderated
    May 29, 2008 12:57 AM (in response to interconnect)
    Agreed 10.5.3 seems to have settled it for me thus far. I've been on a few different networks already today and pre 10.5.3 I would have noticed this bug by now I'm sure. I'll keep an eye on it but it does indeed seem like it's been resolved (and not a moment too soon).
    Powerbook G4 15" (1.67Mhz), Mac OS X (10.5.3)
  • WendySH Calculating status...
    Currently Being Moderated
    Jun 1, 2008 3:41 PM (in response to lstnmysphr)
    I thought I had this problem fixed (with your help) by adding these files (mdnsresponder, configd, nmblookup) to my "allowed" list in the security pref pane. Since I have done this it had worked flawlessly until now when I upgraded to 10.5.3 I am back to the same problem as before. Something is not being allowed to load when I have "set access for specific services and applications" and I have to switch to "allow all incoming connections" each time I restart to get my (any) network to function. Any idea what the new files that are being blocked may be??? or if this is a new problem???
    MacBook Pro, Mac OS X (10.5.3)
  • Michael St. Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 4, 2008 9:40 PM (in response to lstnmysphr)
    I confirm that 10.5.3 has fixed this issue for me as well - I upgraded just yesterday (was on a trip), then let my laptop sleep for > 24hours. After wake from sleep configd (ie. DHCP) works just fine, acquiring IP etc., where it previously failed to do so.

    Regards, Michael
    iMac 24", 2.4GHz, 2GB; PowerBook G4, 1.67GHz, 2GB;, Mac OS X (10.5.3)
  • thermatoga Calculating status...
    Currently Being Moderated
    Jun 6, 2008 10:44 PM (in response to WendySH)
    I too had resolved this issue using the suggestions listed in this post but after loading 10.5.3 on my mac they have just come back. I want a permanent solution to this issue. It is very Microsoft like in its symptoms. I switched to mac to run away from these types issues. Apparently not the case.
    MacBook, Mac OS X (10.5)
  • thermatoga Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 6, 2008 11:06 PM (in response to thermatoga)
    But I thought since others had their problems resolved with 10.5.3 then what would happen if I got rid of the work-around. So I went into the firewall list of allowed programs and removed mdnsresponder and configd from the list. So far so good. I was able to connect to the internet again and work as normal. Hope this helps.
    MacBook, Mac OS X (10.5)
  • lstnmysphr Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jun 6, 2008 11:59 PM (in response to WendySH)
    Try a firewall reset (after upgrading to 10.5.3):

    In terminal paste the following command:

    sudo cp /usr/libexec/ApplicationFirewall/com.apple.alf.plist /Library/Preferences/com.apple.alf.plist

    May help...
    Powerbook G4 15" (1.67Mhz), Mac OS X (10.5.3)
  • WendySH Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jun 9, 2008 7:03 AM (in response to thermatoga)
    Removing the original work-around fixed it!. Thanks. That was easy.
    MacBook Pro, Mac OS X (10.5.3)
  • Steve P. Level 1 Level 1 (105 points)
    Currently Being Moderated
    Jun 17, 2008 1:28 PM (in response to Krakatos)
    Krakatos wrote:
    That's odd, even though I added configd and mDNSResponder to my firewall list, I am still prompted to accept incoming connections for them after rebooting.


    How did you do that? I wanted to try adding configd and mDNSResponder to my permitted applications, but those two items were not locatable and therefore cannot be added.

    EDIT: I just saw the instructions at the start of the thread.

    Message was edited by: Steve P.
    Powerbook G4 15 1.5Ghz, Mac OS X (10.5.3)
  • Steve P. Level 1 Level 1 (105 points)
    Currently Being Moderated
    Jun 17, 2008 1:24 PM (in response to lstnmysphr)
    lstnmysphr wrote:
    Try a firewall reset (after upgrading to 10.5.3):

    In terminal paste the following command:

    sudo cp /usr/libexec/ApplicationFirewall/com.apple.alf.plist /Library/Preferences/com.apple.alf.plist

    May help...


    This seems to only reset the Firewall preferences to the factory default setting of 'Allow All' and clears any existing list of specific applications. It did not fix the problem for me unfortunately, as I want to specify certain apps, not Allow All.
    Powerbook G4 15 1.5Ghz, Mac OS X (10.5.3)
  • Steve P. Level 1 Level 1 (105 points)
    Currently Being Moderated
    Jun 17, 2008 3:34 PM (in response to lstnmysphr)
    lstnmysphr wrote:
    Okay, Wendy so I was in totally the same boat as you, with no idea how to do this. After playing around though this is how:

    1. Download Main Menu (http://www.santasw.com/)

    2. Install and then it puts an icon in your menu bar. Click it, highlight finder (in the menu) and then click show invisibles. Finder will restart.

    3. Clear the deksotop and open finder. Go to Machintosh HD (they'll be lots of folders, including the crucial usr folder).

    5. Open system preferences, go the firewall section.

    6. Click the add button and then in the finder window that you opened drag the usr folder onto the window (see this image: http://img122.imageshack.us/img122/9158/howtoue6.jpg)

    7. Then naviagate to /usr/sbin/mDNSResponder and you can select it. This can also be repeated for configd (it was giving me problems).

    8. Voila, problem solved.


    This solution WORKED but only after I repaired disk permissions afterwards. None of the other suggestions worked.
    Powerbook G4 15 1.5Ghz, Mac OS X (10.5.3)
  • acdawson Calculating status...
    Currently Being Moderated
    Aug 13, 2008 5:30 PM (in response to SolRayz)
    I've found a solution to this problem that has worked for me. I simply replaced mdnsresponder, configd, nmblookup and nmbd with the same files from another computer. Amazingly, this fixed it. But, of course, it means you must have access to another machine running the same version of Leopard.

    acd.
    Macbook Air, Macmini, Mac OS X (10.5.4)
  • William Brawley Calculating status...
    Currently Being Moderated
    Aug 18, 2008 10:53 AM (in response to SolRayz)
    I am having the same problem under 10.5.4, however it only occurs when trying to connect either by wireless or with ethernet to my campus network. the only way to get it to work is to "allow all incoming connections." I've tried some of the tips in this thread - rebuilding Kerberos keys in Keychain, and setting the firewall to allow connections to mDNSResponder and configd. This still does not work once i wake my mac from sleep and try to reconnect. Also, the "allow only essential services" doesn't work either.

    It sounds like this is a problem with my campus's network, but other friends' macs running Leopard connect, my ipod touch connects, etc with no problem. So i am confused, and would like to have a little bit of a firewall.

    thanks
    black MacBook (Santa Rosa), 2.2Ghz Intel Core 2 Duo, 160GB HD, 4GB RAM, Mac OS X (10.5.4), 16GB iPod Touch, 2G 1GB iPod Shuffle, 4G 20GB iPod
1 2 3 4 5 ... 7 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.