Skip navigation
This discussion is archived

macbook air airport disconnecting solution for lots of people.

71344 Views 70 Replies Latest reply: Dec 23, 2009 10:11 AM by lmorris99 RSS
  • Kurt Anglese Calculating status...
    I wish I would have found this months ago! It works like a charm now! I used to always lose signal if I stepped away from my computer for more than 5 minutes. I tried everything. I was first with my Airport Express (g), and continued even after I purchased my new Airport Extreme (n). I'm sure there may be many others that need to know about this. Can someone explain to me exactly what this setting is intended to do and what other implications shutting it off may have?
    iMac G5, Mac OS X (10.4.11)
  • natn2208 Calculating status...
    I did as instructed, and now the home PC appears under 'Shared'. The only problem is every time I try to open it it says 'Connection Failed'. I'm not sure if this is a problem with the PC, or what. Don't suppose someone can help with this?
    But either way, thanks for the help, because at the very least, I'm now one step closer!!!
  • jacoch Level 1 Level 1 (0 points)
    Not really. IPv6 is the successor of IPv4. Currently, an IP address use the format xxx.xxx.xxx.xxx where each block can be from 0 to 255. Unfortunately, with the extensive use of IP addresses (almost every single phone can connect to a network), ISPs start to be short of available IP blocks. That's why IPv6 has been created. But to work properly, you either need to have all network devices support IPv6, or have one of the router doing IPv6/IPv4 translation. Currently, there are no providers supporting IPv6 (at least in our country). So you can for example use IPv6 internally and have your internet gateway do the translation when connecting to Internet. This scenario is possible if all your internal devices are IPv6 compatible. But there are big chances that you are still using IPv4 only. So disabling IPv6 in that situation has no effect. More information on IPv6 here (http://en.wikipedia.org/wiki/Ipv6).
  • Mihai Ciobanu Calculating status...
    My MBA stopped seeing the Airport Express at all. It sees other networks in the building, but not mine. I have restarted the Airport Express, the MBA, tried through Airport Utility, nothing. Both my iPhone and my old PB see the Airport Express without any glitch. The PB runs 1.5.2, just like the MBA, has IPv6 enabled and WEP encryption - but it works.

    Do you have any idea what to do in this case?
    Thanks a lot!
    MacBook Air & Powerbook G4 17, Mac OS X (10.5.2)
  • jmvicaria Calculating status...
    I just tried everything (change channel, wpa, Ipv6) and it looks to work fine in the last 30 minutes. Is the first time in 3 weeks that my MBA is connected so long! Thanks for the advise, I will let you know what happen next tuesday from my office.
    This is my first MAC and I am dissapointed with internet going in and out ! Never happen to me with my PC.
    THANKS
    Macbook air, Mac OS X (10.5.2)
  • Michael King Level 2 Level 2 (230 points)
    TheMiz wrote:
    I have never used Wi-Fi outside my house

    I leave for Mexico on Saturday and I planned on taking the MBA
    I have no clue what I have to do to use the Wi-Fi at the hotel

    Any tips ?

    If you're sure the hotel has wireless, when you get to the hotel, first look for some instructions about their network name and how to log in. Then click the little Airport antenna "fan" in your top memu bar, which should create a drop-down with all the available nets listed. Click the one for the hotel to connect, and enter a password if asked. If not password protedted, your wireless transmission will be "in the clear" and theoretically 'anyone' with the right software could read what your sending and receiving, so be a little cautious.

    In my experience (in America) the wireless net probably isn't password protected but you'll have to go to some web site to log into a server with your guest information, and that will be the gateway to the internet.

    Travel safe!
    MacBook 2.0GHz Core Duo, Mac OS X (10.4.11), MB Air, ruby iMac; AEBS Gig, 3G ipod, Windows-free home since 1984
  • Kurt Anglese Level 1 Level 1 (5 points)
    This is an update to my earlier post where I thought this was the solution.

    The problem returned a few days later. The iPv6 thing probably didn't do anything and it just started working again for a while by chance. I'm back to getting disconnected everytime the iMac (running Tiger 10.4.11) sits idle for more than about 5 minutes. However, I only need to go up to the top right on the signal menulet and reselect my network signal. What could be causing this to loose connection and dim (gray out) the signal bars.
    iMac G5, Mac OS X (10.4.11)
  • stephen w Level 1 Level 1 (5 points)
    Completely switched to Apple...MBA, iMac, iPhone, Time Capsule, Apple TV. Now my MBA can't find the home network!

    How do you change channels on the Time Capsule or Modem?
    MacBook Air 1.8ghz/64gb w/SSD, Mac OS X (10.5.3), iMac Aluminum 20"/Time Capsule 1TB/160gb ATV/Bose QC3's/White iPhone 3G (SOON)
  • old_vine_zin Calculating status...
    Glad to hear that some of you have resolved the problem by specifying which channel your router & MBA connect on.

    However, I travel for business which is why I bought the MBA. I cannot have every hotel, airport, customer, trade show, etc configure their router to channel 1. Quite frankly, if I was only using my machine on my home router, why buy an MBA, the MBP isn't that heavy that I cannot carry it from the kitchen to the den!

    Apple needs to resolve this not ignore it. Claim what they want about the spec but they seem to not have the issue with any of their other equipment. My entire office uses MBPs and I use an MBA, I am the only one with a problem.
    MBA, Mac OS X (10.5.4)
  • 1Peter Calculating status...
    try this:

    look in your

    system prefs -> accounts -> login items

    for something called realplayer downloader.

    if it's there delete it.

    reboot. et voila?

    I ran around in circles with this, til I talked to an L2 (or 3) Mac tech person who has been on this particular issue and recommended this fix. apparently this little daemon runs and continuously asks for updates, which freaks out the network, and then the your network doesn't want to talk to the machine running it anymore.

    good luck!
    macbook air, Mac OS X (10.5.4)
  • mzn Calculating status...
    menajemh,

    thanks for the posting. I just purchased this MBP and received it yesterday. Experiencing intermittent disruptions in connectivity using Airport with my d-link dir-625 wireless router. Using WPA-personal and 802.11N. 2 PCs work perfectly so I doubt its the router. Status bar claims that Airport is still on and connected, but no TCP traffic. I turn airport off, then on, and all worked again for another unpredictable period of time. Upsetting. I am evaluating this for a customer that wants to use this exact MBP configuration for 9 people. There is no way I can recommend this product. Support rep was nice but clearly a novice and had me answer questions that had nothing to do with it.

    I plan to dig deeper, but time is money and will probably send this machine back to them.

    -Mike
    MBP 2.6Ghz Core 2 Duo, Mac OS X (10.5.4)
  • CateinTo Calculating status...
    Hi ... someone mentioned the constant scanning -- my airport is also constantly scanning, at home and on other wifi signals, and periodically dropping. I tried the turning off of the V6 thingy and changed the channel on my airport extreme to 9, but I'm still getting the constant scanning. It's like it can't fix on a signal or something. I've only noticed this to be such an issue since I upgraded to leopard. I do not have the realplayer login item someone mentioned upthread. ANy other thoughts?
    MacBook, Mac OS X (10.5.4)
  • mzn Level 1 Level 1 (0 points)
    Hi ... well here are some new findings from my efforts today:

    1) Even when I have an established/working connection, my Airport monitor still toggles back and forth between the "on" / "scan" status. The Apple Support Rep claims this is correct behavior.

    2) I went into my router's wireless settings and changed from mixed mode (i.e. automatic support for 802.11 b/g/n) and forced it to be ONLY 802.11g. I was connecting at 100+mbits using "n", now with "g" I am at 50+mbits (not liking that).

    The result, after changing to "g" only, is actually good, despite the slower connection speed. I did NOT have one disconnect for over 8 hours and I was running Terminal Server Client over a PPTP-VPN the whole time. Again, not happy about running at 1/2 the speed, but I see now that there must be a poor implementation of "n" on the MBP or the router. Which devise to blame, I have not yet determined.

    After reading this topic over once more, I see there are likely more than 1 problem experienced.

    Will report back as I uncover more.

    -Mike
    MBP 2.6Ghz Core 2 Duo, Mac OS X (10.5.4)
  • mgerbasio Level 1 Level 1 (20 points)
    The only solution that worked for me was setting up a separate router for 802.11n only. Then connecting the MBA in WPA2 mode to the router. It has worked perfectly. The airport will not keep going into scanning mode. It shows scanning for a few seconds then shows I'm connected. This never happened when I was on a 802.11b/g router.

    This isn't a good solution though. Hot spots in hotels and other public places are generally 802.11b/g so the MBA isn't a laptop I can count on when I travel. I forgot about this on my last trip but luckily there was a AT&T 3G signal in the hotel.

    Regards-Michael G.
    Macbook Air, Mac OS X (10.5.2)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (1)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.