1 2 3 Previous Next 156 Replies Latest reply: Jun 13, 2014 7:30 PM by Michjimz Branched to a new discussion.
Pym Cantellow Level 1 Level 1 (0 points)
Hi there to those nice enough to try and help me! Did an erase and install (and zero HD) two days ago on my 1st generation MBP and everything worked fine till today! My Airport suddenly seemed to freeze and I was unable to turn it off. I ended up re-starting to then be presented with the error saying no AirPort card installed! Its also not in the sytem profiler! I have read through the other topics on here already and someone suggested deleting the old airport and making a new one, but I can't make a new one as it is not in one of the services! Please help!!

Regards,
Pym, Owner Gamerswl.com

Message was edited by: Pym Cantellow
  • 1. Re: No AirPort card installed!??
    Judd Stephens Level 1 Level 1 (0 points)
    I'm currently having the same problem. I have tried reinstalling OS X. I have started up in safe mode. I have reset my SMC. I have reset my PRAM. I have preformed the extended hardware test and yet it found zero errors. I am currently using OSX 10.4.11.

    My machine is a MacBook Pro 17in second generation.
  • 2. Re: No AirPort card installed!??
    Pym Cantellow Level 1 Level 1 (0 points)
    having played around I think I found the solution, in another thread someone posted to delete tha appleairport2.kext file but as that wasnt there i tried moving/deleting the appleairport.kext instead and this worked! You can find it in /system/library/extensions/ move it first then reboot (I got some fancy error about cache etc but its ok...I hope!)
  • 3. Re: No AirPort card installed!??
    Judd Stephens Level 1 Level 1 (0 points)
    Thank you for the idea but it did not work for me.
  • 4. Re: No AirPort card installed!??
    vg86 Level 1 Level 1 (0 points)
    I had the same issue and called apple care (I have a macbook pro running os 10.5.2). They had me shut down the computer, remove the power cable and battery. I then had to hold down the power button for 5 seconds. I reinserted the battery and attached the power cord. I was instructed to hold down the command, option, p & r keys will pressing the power button. I had to keep the command, option, p & r keys pressed down until I heard three start-up chimes. After the computer booted I turned on my airport and it was working fine. Hope this helps.
  • 5. Re: No AirPort card installed!??
    mordawdz Level 1 Level 1 (0 points)
    I have the same problem, and this procedure solved it a couple times.

    Although, in my case, the error is coming back every second week. I can't keep on patching the problem by resetting the PRAM.

    Is there anyone from Apple actually reading those threads? It seems we're not the only folks with that issue, can we expect a decent/complete resolution of the issue by Apple in the near future?
  • 6. Re: No AirPort card installed!??
    JonnyCatlst Level 1 Level 1 (15 points)
    Boot to safe mode by holding the Shift key on startup. Once booted, reboot the computer and test.

    Reset SMC by shutting down, disconnecting battery and power cord and holding power button for 5 seconds while they are disconnected.

    Boot to the install disc by holding the 'C' key while the computer boots (with install disc in the optical drive). Check for an Airport menu while booted to the install disc.

    If it is not recognized while booted to the install disc, the Airport Card or logic board will need to be replaced.

    If it is recognized while booted to the install disc and you can see available networks, you will need to reinstall the operating system.
  • 7. Re: No AirPort card installed!??
    Jerry Stuteville Level 1 Level 1 (10 points)
    This holding down command-option-P-R worked for me. Thanks!
  • 8. Re: No AirPort card installed!??
    mtbike139 Level 1 Level 1 (0 points)
    Thanks guys, command option p r worked perfect for me too!
  • 9. Re: No AirPort card installed!??
    Ciguatera Level 1 Level 1 (0 points)
    I have done all those resets and it fixes it for a couple of days and then it comes back again. It seemed like it was fixed for a week and now it froze my computer 5 times today and about 5 random restarts. Every time the airport card seems to loose connection right before the freeze.
  • 10. Re: No AirPort card installed!??
    Heather-9 Level 1 Level 1 (0 points)
    I read that Apple built the antenna into the MacBook Pro's hinge at the bottom of the display. I have also noticed that this issue occurs when I close the lid and when the computer re-awakens.
    Has anyone tried not closing the lid over a long period of time to see if this overcomes the issue?
  • 11. Re: No AirPort card installed!??
    njfan Level 1 Level 1 (0 points)
    I have had this problem too on my MacBook with OS 10.5.2. The airport card worked for months. Sometime after I used the ethernet cable it stopped working (don't know if this is related). I tried the command-option-P-R solution and got one beep (not 3) and it did nothing. I also tried moving the AppleAirPort.kext out of the preference folder (advice from another thread) and that did not work either. Will try the JonnyCatlst suggestion once I locate my install disc.

    This sounds like a widespread problem? Is Apple addressing this?
  • 12. Re: No AirPort card installed!??
    ibdunn Level 1 Level 1 (0 points)
    I have a imac bought new in April 2008 with leopard installed everything working great till I did the most recent update last night 10.5.4. Now my wireless says no Airport card installed. I have tried an archive and install -no help. I found this topic and though it seems everyone talking about laptops I tried shut down pulled power cord and held power button down for 5 secs and then tried the cmdopt+pr while holding power button (a rather clever manouver to say the least) I have a bluetooth keyboard and mouse and could only get the chime 2 times instead of 3. Anyhow --no help!! Still no airport card installed. In network settings there is the option to turn the airport card on --but it doesn't actually allow me to turn it on. Does anybody else have any ideas for me?? I'll be calling apple support in the morning but stuff like this just keeps me trying everything I can think of ... I'll post solution if I ever get one - -(trying to avoid complete re-install of operating system as opposed to the archive and install ..but may have no choice)
  • 13. Re: No AirPort card installed!??
    Tom in London Level 4 Level 4 (1,585 points)
    ibdunn. you wrote:

    "I'll post solution if I ever get one"

    Well, did you? I'm now experiencing this problem
  • 14. Re: No AirPort card installed!??
    vashka0310 Level 1 Level 1 (0 points)
    I have the same issue. It says no airport card installed and I have tried everything on this page and nothing is working. Looking inside the laptop nothing seemed to be jarred loose. I'm at a loss of what to try next. Any suggestions?
1 2 3 Previous Next