Skip navigation
This discussion is archived

iPhone 3G Accelerometer

42019 Views 152 Replies Latest reply: Jan 2, 2009 11:37 PM by ltruong8 RSS
  • Ian Glazer Level 1 Level 1 (5 points)
    Currently Being Moderated
    Jul 13, 2008 10:50 AM (in response to John S. Thomson)
    I am having the same problem. So what's the consensus: replace or wait for firmware?
    G5 iMac, Mac OS X (10.4.1)
  • royalwelsh@mac.com Calculating status...
    Currently Being Moderated
    Jul 13, 2008 11:09 AM (in response to karenclassic)
    I too had exactly this same issue. The Genius I worked with at the Apple Store tried both reset and restore to no avail, and my phone was replaced on the spot. So far, all seems well with the accelerometer on the new phone with no issues whatsoever.

    Thorough, prompt, and professional Apple Care -- always impressive and always appreciated.
    MacBook Pro, Mac OS X (10.5.4), iphone 3g
  • Rüdiger Lettau Calculating status...
    Currently Being Moderated
    Jul 13, 2008 11:34 AM (in response to Ian Glazer)
    I have the same problems with my "German" iPhone 3g. I´m very disappointed because i waited so long to get an iPhone and now it works not as good as the 2g model.
    I hope in the next or in max.2 weeks this will be fixed by an update. If not, i´ll have to replace my iPhone.
    regards
    Rüdiger
    iPhone 3g, Notebook HP Pavilion
  • guidedbyvoip Calculating status...
    Currently Being Moderated
    Jul 13, 2008 1:15 PM (in response to John S. Thomson)
    A friend's iPhone was doing this same thing. When in Camera it would invert the viewpoint 180deg, Safari wouldn't landscape, and other accelerometer app functions would not work properly. Take your iPhone back to the store and they will replace it on the spot.

    You might even be able to back up your old phone and restore it onto the new when you get home, but I would speak to a specialist or genius for the details before doing it.
    MacBook 1.3Ghz, Mac OS X (10.5.4), iPhone 3G
  • danperth Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 13, 2008 6:25 PM (in response to John S. Thomson)
    Wow, sorry to hear you're all sharing the pain, but it's good to know it's not an isolated problem.

    Given WMtoiPhoneconvert's report of firmware 2.0 causing this problem on an original iPhone, I think I'll wait a couple of weeks for a firmware update.

    Those without shortages in their area, who can easily get replacements, might as well get them (that should certainly give Apple an incentive to work on the firmware fix!)
    PC, Windows XP Pro
  • mDiddy18 Calculating status...
    Currently Being Moderated
    Jul 13, 2008 7:01 PM (in response to John S. Thomson)
    It is definitely an issue in the 2.0 firmware. When safari rotates on the touch its just as jerky.
    Dell XPS 410, Windows Vista
  • stefandaversa Calculating status...
    Currently Being Moderated
    Jul 13, 2008 9:20 PM (in response to mDiddy18)
    I really hope it is just firmware. I don't want to have to get my phone replaced. They are most likely out of stock of 16GB Black phones at all the Rogers stores here in Canada.
  • sur4dye Level 1 Level 1 (75 points)
    Currently Being Moderated
    Jul 13, 2008 9:30 PM (in response to stefandaversa)
    the new 2.0 is just making everything lag...
    mac pro, Mac OS X (10.5.1)
  • stefandaversa Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 13, 2008 9:41 PM (in response to sur4dye)
    It isn't even lag with the accelerometer problems for me. After the phone sleeps for a few minutes, the accelerometer completely stops working.
  • SNOOP97DAWG Calculating status...
    Currently Being Moderated
    Jul 13, 2008 10:03 PM (in response to John S. Thomson)
    just return it to an apple store they will replace it on the spot
    HP PAVILION, Windows Vista
  • Cleverhobbit Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 13, 2008 10:22 PM (in response to Cleverhobbit)
    Hmm! I don't know what I did to the phone but the accelerometer of my iphone is working properly now. I tried to put it to sleep mode several times, but the issue appeared no more.
  • Cleverhobbit Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 13, 2008 10:51 PM (in response to John S. Thomson)
    Hmm! I don't know what I did to the phone but the accelerometer of my iphone is working properly now. I tried to put it to sleep mode several times, but the issue appeared no more.

    Edit: Never mind. It happens again. Seem like a trip to the apple store is inevitable.

    Message was edited by: Cleverhobbit
  • derk.dukker Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 14, 2008 4:25 AM (in response to Cleverhobbit)
    I also have this.
    I tried to switch my iphone off and back on with the home button pressed.
    it worked like it was supposed to work except after a while not touched it (5 min) I have the same issue again.
    I also tried it without the home button pressed and that worked too.
    So to me it looks like an software bug... maybe somebody can try the 5A347 build? I can't right now...
    Macbook Pro, Mac OS X (10.5.4)
  • stefandaversa Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 14, 2008 5:03 AM (in response to derk.dukker)
    The Apple stores in Canada don't even have them, gotta go through Rogers. I doubt they have any stock on the 16GB Black.
  • derk.dukker Level 1 Level 1 (0 points)
    Currently Being Moderated
    Jul 14, 2008 5:23 AM (in response to derk.dukker)
    can somebody how also has the 3g confirm that it's working OK...
    In my opinion if it is a software bug than everybody should have this issue right?
    Macbook Pro, Mac OS X (10.5.4)
1 2 3 4 ... 11 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.