Skip navigation
This discussion is archived

Airport Issues with Comcast and RCA Modem

2627 Views 13 Replies Latest reply: Jul 15, 2008 1:04 PM by Christopher Wall RSS
WooHokie Calculating status...
Currently Being Moderated
Jul 14, 2008 7:20 AM
Need help!

I recently moved this weekend and got set up with Comcast for the first time. I've never had a problem with my Airport Extreme until this weekend. I know the modem and cables work because when I plug the ethernet directly into my computer from the RCA modem it works fine.

However, when I plug the ethernet into the Airport I simply cannot connect to the internet. Its bizarre because the Airport light is solid green and my computer recognizes the device and shows me that I have a full signal. Yet when I try to open Safari or Mail, it tells me that I am not connected to the internet.

I have tried rebooting and reseting multiple times. Please help me as I am extremely frustrated and have dedicated hours to trying to fix this already!

Thanks very much!
MacBook, Mac OS X (10.5.4)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.