1 2 3 4 5 6 Previous Next 718 Replies Latest reply: Apr 15, 2010 12:07 AM by JJ Decker Go to original post
  • 45. Re: iPhone applications no longer work
    meridiandevv Level 1 Level 1 (0 points)
    That's what I did. Perhaps chris pirillo (www.chrispirillo.com) will be doing the same as he also has this problem now.
  • 46. Re: iPhone applications no longer work
    theedge103 Level 1 Level 1 (10 points)
    Yeah, that fix worked for a few days...I downloaded iAnywhere last night, and had to change some settings then boom..crash on any app again... ***... did not try my process that worked last time, hopefully it will work, but after reading others responses, it doesn't sound hopeful...

    Anyone from Apple read this? Acknowledge this? Get a new firmware out with a fix!! This is a waste of time to keep this thing running make me (almost) wish for a Blackberry!
  • 47. Re: iPhone applications no longer work
    pmonahan Level 1 Level 1 (0 points)
    theedge103, your fix worked for me as well others. I have not heard of anyone that gave it a try without success initially. I added a few steps that may help make the fix stick. Many of the posts to this and other threads do not have detailed steps listed so its hard to know what is working by process of elimination. It seems that the issue came back once you downloaded a new app. Did you download that directly from your iPhone? If so, that may be the problem. Perhaps there is a bug between iTunes and the iPhone when logging onto the App Store from both iTunes on your computer and the iPhone. The Push feature may also cause a conflict, I'm guessing and have no direct evidence, yet I am not going to take the risk until Apple has a chance to iron out a few more bugs and make things more stable. I have decided to only download apps directly into iTunes and then transfer them to my iPhone on a sync. I will not even open up the App Store icon on my iPhone due to concern that the issue may return. I have had all apps working now for more than a day and have made more than one app download and sync. For those new to reading this thread, I will list the steps that theedge103 originally posted with changes that I have added so that others can give it a try:

    @ Remove all apps from iPhone
    @ Turn off "Push" (May not be needed, but I wanted to eliminate MobileMe Sync as a potential problem)
    @ This eliminates all contacts, bookmarks, etc. on the iPhone, but they will return upon next sync providing it has not been deleted from computer
    @ Reboot iPhone by holding the power button down until prompted to "Slide To Power Off"
    @ Unauthorize and then Reauthorize iTunes on the computer
    @ Login to iTunes Store
    @ Click on your user name on the upper right
    @ Click 'Sign out' on pop-up window
    @ Close iTunes
    @ Open iTunes
    @ Log in to iTunes Store
    @ Check for app updates
    @ Update only those apps that actually have a new version number (You can check the current version of your apps by clicking on one and selecting "Get Info")
    @ Close and then reopen iTunes (May not be needed, but this resolved the problem of showing multiple apps needing updates that were already the same version)
    @ Buy a few free apps
    @ Select Replace Information on this iPhone for Contacts, Calendars, Mail Accounts, Bookmarks
    @ Make sure that the number of apps selected for transfer to iPhone will not fill more than the 9 pages limit of 16 icons each
    @ Sync the data and all apps to the iPhone
    @ Reboot iPhone by holding the power button down until prompted to "Slide To Power Off"
    @ Apps should be working and all videos and music should appear
    @ Only sync directly for now on and only get new apps and updates from iTunes on the computer, then sync to transfer to iPhone
    @ Hold your breath and see if the fix works for you until Apple resolves this for all of us

    Yes, its a lot of steps, but it seems to work and is a better alternative to the time intensive, clean wipe of their iPhone only to find the problem return. I would love to see a few posts from anyone with the same problem to take the steps outlined above and state if your problem either continues or gets resolved so that we can move in the direction of a definitive fix for all.

    I look forward to your postings...

    Thanks, pmonahan






    <Edited by Moderator>
  • 48. Re: iPhone applications no longer work
    Alexander Newman Level 1 Level 1 (30 points)
    I deleted Currency, restarted the phone, and the problem persists...

    I'll try pmonahan's recipe this evening when I get home.

    This is insane. Imagine if the iPhone were an aeroplane...
  • 49. Re: iPhone applications no longer work
    Kevin Parker1 Level 1 Level 1 (0 points)
    I also had this problem. For whatever reason, when I downloaded the 2.0.1 software my 3rd party apps quit working.

    In order to fix it first I spent all day worrying about it. (This is key to have this work.) Then I read the message boards. (Again, key.) Finally, I followed these steps:

    @Deleted all 3rd party apps from iPhone
    @Plugged iPhone into computer to download apps from iTunes to iPhone
    @Everything worked

    Hope it goes as easily for you as it did for me.

    Message was edited by: Kevin Parker1
  • 50. Re: iPhone applications no longer work
    earhere Level 1 Level 1 (0 points)
    After upgrade to 2.0.1, apps were broke. Resynched with iTunes deleting all third-party apps. Reinstalled apps. Joy. All tested apps now work. Call me lucky.
  • 51. Re: iPhone applications no longer work
    Shank2001 Level 1 Level 1 (0 points)
    I am having the same problems. One silly question. How many of us installed the app "NetShare"? I have a sneaking suspicion about this app being the reason this is happening. Here is my situation. After a reboot, all my music is missing (as well as video) and none of the downloaded apps work anymore (apple apps that were included with the iPhone work fine. If you are also having this problem... did you download "NetShare"? If not, please speak up so I can rule this app out.

    Thanks,

    -Sean

    Message was edited by: Shank2001
  • 52. Re: iPhone applications no longer work
    MacCrazyMan1985 Level 1 Level 1 (10 points)
    I had installed netshare. Problems did start after. When I had it on my other device I had problems to. Good point. This could be the bad app.

    I uninstalled the apps.
    did a restore.
    synced mail, ringtones,
    set up mobile me push.
    installed a few apps paid and free.

    No problems as of now. I have not added music or netshare.


    Joel
  • 53. Re: iPhone applications no longer work
    DC-NL Level 1 Level 1 (0 points)
    I have NetShare installed, but not configured yet. But it might be wise to wait.

    I did a restore and still had the problem.

    What seems to work, but is a lot of work if you have many apps (for testing like me), is to redownload the apps to your iPhone over WiFi, one-at-a-time...
    The other apps still don't work, but the re-installed do!
    Will try the lastest solutions later this day...

    Message was edited by: DC-NL: WiFi
  • 54. Re: iPhone applications no longer work
    iFixPls Level 1 Level 1 (0 points)
    It is appearant that it is the copyright protection that prevent the apps from running. The apps are not bugged.

    Removing the apps from iPhone and reinstalling it using iPhone appstore can fix the authorization issue. But you are charged again for paid apps. This is intolerable.

    ==============================================================
    I have got a response from Apple Support:

    I'm sorry to hear that you have been having some problems with your applications. I can certainly appreciate your concern with this.

    *I have checked your account and have found that the reason that you are having these issues is due to the fact that your account has been split into two separate accounts. I apologize for this inconvenience.* (I BELIEVE THIS IS A ITUNES ISSUE)

    Apple is currently working toward a resolution for the issue you have reported. You will receive an email after the matter has been investigated and further information is available.
    =============================================

    Let's hope Apple will find a fix soon. The sole purpose of Apps are the run. Please Apple.
  • 55. Re: iPhone applications no longer work
    DC-NL Level 1 Level 1 (0 points)
    This indeed sounds plausible, the copyright protection. Still not okay and very much not exceptable, but plausible.
    This gives an explanation of what I explained before, that after downloading the apps again to iPhone over WiFi again, they seem to work.
  • 56. Re: iPhone applications no longer work
    Christian Turner Level 1 Level 1 (0 points)
    After upgrading my iPhone 3g to 2.01, all downloaded apps stopped working. I was preparing to do a restore or one of the other lengthy methods, but I decided to try downloading a new app first. It worked. After downloading a free app, which involved entering my username and password, all my apps are working again. I suspect that in my case all my apps were somehow marked as deauthorized. Downloading and authenticating somehow fixed this.
  • 57. Re: iPhone applications no longer work
    meridiandevv Level 1 Level 1 (0 points)
    It's not netshare. I never installed it. My problems started right after iTunes 7.7.1. This is a more fundamental problem than one app could cause. Besides apps. run in their own "sandbox" space segragated in memory for security reasons. An app should not be able to bring down the O/S, or some basic feature of the O/S. The problem therefore is with the O/S or iTunes more "privileged interaction" with the O/S. My opinion anyway.
  • 58. Re: iPhone applications no longer work
    meridiandevv Level 1 Level 1 (0 points)
    Well this sounds like a theory, but wouldn't we expect some message like "this application is not authorized". We get a similar message on iPods and Apple TV. Further, as plausible in isolation as this theory is, it does not address why the iPod media is no longer accessible. A more low level O/S problem or iTunes-O/S problem would possibly explain that, no?
  • 59. Re: iPhone applications no longer work
    meridiandevv Level 1 Level 1 (0 points)
    Some good news on this thread:
    http://discussions.apple.com/thread.jspa?messageID=7827780#7827780

    Looks like the problem has been isolated to iTunes 7.7.1 update. Falling back to iTunes 7.7 clears up this problem for good (at least so far for a few people that have tried it). If you are going to try something, try this, from what I can see it is your best bet to resolve the crash-on-start-apps with missing media problem once and for all.
1 2 3 4 5 6 Previous Next