Skip navigation
This discussion is archived

iPhone 2.0 - Can't locate me in Google Maps

31064 Views 268 Replies Latest reply: Sep 14, 2008 5:23 AM by Adrian H RSS
  • Dr Gordon Freeman Calculating status...
    Mornin' chaps,

    Just to add to the discussion, if your WiFi is on and you are being located it is because the WiFi hub, that you are connected to, has more than likely been registered with Skyhook.

    For me the problem is simple, under 1.1.4 (before the upgrade) the locate me would work fine with WiFi witched off and only using Edge; this is the issue that needs to be rectified.

    Dr Freeman
    Mac Pro 8 core, Mac OS X (10.5.4), iPhone (gen 1) 12" Powerbook
  • daroca Level 1 Level 1 (0 points)
    SC::UK, I agree with your statement the GPRS/EDGE locateme is still not working for me.

    But before yesterday, the WiFi locateme was also not functioning, and I believe this was the case for many other people in the UK.

    Something changed yesterday (externally from the phone) which resolved the WiFi issue. Its not clear why this effected some phones and not others.

    Hopefully it may be possible to resolve the GPRS issue without having to upgrade the firmware again.
    Mac OS X (10.5.4)
  • Dr Gordon Freeman Level 1 Level 1 (0 points)
    Afternoon chaps,

    With reference to the last post I strongly believe that the problem is external to the phone; basically speaking, I doubt we will have to upgrade/download any firmware patches to correct the problem.

    BUT! I was mucking around with my phone whilst on the throne and thought I'd test the Locate Me button...IT WORKED! And I had the WiFi switched off! However...not again...I've just tried it and the icon has been spinning for about 5 minutes.

    Somehow I just got lucky

    Dr Freeman
    Mac Pro 8 core, Mac OS X (10.5.4), iPhone (gen 1) 12" Powerbook
  • DrewInTheUK Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 14, 2008 4:41 AM (in response to DrewInTheUK)
    Little update on my previous post. After talking to O2 support (useless) and Apple UK support (better) twice, I have had it confirmed that cell/mobile tower triangulation is currently broken in the UK. This is a known problem with the 2.0/2.0.1 firmware and affects the v1 and 3G iphones. It does not affect GPS or WiFi based locating. The CSR said they are getting "many, many" issues logged on this and engineers are working hard on a fix that will likely involve another firmware update.

    Just as an FYI, I am pretty sure this wasn't a problem with the pre-release 2.0 firmware that leaked out onto the net about 12hrs before the official one (search appleinsider archives for details). They had the same version number (as far as iTunes was concerned), but slightly different build numbers. Silly me, thought I better get on the official firmware and forced the re-upgrade, loosing location features in the process...

    At least there is some chance of this getting fixed eventually. But as usual, Apple's silence is deafening on this issue. How can a company get one aspect of it's PR so right (keynotes, product launches, advertising campaigns) while getting the other (support issues) so wrong. Apple, you are ruining all your good work with this approach and it is so simple to fix....
    PC, na
  • eccparis Level 3 Level 3 (740 points)
    Currently Being Moderated
    Aug 14, 2008 6:51 AM (in response to DrewInTheUK)
    FWIW, the leaked version was for the 3G iPhone hence the slightly different build number, 1.2xxxx as opposed to 1.1xxxx. Maybe I'll get up my nerve and install the 3G version on my original iPhone as a test since my 3G iPhone works fine.

    (I upgraded to the 3G in order to give my legally unlocked French original iPhone to my mother, who has a Blackberry on T-Mobile USA. Supposedly her T-Mobile SIM card will work in an unlocked iPhone with all functions except visual voicemail. Looks like I may as well use my original iPhone for a few tests here before pawning it off to her!)
    MacBook (Intel) / G4 iMac (PPC), Mac OS X (10.4), various external HDs, original and 3G iPhones, iPod... and I sing, too (really!)
  • pl_svn Calculating status...
    Currently Being Moderated
    Aug 16, 2008 3:10 PM (in response to SC::UK)
    Hi everyone. Milano, Italy, here and...

    ... my original iPhone's problem, after it was updated to 2.0 is exactly the opposite you all are experiencing: locateme, in Maps, stopped working when connected to a wi-fi network but works on cellular connections (even if it's way less accurate than it used to be on 1.1.4)

    This was my situation until yesterday then... today everything is working again (and it's also back to good accuracy). So... seems it was a Skyhook problem, not a bug, but... I'll keep my fingers crossed another few days!
    PowerBook G4 17" 1,67, Mac OS X (10.5.4), iPhone 1st gen
  • daroca Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 17, 2008 1:59 PM (in response to pl_svn)
    Today I was trying the locateme function when I was near Elstree, and it worked using the GSM network, there was no wifi connection.

    I tried it a few times, and it succesfully located me within about 30-50 meters radius, it look about 10-20 seconds to work each time.

    Since then I tried to use the locate function in another of other locations today and it fails, so it appears that certain GSM basestation do work with f/w 2.0.1.
    Mac OS X (10.5.4)
  • scottnorville Calculating status...
    Currently Being Moderated
    Aug 18, 2008 6:40 AM (in response to daroca)
    ok, as per previous threads, I have managed to get the maps to work and pin point to exactly where I am via wi-fi gps etc!

    I have looked at various sites, and no-one really knows what's going on and just blaming everything on the new upgrade 2.1.

    This is wrong.

    The iphone just needs a little 'kick start' in finding the location on where you are, after this process (please see below) it will work fine as it has with mine and my girlfriends iphone.

    1) Turn off iphone by the home button and the screen off switch (located on the top) keep both pressed until the phone turns off by itself.

    2) Restart the phone OUTSIDE, and leave OUTSIDE for 10 minutes.

    3) Turn the phone back on and go into maps.

    4) DONT HIT LOCATE ME BUTTON, but manually enter postcode/zipcode in the area you are at.

    5) The pin will drop into the position you have entered.

    6) Now this is where it works, press the locate button the the bottom left, this will take about 30 seconds max to find you.

    You will now see the blue dot on the exact location you are standing in.

    THIS WILL NOT WORK INDOORS ONLY OUTSIDE.

    I hope this helps.

    Scott
    iphone 3G
  • William B. Mcintyre Level 1 Level 1 (135 points)
    Currently Being Moderated
    Aug 18, 2008 7:08 AM (in response to scottnorville)
    I think you may have not read that this problem (despite some tangents) has to do with non 3G phones (although it seems that more and more issues are cropping up with the 3G version), therefore they have no GPS and locate themselves from Cell tower triangulation, and as such there is no reason to leave the phone outside for 10 minutes.

    This work around may well work for 3G phones having issues.
    MacPro 3GHZ, Mac OS X (10.5.3)
  • marisa8184 Calculating status...
    For first generation iPhone this is still not fixed with the new update released today. How disappointing.
    Dell, Windows XP
  • William B. Mcintyre Level 1 Level 1 (135 points)
    Currently Being Moderated
    Aug 19, 2008 1:39 AM (in response to marisa8184)
    Welcome to the world of Apple (from an increasingly bitter user), it's an old product you see, why should they bother fixing it.

    This update has done diddly squat as far as I can see to first gen iphones, except now some of my apps don't work, and I had to wait about an hour for my phone to backup (how long does 6gb take to copy off?)
    MacPro 3GHZ, Mac OS X (10.5.3)
  • Graham Lucas Level 1 Level 1 (45 points)
    Currently Being Moderated
    Aug 19, 2008 2:30 AM (in response to SC::UK)
    The locate button on maps now works for GSM, EDGE and WiFi on my 1st gen iPhone - and has been for several days now. I didn't apply any updates, it just started working again on my iPhone - and both my colleagues' iPhones.
    MacBook 2GHz and iMac 24" white, Mac OS X (10.5.4)
  • tvrs3 Calculating status...
    Currently Being Moderated
    Aug 19, 2008 4:29 AM (in response to SC::UK)
    2G iPhone UK O2 user here.

    Just upgraded to 2.0.2 and locate still doesn't work.

    If WiFI is on, it works fine.
    If GPRS/Edge is just tries to locate for ever...

    Interestingly, it seems to work fine via the API (ie: any program that uses locate works fine), just not Google Maps.

    This has been broken since the 2.0 rollout with still no sign of a fix. Poor show Apple.

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.