Skip navigation
This discussion is archived

MacBook Pro Blank Screen (Built - in & External)

373790 Views 703 Replies Latest reply: Sep 26, 2008 7:38 AM by Nubz N. RSS
  • Michael Moy2 Calculating status...
    Currently Being Moderated
    Aug 26, 2008 4:24 AM (in response to rebooter)
    I have three MacBook Pros from August 2007, January 2008 and February 2008. The one from August died Sunday so I brought it in yesterday. They wanted $310 for the repair. I called AppleCare later that night, explained that this was a product problem in the news and on their discussion board and that I expected them to cover it. The supervisor said that they would cover it because it was just outside the warranty but didn't admit a product problem. They will repair the August 2007 system and provide a 90-day warranty on the motherboard.

    I did some testing on the February 2008 system (Penryn) and found that GPU temperatures run about 73 degrees C when running Windows XP at no load. I did a little reading and found that this was generally considered hot. So I bought a USB fan (Thermaltake) and put it under the laptop and it dropped the GPU temperature to 64 degrees C. Same effect when I put the cooler over the keyboard (I use an external keyboard and mouse with the system). I plan to try some experiments with two fans including trying the fans with the battery removed so that the fans can more directly cool the hot parts of the laptop. The only other supplier of these fans that I know of is Antec.

    I find that Windows XP results in a warmer MacBook Pro compared to Mac OSX so I will use an external fan when running Windows at home or the office. I need to do some testing to find the GPU temperatures (I hope that there's a utility for this somewhere) running Mac OSX to do some testing. I don't do anything graphics intensive so I'd actually be fine with integrated graphics. It would be nice to have a way to turn off all of the fancy graphics stuff in the nVidia chip.
  • marka29 Calculating status...
    I have a MacBook Pro 2.2GHz purchased back in May. Initially had all kinds of kernel panics, sent in and the replacement logic board seemed to fix the problems. Until this morning, now I get no display video (external too). I installed Windows XP last night using Virtual Box and it worked fine, although I did notice the laptop was a bit hot.
    MacBook Pro, Mac OS X (10.5.4)
  • Heebie Calculating status...
    Currently Being Moderated
    Aug 26, 2008 9:53 AM (in response to marka29)
    I've just been faced with the same as all of you guys. *Shuts the lid, goes out, comes back, no screen. Forces shut down, boots up, no screen, zaps all the PRAM and NVRAM, performs tricks as on this forum, despairs, goes to Apple Store, waits.*

    I emailed Steve Jobs, though. This is what I said:

    Dear Steve,

    My name is (NAME) and I'm a student (16 years old) in the UK,
    using my MacBook Pro to aid my studies. I've been the main instigator
    of a mass conversion to Mac in my classes at school, explaining and
    helping people to make the switch. I've placed a lot of confidence and
    trust in Apple and Macs in particular (not having had a great
    experience with iPods). It seems that after only a year of having my
    first Mac and having used it like a power user, writing little apps
    for myself and friends, I have lost faith with the machine... The
    computer for me is more of a necessity to me when at school, but even
    so not having it at home is a major problem.

    I bought my MacBook Pro last July from your retail store in (MY LOCAL
    STORE) and until yesterday it's been the best thing I've done.
    I've enjoyed using it and all its great futures for the whole year up
    until now. I had a problem, whereby the screen would not display
    because of a faulty logic board. I will (or my father will) have to
    fork out £606.30 GBP for a new logic board, the labour cost and of
    course VAT because we chose not to buy Applecare. I would be writing
    to you, however, even if I had decided to buy the plan.

    Earlier this morning, I phoned Applecare in the UK asking them what
    they thought the problem with my Pro was. They were as helpful as they
    could have been over the phone and suggested that I should go back to
    (MY LOCAL STORE) to talk to a Genius there. Luckily I booked myself in the
    night before and I've just come back.

    If this was a one-off problem that doesn't happen often, I would not
    be writing to you now. However, it has been brought to my attention
    that many people have had problems with this particular model of
    graphics card. Here are some, not all, of the sites and documents I've
    found that concern this particular problem:

    https://spreadsheets.google.com/ccc?key=pV-CKzYqbB6dLQRx8wpC2aw

    http://news.softpedia.com/news/NVIDIA-Faulty-Chips-Reported-on-MacBook-Pros-As-W ell-91707.shtml

    This link shows that Dell has acknowledged the problem with the GPU
    from NVidia:
    http://direct2dell.com/one2one/archive/2008/08/18/nvidia-gpu-update-dell-to-offe r-warranty-enhancement-to-all-affected-customers-
    worldwide.aspx

    http://www.pcworld.com/article/149055/delltakes_heat_for_faulty_nvidiachips.html

    http://www.macnn.com/articles/08/06/27/macbook.pro.video.glitches/

    http://www.engadget.com/2008/07/02/nvidia-says-significant-quantities-of-laptop- gpus-are-defectiv/

    http://www.hortont.com/blog/2008/06/macbook-pro-santa-rosa-a-fatal-flaw/

    -------

    Of course these sites do not necessarily have all the information at
    all, but it seems that although Dell has admitted the fault occurring
    with the faulty NVidia GPUs, Apple has not. When I spend £1600 (GBP)
    on a notebook which I expect to keep for at least 5 years, should I
    really expect a fault that could be resolved to linger and hamper not
    only my experience with the computer itself but moreover my ability to
    use it at all? This is I'm sure what the other people who have had the
    same problem (not just those whose warranties have expired) feel.

    Is there a reason that Apple hasn't tackled this relatively small, yet
    hugely important problem? Or is the company choosing to divert most of
    its horsepower to developing new products? For a problem which is most
    certainly not the fault of the customer of for time's toll, perhaps
    some sort of permanent solution for all those affected is a
    appropriate.

    I hope that I can once again rely on your great computers without
    having to worry about hardware problems in the future and that this
    issue can be cleared up swiftly and efficiently à la Apple.

    Sincerely,

    -(NAME)

    Tel: +44(TEL)
    Email: (EMAIL)
    MacBook Pro Serial No: (SERIAL)
    Repair No: (REPAIR)

    ------------------------------------------------------------

    And this is Steve's reply:

    (NAME)

    Apple never used the faulty nvidia chips.

    Best
    Steve

    Sent from my iPhone

    ------------------------------------------------------------

    Interesting! I suppose he knows best. What do you think?
    MacBook Pro, Mac OS X (10.5.4), Dead Logic Board (NVidia Graphics)
  • John Ciaran Frawley Calculating status...
    Currently Being Moderated
    Aug 27, 2008 1:16 AM (in response to rebooter)
    Hello,

    This is my first time posting on this thread.
    I have lots of Apple products that I have purchased over the last 7 years.
    Up until now most problems have been fixed quickly.
    This is the first issue that really scares me as my MBP is about one month out of warrant and I did not purchase Apple care.
    This morning my MBP was working fine and I turned it off to go do some work. When I started back up the screen was black but the computer was turning on.
    After playing with it for about half an hour the screen came back on and the grey launch screen spun for a LONG time (45 min) and then the computer launched.

    From this point on every time I have started the machine I am being asked to log in and enter my password which it has never done before.

    About 12 hours later after some normal use and troubleshooting the blank screen happened again and was fixed after a half dozen restarts.

    I ran disk utility this morning and verified the disk getting an error. "Invalid directory item count. It should be 36 instead of 35"

    Then I reset the PRAM a few times.

    I plan to launch from the startup disk tomorrow and try and fix this disk utility issue.

    Although I hope this works I am very worried that the issue will be my chip set and Apple (who I have given tons of busines$) might try to charge me to fix this problem.
    Off the top of my head I must say that if they do I will give serious consideration to becoming an ex Apple customer.

    Best of luck to everyone and hopefully I will fix this myself.

    J
    MBP 17" 2.4Ghz, Mac OS X (10.5.4)
  • Jorge Arroyo Gonzalez Calculating status...
    Currently Being Moderated
    Aug 27, 2008 4:48 AM (in response to rebooter)
    My computer is back with a new logic board and version MBP31.0070.B07 of the firmware (the latest). Everything is working fine right now but the left speaker has a problem (sounds too soft) so I guess I'll have to take it back before the three months repair warranty is up.

    Apple repaired the computer for free because of the 2 year warranty that most European countries have, so I guess I'm pretty safe if the problem re-appears during this year...

    -Jorge
  • Vishal Joshi Calculating status...
    Very annoying - my MBP display died yesterday (purchased in june 2007) Tried everything as outlined in this forum, even purchased new RAM to check if it was the memory - nothing.

    When I turn it on, the sleep light comes on right away.. and keeps pulsating slowly (yes, I deleted the sleep image, etc) Before I take this POS to the apple store.. I have a question.

    Is it possible to get an image using a USB to DVI device? I know the graphics card is shot, but still.. anyone have ideas?
    Mac OS X (10.4.11)
  • what_the Calculating status...
    Currently Being Moderated
    Aug 27, 2008 6:22 AM (in response to rebooter)
    There are a lot of posts here, and I thought this problem was unique (assuming I'm having the same one). Especially since the local apple store said they'd never heard of this problem. After reading the top 20 of these responses, I think I'll stick to my fix....

    unplug from external power source, eject the battery, wait 10 seconds, reinsert battery, boot

    (just like my old dell running microsoft apps that froze up)

    ps. I do not have an external monitor, the macbook screen "freezes?" after the thing has either a) gone into sleep mode when left open or b) just won't "light up" when the lid is opened.

    Good luck
    macbook pro
  • Segovius Calculating status...
    Hi, stop the train, I'm climbing aboard....

    Brief sorry tale:

    1) Bought MBP June 2007
    2) a few weeks back started to notice corrupt text, random freezes. No boot problems as of then. restart fixed.
    3) 10 days or so ago more frequent freezes accompanied by severe screen artifacts which took the form of horizontal purple/pinkish parallel lines down screen.
    4) Lines continue on start up followed by kernel panic after grey start up screen. Happens every time attempt to reboot.
    5) Leave overnight: starts up fine - no problems for 5 days allowing me to back-up and do some work.
    6) Few days later problem repeats; lines, artifacts, freezes and KPs. Cannot boot.
    7) Take to local (Spain) Apple Reseller who quotes 1100E and says is logic board. I decline this price BUT when I get the MBP back home (today) then am having the black screen problem that is mentioned here for the first time. I conclude that both my original different issue and the Black Screen of Death are related.

    Not sure what to do here, might try Apple though am a month or so out of warranty. Just thought I'd document the original precursor issue in case it is of any relevance.

    PS: anyone know how to use screen sharing which has been mentioned a few times? I can connect to the dead MBP through Firewire mode on my MacBook but don't know how to screenshare....cheers!

    @ Jorge: I am in Spain, do they give you the 2 years leeway off the bat or do you have to ask/hassle them for it? What's the best way to approach it would you say?
    MacBook Pro, Mac OS X (10.5.4)
  • weisserj Calculating status...
    Currently Being Moderated
    Aug 27, 2008 2:14 PM (in response to rebooter)
    This is very pathetic and sad that this had been going on for so long. I have the same problem as everyone else- blank screen but you computer still boots.

    I brought it to an authorized "repair" place because I have the applecare and I figured I wouldn't lose any data because after all it is the graphics card that has issues not the hard drive. They tell me it will probably take two days to fix.

    after 4 days of no contact with the store I call them and ask what's up. They tell me that there is something wrong with the logic board and I will lose all of the data and there is no way for them to access it.

    I was really p-o'd so I decided to go get it and try and get at the files by myself.

    After about 20 minutes I found this thread.

    I couldn't read it all and I couldn't get much of anything to work.



    I ended up being able to access my blank screen computer with a crossover cable and cyberduck. Those idiots at the computer store couldn't figure this out? It was very easy.

    I am almost done backing it up and then I'll bring it in so no matter what they do I'll at least have my data.
    17inch Macbook Pro, Mac OS X (10.4.9)
  • kimptoc Calculating status...
    Currently Being Moderated
    Aug 28, 2008 1:48 AM (in response to weisserj)
    Me too!

    Last night screen remained blank after a restart, but it starts ok as I can get in via VNC (luckily I turned it on recently).

    However it did come back after one restart, but then failed to work on the next restart...

    Another just out of warranty, non-applecare buying consumer, so lets see what Apple respond to my enquiry...

    Regards,
    Chris
    Mac OS X (10.5.4)
  • manubalde Level 1 Level 1 (0 points)
    Currently Being Moderated
    Aug 28, 2008 3:19 AM (in response to kimptoc)
    I have the some problem, i hope apple take care of their users fixing the problem in and out warranty as soon as possible.
    Manublade, Italy
    Macbook pro 2.2, Mac OS X (10.5.4)
  • davan Calculating status...
    Currently Being Moderated
    Aug 28, 2008 4:22 AM (in response to rebooter)
    It happened today after waking up my mbp from sleep, this only 6 weeks after the first logic board replacement. (more than annoying, when you work with your toys)

    Maybe it's to expensive to make it official?

    Thankfully, (but still strange for us the customers) we hear (in this thread & thanks to a young UK individual) Apple's ceo made the right decision in buying the working gpu's not the faulty ones, like the guy's from Dell & HP did, lucky us.
    I see it as an unacceptable replacement cycle for a 12 months old 2,799.00 euro computer.

    Should'nt a 3rd replacement qualify for a machine replacement or something? If it happens, after experiencing this (the 2nd time so shortly after my original, 6 weeks old replacement) I consider this a broken machine with so many breaks in my work cycle.
    MBP 3.1 SR, 2.4, 17", Mac OS X (10.5.4)
  • Sternocleidomastoid Calculating status...
    Currently Being Moderated
    Aug 28, 2008 7:44 AM (in response to davan)
    You would think wouldn't you? That after the second fails that they should replace it and deem the machine bad.

    Well, in my case, they will not. After having it go out with this exact problem, They replaced my logic board, and 1 day later, I had the same issues. So i took it in again, and had it fixed, only to have it break 2 days later. So i then attempted to bring it to the Southlake store in Texas where they attempted to fix it in store, in a week with no problem. But as Friday came around, they had not even touched it. So I took it from them and called in Apple Care since I moved out for college and wasn't going to be in the state anymore (which they had a hard time understanding).

    So I got it back and within TEN MINUTES, I had a graphics card problem!

    So for the past month and a half, they are still just fixing it, with the same part over and over again. . .
    MacBook Pro SR (Sept 2007), Mac OS X (10.5.4), Windows XP SP3
  • Michael Moy2 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Aug 28, 2008 8:23 AM (in response to weisserj)
    When I brought it in to the Apple Store, they asked for the username and SuperUser password. They said that they would wipe the disk if they didn't have the SU password which makes sense as they wouldn't be able have full access to the system otherwise. I didn't backup the hard disk as I checked with our daughter on the contents of the laptop. She indicated that she would lose a little work but nothing critical. We have three MacBook Pros, one for me, one for our son and one for our daughter.

    I bought two Thermaltake USB fans and plan to buy several more (though the others might be Antec). At home, our son is using the fan whenever he uses his MBP. I use my fan whenever I use my MBP (17 inch model). I'm considering adding AppleCare to all three machines (I'll ask them if I can add it to the one out of warranty as they're replacing the motherboard). This will cost me about $1,000 for the three machines. I'm wondering if it would be cheaper to just replace the motherboard when they fail as the Depot repair cost is less than the cost of AppleCare. My guess is that chips after late September or October will be okay - the problem is that you don't know if you're getting something recycled. I read that nVidia had a lot of 8400s and 8600s in inventory (I wonder why) and it wouldn't surprise me if they tried to dump those off on someone for desktop chips where they are less likely to fail.

    I've told the folks in my office about the problem and people with MBPs are looking for solutions. One of the first is to monitor GPU and CPU temps. I'm using nTune (from nVidia) and Real Temp when running Windows. I have smcFanControl on Mac OSX but would like to get something that monitors the GPU temperature on Mac OSX. Any suggestions?
    MacBook Pro 17 inch, Windows XP Pro
  • Smarty- Calculating status...
    Cheers to everyone here,

    my MBP "died" last Friday. Blank screen on internal and external display. Bought the machine late June 2007, so it is 2 month out of warranty now...

    Called Apple support hotline in Germany. The guy told me to zap PRAM and to reset SMC (we did it together on the phone). Had no effect. I told him about the Nvidia thing and this thread here. He told me, at Apple, they do not know anything about it... ;-. I should go to a certified retailer and get a proof, that it is a hardware defect along with some calculation for the costs to fix it. "Maybe we can do something about it...." (that is what he said). Since i work abroad during the week, i did not have an opportunity to do so...

    Message was edited by: Smarty-

    Message was edited by: Smarty-
    MacBook Pro 2,2 Santa Rosa, Mac OS X (10.4.11), 4GB RAM, 120 GB HDD, 128MBVRAM
1 ... 32 33 34 35 36 ... 47 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.