Skip navigation
This discussion is archived

unknown error occurred (0xE800002E).

25583 Views 76 Replies Latest reply: Nov 22, 2008 12:50 PM by jjaggers RSS
  • thomas witt Calculating status...
    Currently Being Moderated
    Sep 8, 2008 12:56 AM (in response to NYR)
    I have exactly the same problem. This is really annoying!
    iPhone 3G
  • JamesHT Calculating status...
    Currently Being Moderated
    Sep 8, 2008 6:39 AM (in response to SASanderson)
    I tried this fix, but it resulted in most of my apps disappearing from the list in iTunes. My Mobile Applications folder is full of files like "Units.ipa", "Units 1.ipa", "Units 2.ipa", "Units 3,ipa", etc. Trying to follow the above directions didn't work for me.

    Deleting the app from the ipod and then putting it back is a temporary fix at best. Where it becomes are real problem is when you have to do it with an app that keeps it's own data. An app like Gas Hog becomes completely useless when you lose your milage log every time the app gets updated.

    Also, iTunes is VERY confused about available updates. The Applications item in the library often has a number after it, indicating that updates are available. When I click the Applications item, the Applications pane says that there are updates available at the bottom of the screen. However, clicking on that will take me to another pane that, more often than not, tells me there are no updates available, lists updates I already have, or if it lists multiple updates, often fails to display the "update all" button.

    Is there a safe way for me to remove all the apps, clear out the Mobile Applications folder, and redownload everything and start from scratch? Would that fix this mess?
    hand built, Windows XP Pro
  • SASanderson Calculating status...
    Currently Being Moderated
    Sep 8, 2008 7:27 AM (in response to JamesHT)
    JamesHT,
    What you say in your last paragraph is what I did in my instructions. You move the apps out of iTunes and your Mobile App folder, get rid of the older versions of the apps, rename to eliminate the duplicate suffixes (_1) and then reinstall them onto an iPhone which has had third party apps wiped. Reinstalling the apps into their original folders, then setting up the phone to sync all apps, gives what you are asking for. However, you do lose all customization and data.

    It worked for me. Previously I had been completely unable to download and install the update 1.1 to VelaClock, because VelaClock 1.0 was still in the Mobile Apps folder.
    MacPro 8 core, Mac OS X (10.5.2), 8 GB RAM
  • jaedyn Calculating status...
    Currently Being Moderated
    Sep 8, 2008 11:44 AM (in response to JCC123)
    YOU WROTE:

    Hi folks, all you have to do to fix this problem is this:


    1. Uncheck the apps in iTunes so that when you sync, it will remove it from your iPhone.

    2. Re-check it in iTunes so that it will put the Apps back onto your iPhone.

    That's it. You will not see the error message anymore.
    <<<<


    This worked for me!!!!!!! I had a problem where I was getting that error message, I believe because my handset corrupted and needed to be restored. iTunes then placed the most recent backup (a week old) onto the handset. I think a few apps had been updated by apple since then- and for some reason iTunes was choking during the sync when it got to these particular apps.

    I did exactly what this person said to do- very easy- uncheck the troublesome apps, sync, recheck them, sync, et voila!!!

    Jaedyn
    G5, Mac OS X (10.4.11)
  • KentGoldings Calculating status...
    Currently Being Moderated
    Sep 9, 2008 12:53 PM (in response to JCC123)
    Nice fix proposed by JCC123. It worked perfectly for me. I was up to six updated apps with error messages, and this fixed all the problems.
    True, you lose the associated data, but I didn't have any data I couldn't afford to lose so it didn't matter to me.
    Hopefully, this will all be straightened out with the 2.1 update to the iPhone software.
    iMac, Mac OS X (10.5.4)
  • Big Scary Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 9, 2008 8:01 PM (in response to thomas witt)
    Does anyone know if installing Itunes 8 has fixed this syncing error. I still haven't done anything with my Stuff Radar program that seems to need an update but wont sync to my phone due to this error. I wont delete it or ill lose all of the info I had added to Stuff Radar so far at least 550 CD and movie titles.
    Windows XP
  • reagan9000 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 9, 2008 8:55 PM (in response to Big Scary)
    Still broken in iTunes 8.0 on Leopard.
    iMac 24" Intel, Mac OS X (10.5.1), MB, MBP, ATV are in the hizzouse
  • Big Scary Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 10, 2008 12:50 AM (in response to reagan9000)
    I guess I won't do the ITunes update then. I've heard nothing but bad things so far about 8 and if it won't fix this Application bug then I won't update.
    Windows XP
  • Subsector Calculating status...
    Currently Being Moderated
    Sep 10, 2008 2:32 AM (in response to reagan9000)
    Still broken in iTunes 8 on Leopard with iPhone 3G
    MacBook Pro, Mac OS X (10.5.4)
  • ktrides2 Calculating status...
    Currently Being Moderated
    Sep 10, 2008 4:53 AM (in response to NYR)
    Same problem. I want to update my apps, but the list of apps not loading to my iphone is up to 15. I don't feel I should have to jump through the hoop of uninstall - reinstall. It should just work, especially since it worked before.

    But...I will try the re-installation tonight.

    Thanks to everyone who contributes their experiences
    hp pavillion, Windows XP
  • ktrides2 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 11, 2008 4:36 PM (in response to ktrides2)
    I decided to wait and see if tomorrows (hopefully) update to 2.1 fixes this before I delete everything.
    hp pavillion, Windows XP
  • pl_svn Calculating status...
    Currently Being Moderated
    Sep 11, 2008 5:51 PM (in response to ktrides2)
    ... knock on wood but... at least iTunes 8 auto-deletes old app's version after an update
    PowerBook G4 17" 1,67, Mac OS X (10.5.4), iPhone 1st gen
  • glaurent Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 12, 2008 7:51 AM (in response to ktrides2)
    Apparently it doesn't.

    I've just updated to 2.1, after which there was an update for one of my installed apps available (DataCase). The application upgrade gave the same old error, and I had to de-install/re-install it again. Very annoying.
    mac pro, Mac OS X (10.5.1)
  • Stuart Greenwell Level 1 Level 1 (15 points)
    Currently Being Moderated
    Sep 12, 2008 8:13 AM (in response to NYR)
    Same problem after iTunes 8 and iPhone 2.1

    Does anyone know if these apps are actually updating and these errors are lingering, or if it is blocking the update?
    Macbook Pro 2.2Ghz, Mac OS X (10.5.4), iPhone 3G, AppleTV, iPods (Nano and Shuffle) / Airports (Extreme & Express)
  • ATRB72457 Calculating status...
    Currently Being Moderated
    Sep 12, 2008 8:15 AM (in response to glaurent)
    Same here. After the 2.1 update, I still can't update apps from the phone without the update error, and trying to update from iTunes I'm still getting the 0xE800002E error. At this point I'm seriously considering wiping it and starting over. This has been occurring constantly pretty much since I installed the 2.0.2 update.
    Macbook Pro 15" C2D, Mac OS X (10.5.4)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.