Skip navigation
This discussion is archived

Newly purchased applications won't open

21292 Views 21 Replies Latest reply: Mar 13, 2009 11:43 PM by Mark Watkins RSS
1 2 Previous Next
junepost Calculating status...
Currently Being Moderated
Sep 6, 2008 11:18 PM
I have just purchased a dictionary application for my iPhone and also downloaded a free Wikipedia program. The applications show up on my computer and on my iPhone. When I open the applications, the go to the home page (on Wikipedia) and a black blank page (on the dictionary program), stay open for 1 second, then disappear back to the iPhone main screen. When my husband hooked up his iPhone to my computer, the downloaded onto his iPhone and work perfectly! I tried to purchase the dictionary program again (and download the free Wikipedia program again). The iTunes store keeps informing me that I purchased them already and asks if I want to download them for free again. Trying this several times has not worked. What can I do?
MacBook, Mac OS X (10.5.4)
  • eq2675 Level 1 Level 1 (35 points)
    Currently Being Moderated
    Sep 7, 2008 2:12 AM (in response to junepost)
    Just purchased my Iphone 3G today. None of the free or one that I purchased 3rd party apps while using the phone would completely load. The screen would come up on the app, stay for a few seconds, then go back to the main screen.

    I then deleted all 3rd party apps and downloaded them using Itunes on my Mac. Then installed them on the Iphone.

    They work!
    Black MacBook 2.2 Ghz 4 GB and Mac Mini 1.66 Ghz 1 GB, Mac OS X (10.5.1)
  • Sakuraz Calculating status...
    Currently Being Moderated
    Sep 7, 2008 2:51 AM (in response to junepost)
    I've had this problem right after I restored.

    I tried erasing settings, erase all data, erasing backup, setting it up as a new iPhone.....nothing worked.

    Then I read the above reply and tried downloading via iTunes.

    In order for me to sync the files however, I had to Authorise the computer.

    The apps work perfectly now.
    Windows Vista
  • kydemocrat Calculating status...
    Currently Being Moderated
    Sep 8, 2008 12:26 PM (in response to Sakuraz)
    I had the exact same problem on my iPhone purchased one week ago. I downloaded four free apps using the phone, but they wouldn't open. I deleted them from the phone and synced my phone w/my MacBook and now they all work.
    MacBook, Mac OS X (10.5.4), iPhone, iPod
  • Sojourner1 Calculating status...
    Currently Being Moderated
    Sep 8, 2008 3:56 PM (in response to Sakuraz)
    I had the same problem. None of the downloaded Apps worked. It didn't matter whether they were free or purchased. I talked to the guy at the Genius bar, he recommended I go home, restore the phone and when it asked me whether I wanted to re-download apps from the computer vs. start up a new phone, I was to choose the new phone. That way none of the previous Apps (that were on the computer would be re-loaded onto the iPhone). After the iPhone restarted, I used the Apps program on the iTunes to download the previously erased Apps. Each of those Apps didn't work either. I tried this method twice.

    I read this thread and downloaded the Apps from iTunes (which then re-installed them onto my iPhone with the sync). I went through the "You previously downloaded this...." clicked, YES and downloaded the App. This worked. The re-downloaded Apps worked.

    But would I have to download Apps via iTunes and not via my iPhone Apps Store? I tried downloading several programs one-at-a-time and they work.

    I don't know what the original problem was, or how this all got started. Doesn't seem to make sense to me. Oh well, I better cancel the appointment I made with the Genius Bar for tomorrow - your suggestion worked better than the guy behind the bar. THANK YOU

    Please be aware that once you RESTORE, all NOTES, phone messages etc...will be wiped out of your iPhone, I suggest you e-mail your NOTES to yourself to save them.
    Powerbook G4 17", Mac OS X (10.5.2), Axis camera 207w
  • andy198456392 Calculating status...
    Currently Being Moderated
    Sep 9, 2008 2:27 PM (in response to junepost)
    Hang on a minute! This isn't solved at all

    I want to be able to download apps from my ihpone, be stuffed if I will continue to download through Itunes

    This needs to be fixed/addressed!
    macbook and iphone 3g, Mac OS X (10.5.4), nil
  • Sojourner1 Level 2 Level 2 (215 points)
    Currently Being Moderated
    Sep 9, 2008 4:39 PM (in response to andy198456392)
    That's what I was afraid of, but I was able to successfully download apps from my iPhone without further issues. That includes apps not previously downloaded to my iPhone. The question is why and how this problem started.
    Powerbook G4 17", Mac OS X (10.5.2), Axis camera 207w
  • trappmane Calculating status...
    Currently Being Moderated
    Sep 9, 2008 5:06 PM (in response to junepost)
    I have the exact same problem with opening my free applications I downloaded through Itunes app store. It seems that every time I try to open an app I downloaded it will open like it's going to load and then it will blink right back to the home screen every time with every app showing no mercy or no change in action.... What is the deal with that and I see that slot of others are having the same **** problem. So apple, could you please try to resolve this paticular problem, besides this problem, the iPhone 3g is great and much faster but don't put something new on it that's not going to work!!!! Thanks to all those who responsed to this message . Email me at trappmannstudio@gmail.com if you have any answers to this problem.
    Thank You!!!!!!!!!!!
    emachines, Windows XP, 80GB with 320GB external hard drive
  • cutupanului Calculating status...
    Currently Being Moderated
    Sep 9, 2008 5:17 PM (in response to junepost)
    Same here
    Try this: delete all your apps from iphone.After that delete all from Itunes Applications tab.Restart iphone ,conect to itunes and than buy them from itunes App store and than sync
    this will solve the problem for sure!!!
    hope it helps!
    apple will fix this bug
    MBP 2.2Ghz intel core 2 duo, Mac OS X (10.5.2)
  • eric Foster Calculating status...
    Currently Being Moderated
    Sep 9, 2008 8:00 PM (in response to junepost)
    Same problem here. I just purchased two apps from the app store and neither one works, even after a few days, a new software update to iTunes (to 8.0) and mac os, system restarts, iphone restarts, synching etc. Nothing seems to make these apps work. They start up then quickly shut down.

    I've heard of a rumored email from Steve Jobs that references a software update sometime in september as being a fix to the problem, so will just wait and hope. Not exactly a plan I ever expected to use with regard to an Apple product.
    Mac OS X (10.5.4), iPhone 3G
  • tdavis312 Calculating status...
    Currently Being Moderated
    Sep 10, 2008 7:03 AM (in response to junepost)
    This problem continually occurs on my iPhone (along with the dropped call problem). All of the solutions presented here are for fiddlers. A phone is an appliance. Apple sold it to zillions because it is carefree. Download a sexy app and use it. Not go to a GENIUS BAR (puke) or reload, or reset, or fiddle, or or or. Some people have lives, responsibilities, and interests. This is not 1980. We have moved on beyond the Apple II. Apple needs to email us all an official workaround and apology. THEN FIX THE **** THING.
    Lenovo X61, Windows Vista
  • sputnik_1 Level 1 Level 1 (10 points)
    Currently Being Moderated
    Sep 10, 2008 11:09 AM (in response to junepost)
    hi all - same problem here: program comes up and shuts down after a second. the only thing what worked in this transaction perfectly: apple's invoice process grabing my money using my credit card ...
    MacBook Pro A1212, iPhone 3G Swisscom, Mac OS X (10.4.9)
  • iMattPro Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 17, 2008 10:14 AM (in response to junepost)
    I am pretty sure its a bug that has to do with authorization of multiple macs.
    Powerbook G4 12", Mac OS X (10.4.4), 1 ghz, 768 memory
  • My Last Confession Level 1 Level 1 (60 points)
    Currently Being Moderated
    Nov 4, 2008 6:10 AM (in response to junepost)
    I just got my iphone 2 days ago and now I'm having the same problem. I loaded a couple free apps: facebook, myspace, aim and Google earth. They worked fine until this morning. After voting I took a picture of the people inside and wanted to upload it to facebook. When I launched facebook I got the blank facebook page for 2 seconds, then it went back to the home page. I deleted all apps, tried reinstalling them but it won't let me.

    <Edited by Moderator>
    MBP 17", Mac OS X (10.4.6)
  • K J Calculating status...
    Currently Being Moderated
    Nov 4, 2008 5:04 PM (in response to My Last Confession)
    Same issue. Now I deleted them off of iPhone, but I can't delete them out of iTunes. I can't sync from iTunes b/c it tells me my account is not authorized. HUH??? Phones are new from this weekend and updated fine previously.

    Message was edited by: K J
    iMac 24", iPhone 3G 16GB, iPhone 3G 8GB, Lampshade iMac, Mac SE, Powerbook 180c, Newton!, Mac OS X (10.5.5)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.