Skip navigation
This discussion is archived

iPhone does not auto-connect to WPA Enterprise

7988 Views 11 Replies Latest reply: Mar 5, 2009 4:28 PM by Charles Conway RSS
shubb Calculating status...
Currently Being Moderated
Sep 10, 2008 1:14 PM
At work, we use a WPA Enterprise wireless network. I can connect to it, and it works fine, but when I leave and come back, it does not automatically connect to the WPA2 network again. When I go home, it connects to the WPA personal I have on my Airport, but I have to manually connect to the WPA Enterprise. Anyone else have this problem?
Macbook Pro, Mac Pro, Mac OS X (10.5.1)
  • bazone Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 11, 2008 1:09 PM (in response to shubb)
    Yes ... at least I think I do

    My first gen iPhone often doesn't automatically pick up/use the WiFi network at the office.

    After a fresh restart/power cycle it does connect to WiFi automatically. I'm not quite sure when it stops. I just did a cycle now and its been fine for >15 mins & multiple sleeps.

    If I go into Settings I can select the office WiFi no problems and it connects without any questions. Then the likes of Mail etc do use it ... for a while anyway!

    I've tried "forgetting" the WiFi network and reconnecting to it ... ie entering username etc & accepting certificate etc. All seems to work fine but eventually I'll notice its not automatically using it again!

    I think it is automatically picking up/connecting to my WiFi at home (via Airport & TimeMachine) ... or at least more reliably than at work.

    I'm not sure if my WiFi's are WPA Enterprise or WPA2 etc. If you tell me where to look I'll share.

    I hope someone has a fix.

    Is it anything to do with this thread? http://discussions.apple.com/thread.jspa?threadID=1700260

    TIA
    Barry
    home iMac, iPhone, iPod touch, AppleTV, AirPort, TimeMachine; work Dell XP lapto, Mac OS X (10.5)
  • bazone Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 12, 2008 10:20 AM (in response to shubb)
    Yep @shubb that's my scenario!

    Since upgrading to 2.1 this morning I haven't had the problem but it is a little early to tell.

    You don't happen to be using 1Password do you?? ... I am and had a suspicion it was related to AFTER I had sync'd via WiFi to my iMac at home.

    And are your a 3G or the original iPhone? ... I the original. I asked a few other folks at the office and 2 replied ... they haven't seen the problem but are 3G phone and one of the 2 turns off WiFi to save batteries ;-|

    Where to log a bug? ... hmmm dunno. I know there's a feedback link I've used for MobileMe but not sure if there's one for the iPhone.

    At least its good to know its not just me ;-() ... misery loves company!
    home iMac, iPhone, iPod touch, AppleTV, AirPort, TimeMachine; work Dell XP lapto, Mac OS X (10.5)
  • mwallac8 Level 1 Level 1 (15 points)
    Currently Being Moderated
    Sep 12, 2008 10:37 AM (in response to shubb)
    alright. I had been having the same issue. What I found, by accident, is that if u keep manually connecting the problem essentially goes away. Do not delete the network settings!!! Just keep manually connecting. Eventually it will connect on it's own. My only explanation as to why this works is that your work uses more than one router. Once u manually connect to one, that specific one will automatically connect. But if your phone cnnects to another, it won't and you'll have to manually connect again. I just found the more u manually connect, the less it will not automatically connect. At least this is true for my university.
    Dell E1505 Laptop, Windows Vista, 8G iPhone, 80G iPod Video
  • bazone Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 15, 2008 6:06 AM (in response to bazone)
    Same old behavior this morning so I don't think 2.1 has fixed it ;-(
    home iMac, iPhone, iPod touch, AppleTV, AirPort, TimeMachine; work Dell XP lapto, Mac OS X (10.5)
  • bazone Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 15, 2008 6:09 AM (in response to mwallac8)
    How many times did you manually connected before the problem went away mwallac8? I estimate I would have already manually connected to the same access point (well in the same area!) 10-20 times already (pre and post "forgetting" & reconnecting + login etc) + a few other locations in the office.
    home iMac, iPhone, iPod touch, AppleTV, AirPort, TimeMachine; work Dell XP lapto, Mac OS X (10.5)
  • audiostein Calculating status...
    Currently Being Moderated
    Oct 3, 2008 12:56 AM (in response to shubb)
    I had this problem on firmware 2.1 when using BossPrefs. After uninstalling it, the iPhone automatically connects to my known networks.
  • Enigma55 Calculating status...
    Currently Being Moderated
    Oct 9, 2008 9:57 AM (in response to audiostein)
    I have seen this problem with Jail Broken IPhones. A coworker and myself share an office and both of us have 3G IPhones. His is jail broken and has problems auto-connecting to the WPA Enterprise WIFI. Mine auto-connects everytime just fine. We are both running the 2.1 firmware.
  • sportytoes Calculating status...
    Currently Being Moderated
    Dec 3, 2008 4:41 AM (in response to shubb)
    I have this same issue. We have hundreds of access points and who knows how many routers. On my MacBook it usually connect but I sometimes have to accept a new certificate. I see I have several in my keychain (maybe 4). Will keep connecting manually. Maybe it will start auto connecting at some point.
    Macbook Pro 17" / Macbook Pro 15" / Mac Pro 2.66 GHz, Mac OS X (10.5.4), Have yet to get a support call for a Newton...
  • volman69 Calculating status...
    Currently Being Moderated
    Jan 16, 2009 6:31 AM (in response to shubb)
    I'm having the same problem w/ iPod Touch in WPA Enterprise setting. Can manually connect, but system will not reconnect. Need a fix for this iPhone/iPod bug.
    iPod Touch, Other OS
  • Charles Conway Level 1 Level 1 (50 points)
    Currently Being Moderated
    Mar 5, 2009 4:28 PM (in response to shubb)
    I don't know if this is a solution to your problem, but a little insight from my University where they use WPA2 with 802.1x and a certificate. Here our IT people created an enterprise setup file you load through MobileSafari that sets up the access point (and can access additional settings not available from the phone itself) and includes the certificates necessary. It's possible that the included certificate is helping avoid the need to say "OK" to the certificate prompt that comes up, allowing the auto-login.

    You can download for free the enterprise setup file creator and can save the certificates from a mac running OSX as you connect to the same network and try creating one of these setups to test.
    Macbook Pro C2D, Mac Mini, Mac OS X (10.5.5)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.