3 Replies Latest reply: Dec 15, 2008 8:44 AM by Rick-V
Mount Royal College Level 1 Level 1 (0 points)
I've installed xsan 2, created my san volume, set up users and groups ect...everything works great in xsan admin until i actually quit the admin app. when i run xsan admin again, it won't connect to my controller computers and I get no information through xsan admin. If I go to the terminal and run cvadmin, it tells me everything is normal.
I can reconnect to my san with xsan admin if I do the following: delete the .xsan file in user/library/application support/ , launch the admin app and reconnect to my san computers.
I'm very frustrated with this stupid behavior, because it happens every time I quit the admin app. and although the new xsan admin app is really great, I can't see using it if this behavior continues.
  • 1. Re: why does this happen...?
    Donald Kok Level 2 Level 2 (490 points)
    Does the [Xsan Admin MDCs not showing up|http://www.xsanity.com/index.php?topic=tips|The Fix: On each MDC, the /Library/Filesystems/Xsan/Config/role.plist file must be edited to reflect the new ethernet port.] article on xsanity cover your trouble/solution?
  • 2. Re: why does this happen...?
    Mount Royal College Level 1 Level 1 (0 points)
    thanks for your suggestion and although it seems to be a similar situation, the fix suggested in the post doesn't make sense for xsan 2.1 which has stopped using the "/Library/Filesystems/Xsan/Config/role.plist" file. alas i wish it were that easy, but bonjour seems to have taken over this task and isn't doing a very good job of it.
  • 3. Re: Xsan Admin not connecting to anything
    Rick-V Level 1 Level 1 (0 points)
    I have same problem as "Why does this happen".
    After I launch Xsan Admin even after first install, I'm not able to
    connect to anything even after deleting .xsan file and .plist for Xsan Admin.
    I've even tried to open a copy of working and edited version of .xsan file
    but still not change. Cvadmin shows everything is running normal and
    volumes, luns, controller, and clients are all normal.
    When I launch Xsan Admin, I get following message in system.log and raslog:

    Xsan Admin[358]: * -[NSCFArray objectAtIndex:]: index (7) beyond bounds (7)

    Appreciate any input on this problem.

    Regards,

    Rick Vaness
    Z2A.NET