Skip navigation
This discussion is archived

2.1 - ActiveSync Cannot Get Mail still broken

25780 Views 56 Replies Latest reply: Oct 7, 2009 11:16 PM by kingstonsmommy RSS
  • Nerio Calculating status...
    Currently Being Moderated
    Sep 25, 2008 7:33 AM (in response to johntatum)
    I've had this problem and had originally opened a case with Apple early August. The support reps were completely clueless and said they had never seen this before... to the point of just blaming our Exchange install.

    However, evidence was that my Winmobile device worked flawlessly, but the iphone would not push email once the device was in deep sleep. The phone apparently has 3 modes... on, sleep, and deep sleep. Push would work when it was plugged in without issues. When unplugged, push would work while on, or in sleep... after about 15 minutes in sleep, it would just stop pushing.

    I have all the errors in the AS logs, and it shows that AS tries to connect to the network, but cannot because I think part of the radio is turned off.

    So, on a whim, I set up a dummy yahoo account, set to fetch mail every 15 min. This keeps the radio alive and prevents it from going into deep sleep... or if it does, then the fetch just wakes it up, and then my EAS mail starts to flow.

    I gave the above solution to Apple, but my case was just closed because they did not hear back from development.

    The problem with my experience was that Apple Support made me doubt myself and think that maybe, just maybe it was Exchange. However, with hearing other people having the same issue... now I know it is the phone.
    iMac, Macbook, Mac OS X (10.4.6)
  • LenH Level 2 Level 2 (390 points)
    Currently Being Moderated
    Sep 25, 2008 3:17 PM (in response to johntatum)
    I just had our first incidence of this with version 2.1 (out of 25 deployed phones). I deleted the (iPhone) partnership on the Exchange server and the issue cleared up on the next sync.

    Message was edited by: LenH
    Mac OS X (10.5.4), iPhone 3G
  • SteveMWilliams Calculating status...
    Currently Being Moderated
    Sep 26, 2008 4:04 AM (in response to LenH)
    What's the iPhone partnership? Not come across that
    Novatech, Windows XP Pro
  • LenH Level 2 Level 2 (390 points)
    Currently Being Moderated
    Sep 26, 2008 7:39 AM (in response to SteveMWilliams)
    I used the remote wipe web page (installed separately from Exchange) called Mobile Admin on Exchange 2003 SP 2.

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E6851D23-D145-4DBF-A2CC -E0B4C6301453&displaylang=en

    You can search for an email address on the server and then click DELETE for the Apple device.

    Again, I don't actually know if removing the partnership on the server side actually worked or if it was a coincidence.
    Mac OS X (10.5.4), iPhone 3G
  • MNLang Calculating status...
    Currently Being Moderated
    Sep 26, 2008 7:44 AM (in response to LenH)
    Thanks Len, we are already good with 1 & 2, and 3 maybe part of the problem, but I don't believe it has anything to do with coverage.
  • SteveMWilliams Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 26, 2008 7:57 AM (in response to LenH)
    Thanks Len, I will read into this.
    Novatech, Windows XP Pro
  • FireFish Level 1 Level 1 (25 points)
    Currently Being Moderated
    Sep 26, 2008 8:29 AM (in response to johntatum)
    johntatum wrote:
    I'm still experiencing the issue where my iPhone randomly stops getting mail from Exchange/ActiveSync. The first time I experienced it after the update I deleted and recreated the exchange account, it immediately resumed working. The second time I did a complete restore as a new phone, and the issue reappeared again a few hours later.

    Here's what I do know:
    -This issue is NOT with the exchange server as we have numerous other Windows Mobile devices using activesync with no service interruption whatsoever. The iPhone however will not receive mail on the Exchange account until I delete/reconfigure the account on the iPhone itself.
    -Rebooting the iPhone used to work, however does not work anymore.
    -I have even kept WiFi disabled so it's not related to switching between WiFi and 3G.
    -I have 2 other accounts configured, a mobileme account set to sync contact and bookmarks only, and a gmail account.

    Has Apple even officially acknowledged this issue?

    I'm testing this on 2.2 Beta 1 now.

    Here's a workaround for 2.1 -

    In Mail Settings, make sure that there's no time filter on what messages to show; meaning, set it to show all emails, not just those within 2 weeks.
    MacBook Pro * 15" Screen / 2.6 GHz w/ 4 GB RAM, Mac OS X (10.5.2), iPhone 3G + iPod Classic 160GB Black
  • sdobr Calculating status...
    Currently Being Moderated
    Sep 27, 2008 8:30 AM (in response to FireFish)
    I had a similar problem and suggested workaround worked for me as well.

    Here is what I think was the root cause. My Exchange server enforces security policy so all mobile devices must be protected by a password before any data from Exchange is synchronized. The problem is that iPhone does not show that message to you and simply fails the connection.

    To workaround, really, after the account already setup and failed go ahead change "Mail days to sync" (I've chosen unlimited). Once you do that, you'll be prompted to protect your device with a password. And once you have set the password, you can change this option back to your desired setting and everything will work now.
    Q6600, Windows Vista
  • GenoTeich Calculating status...
    Currently Being Moderated
    Sep 27, 2008 3:12 PM (in response to LenH)
    LenH wrote:
    I used the remote wipe web page (installed separately from Exchange) called Mobile Admin on Exchange 2003 SP 2.

    http://www.microsoft.com/downloads/details.aspx?FamilyID=E6851D23-D145-4DBF-A2CC -E0B4C6301453&displaylang=en

    You can search for an email address on the server and then click DELETE for the Apple device.

    Again, I don't actually know if removing the partnership on the server side actually worked or if it was a coincidence.

    Looks like I finally found the right discussion forum for this issue.

    We have 3 iPhones and they all have the same problem. All users can connect to exchange and get all information (mail, contacts, calendar) at least once and then it will continue for a while both on "push" or on "fetch". Then, at some point the dreaded "Cannot connect to server" message comes up. We then have to go through the following steps:
    - go into iPhone settings
    - change one character in server address (usually add a "/" at the end or delete it)
    e.g. (mail.ourserver.com:8443/ OR mail.ourserver.com:8443) both work but sometimes the inbox is blank if we don't include the "/"
    - wait approx. 2 - 5 minutes and making sure the iPhone can't go to sleep by touching the screen every 30 sec. or so
    - accept the server certificate prompt when it comes up (we use self signed certificates)
    - wait for the second server certificate prompt and accept again

    System details:
    - Exchange Enterprise 2003, SP2
    - Back-end server
    - Windows Enterprise Server 2003
    - Firewall passes port 8443 to Exchange server

    I installed the MobileAdmin tool on our server but I cannot access it. I have tried all of the suggestions for the proper way to get into the tool and none of them work - IE always says "cannot display the web page". I also do not see any new virtual directories in IIS - should there be one called Mobile Admin? Is this possibly because I have a Back-end server?

    I feel like I've tried everything to keep our iPhones connected and nothing works. We are resetting the address as much as 2 - 3 times per day and then waiting for our contacts, calendar and emails to come back in.

    This is incredibly frustrating and we need a solution from Apple for this. By the way, we have multiple Treo phones working off of the same server and they have no issues whatsoever.
    HP, Windows XP Pro, Exchange Enterprise 2003, SP2, Back-end Server on Windows Enterprise Server 2003
  • MNLang Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 30, 2008 6:51 AM (in response to GenoTeich)
    The process you described in getting push or fetch to work again is the exact same thing I do. It gets to be a pain to change one character of your server address 3 or 4 times a day just to check your exchange mail.

    I have yet to find a work around that works, even the "unlimited" sync email option others have had success with.
  • edax Calculating status...
    Currently Being Moderated
    Sep 30, 2008 2:36 PM (in response to hamspanner)
    I have the same issue in a 2003 environment; mails, contacts and calendar items only come through after they have been opened once in Outlook. I made a simple rule in Outlook that sets the priority of all incoming mails to normal, leaving Outlook open and then all mails come through. For agenda items I make myself in Outlook, just a right-button context menu click is enough to make it come through to the iPhone. In such a case when in push mode, the data wheel in iPhone calendar keeps spinning once 2-3 secs until I "touch" the calendar item in Outlook, the item then comes through and the repeating spinning stops. Very strange...
    PowerBook, Mac OS X (10.4.7)
  • GenoTeich Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 30, 2008 8:36 PM (in response to MNLang)
    Yes, I've tried the unlimited email option with no results as well. I did finally get the Mobile Admin tool to work on Exchange and deleted the partnership to our iPhones as suggested in previous posts but this didn't help at all.

    I wish I could post more information about the problem but there is simply no more information to post. There are no errors in the exchange server event log and the behavior of the iPhone is almost identical every time:

    Enter account info
    Wait 3 - 5 minutes
    Accept self signed certificate (twice)
    All mail, contacts and calendar come in
    Read a few emails, forward, reply, delete, etc.
    Then the dreaded "Cannot get mail - the connection to the server failed"
    Change one character in the server address and start all over again

    The only thing I can add is that, every time I reinstate the account information, it automatically changes the message retrieval method back to "push" under setttings\Fetch New Data\Advanced even though I have push turned off.

    COME ON APPLE - LET'S GET SOME PEOPLE ON THIS ALREADY !!!
    HP, Windows XP Pro
  • gr8ful_dead Calculating status...
    Currently Being Moderated
    Oct 2, 2008 1:11 PM (in response to johntatum)
    Just to toss in my .02 - I have the same issue and have been through all most of the ideas in this thread... profile is Exchange 2003 sp2 and iphone 3g ver 2.1 (5f136)...

    Symptoms - syncs for around a day of so, then hits the can't connect to server message. I have found intermittent success with removing mail from sync options, removing account entirely from phone, most recently adding the / at the end of owa address (working right now with that one)

    We just got the ms remote wipe app and cleared 2 previous windows mobile devices that were on my account(hopefull).

    We are not using ssl - but turning the "use ssl" switch on or off has seemed to have no effect (in fact it works with it on)...

    Here is the kicker - we have 4 iphones and some windows mobile devices, mine is the only one that fails all the time... and it started failing for me on my treo 700w few months ago, with various frequencies and similar hacks to make it work again - for a while.

    Will post any updates we find.
    PC, Windows XP
  • SteveMWilliams Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 6, 2008 5:11 AM (in response to gr8ful_dead)
    AT LAST!!!!!!! I have now got this working.

    Here's a URL that explained the fix that worked for me.

    http://www.petri.co.il/problemswith_forms_based_authentication_and_ssl_inactivesync.htm
    Novatech, Windows XP Pro

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.