Skip navigation
This discussion is archived

Lates Java update renders all my Java apps inoperable

27184 Views 33 Replies Latest reply: Nov 11, 2008 3:33 AM by gurth4ng RSS
  • Mason Brown Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 14, 2008 4:04 AM (in response to sbd76)
    For what it's worth, I was having this same issue on a different app (JIRA Client.app), and the fix you described (copying the JavaApplicationStub in place of the file in Contents/MacOS/ within the .app) worked like a charm. Thanks!
    MacBook Pro 2.33 GHz C2D, 3 GB RAM, Mac OS X (10.5.5)
  • runnerr0 Calculating status...
    Same here after updating java angry ipscanner will not open. Consle looks like thins:

    10/19/08 3:40:24 PM [0x0-0x102102].net.azib.ipscan[32728] [JavaAppLauncher Error] CFBundleCopyResourceURL() failed loading MRJApp.properties file
    10/19/08 3:40:24 PM [0x0-0x102102].net.azib.ipscan[32728] [JavaAppLauncher Error] CFBundleCopyResourceURL() failed while getting Resource/Java directory
    10/19/08 3:40:24 PM [0x0-0x102102].net.azib.ipscan[32728] [LaunchRunner Error] No main class specified
    10/19/08 3:40:24 PM [0x0-0x102102].net.azib.ipscan[32728] [JavaAppLauncher Error] CallStaticVoidMethod() threw an exception
    10/19/08 3:40:24 PM [0x0-0x102102].net.azib.ipscan[32728] Exception in thread "main" java.lang.NullPointerException
    10/19/08 3:40:24 PM [0x0-0x102102].net.azib.ipscan[32728] at apple.launcher.LaunchRunner.run(LaunchRunner.java:112)
    10/19/08 3:40:24 PM [0x0-0x102102].net.azib.ipscan[32728] at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:50)
    10/19/08 3:40:24 PM [0x0-0x102102].net.azib.ipscan[32728] at apple.launcher.JavaApplicationLauncher.main(JavaApplicationLauncher.java:61)
    10/19/08 3:40:25 PM com.apple.launchd[166] ([0x0-0x102102].net.azib.ipscan[32728]) Exited with exit code: 1

    ***... I need a good ip scanner for osx... preferably a native coco one.. nmap dont work right under osx too..
    MacBookPro 2.4 GHz, Mac OS X (10.5.5)
  • gurth4ng Calculating status...
    still no fix for this?

    it's a very serious problem..
    Mac OS X (10.5.5)
  • gurth4ng Level 1 Level 1 (0 points)
    alright, i think i found a fix here:
    http://renderfast.com/2008/09/26/java-for-mac-update-2-leaves-some-java-apps-bro ken/

    "Someone in the Apple forums pointed out that simply copying the destination of the jEdit.app/Contents/MacOS/jedit symlink, which points to

    /System/Library/Frameworks/JavaVM.framework/Versions/A/Resources/MacOS/JavaAppli cationStub

    back into jEdit.app/Contents/MacOS/jedit (replacing the symlink with a copy) also makes the jEdit application bundle work again. This method has considerably fewer steps than mine.

    Apparently this file is functionally the same as the one generated by Jar builder. It seems Java developers went for the symlink method specifically to avoid problems created whenever Apple would go and update Java. With this update the symlink doesn’t seem to work again."

    hope this helps!
    Mac OS X (10.5.5)
1 2 3 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.