Skip navigation
This discussion is archived

Printer Presets Not Saving

7623 Views 16 Replies Latest reply: May 7, 2009 9:07 AM by Stevenmacbook RSS
1 2 Previous Next
tpacooper Calculating status...
Currently Being Moderated
Sep 3, 2008 6:17 AM
It has been discussed on here before without any fixes coming from Apple...

Essentially the problem is that I'm trying to set one preset for printing all of my documents and another preset that allows me to quickly print photos from Imagebrowser (a Canon program). The problem is that when you think you have saved a preset you really haven't. It just continues to use whatever settings were last used and often a bunch of work has to go in to getting things to print correctly. I know this worked correctly under Tiger. We're at 10.5.4 and Apple still hasn't sorted this out. Does anyone know of a third-party app or Applescripts that could be used to rectify this problem.

If I missed it, has there been a solution to this problem?
Aluminum iMac 24", Mac OS X (10.5.4), Brand New
  • Mark Nandor Calculating status...
    Currently Being Moderated
    Sep 25, 2008 2:03 PM (in response to tpacooper)
    No, you're right, this just plain hasn't been fixed. I've called Apple any number of times and they're just being lame and stupid about it. I've tried reinstalling the system, trashing every preference I can find - nothing.

    Not only that, but I think some of the printing things have gotten worse with the progression through 10.5.x. For instance, with 10.5.5, the first time I choose some printer and try to print double-sided, it doesn't even print double-sided. The second time I print, without changing any settings mind you, it prints double-sided.

    Just lame.
    2.4 GHz 15" MacBook Pro, Mac OS X (10.5.2), 4GB RAM
  • John Blanchard1 Level 5 Level 5 (4,735 points)
    Currently Being Moderated
    Sep 26, 2008 7:13 AM (in response to tpacooper)
    What settings aren't being saved? There is a known problem with the page setup features not being saved in presets, and there aren't any workarounds to this. Have you submitted feedback to Apple with the specifics?
  • Mark Nandor Level 1 Level 1 (120 points)
    Currently Being Moderated
    Sep 26, 2008 7:30 AM (in response to John Blanchard1)
    Yes, every time a new system update comes out (since April) I submit a new bug report and call. I've also visited a Genius Bar twice and had the problems confirmed by a Genius, who logged the issue again.

    The main problem is that "collate" is off. In fact, it is off even in the "Standard" preset. The thing is, that if I save a custom preset with the "collate" box checked, the com.apple.custompresets.plist DOES show that "collate" is "yes"; however, every time I select to print something else, the "collate" button is again unchecked (and the printer doesn't collate).

    That's the main one. But see above - now whenever I choose to print double-sided, the first time I print it doesn't print double-sided.

    This is repeatable on every MacBook and MacBook Pro (four of them) running 10.5 that I've tried. And it's with seven different printers (from three different companies: Lexmark, HP, and Xerox), both at home and at work, and even with the printer at the Genius Bar. The first Genius I spoke with thought it was an AppleTalk problem, since that's how I was connected to the printers; something about AppleTalk being old and not working well lately or something. But it actually doesn't matter whether I'm connected to the printer through IP, USB, AppleTalk, http, or any other system. Same issue with the custom preset not being read correctly.

    One would think it shouldn't be that hard to fix, given there have been three system updates, I believe, since I first reported the problem.
    2.4 GHz 15" MacBook Pro, Mac OS X (10.5.2), 4GB RAM
  • Grimmerm Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 8, 2008 3:43 PM (in response to tpacooper)
    Same issue here since 10.5 update.
    Intel iMac, Mac OS X (10.5.5)
  • Cheryl Tarbox Level 1 Level 1 (30 points)
    Currently Being Moderated
    Oct 21, 2008 7:13 AM (in response to Grimmerm)
    I'm also having the same issue with 10.5.5. I'm trying to create a preset within 'Layout' of 'Two-sided Printing' set at Long-Edge Binding. After creating the preset, the setting does not hold. I know this works with Tiger as I have all the mac clients in my public labs set up this way and need to carry this preset over to my Leopard clients.

    I can get the 'Border' setting to stick with a preset... Not that I need it -- just created the preset to see if any setting would hold.

    Article http://docs.info.apple.com/article.html?path=Mac/10.5/en/8188.html states:

    "Some options cannot be saved in a preset. After saving a group of print options as a preset, use the preset to see if the document prints they way you want."

    It would be very nice if Apple specified what options cannot be set. (If Two-Sided printing is one of them, it is very disappointing that Apple now disallows this in Leopard.) And if the document doesn't print the 'way you want', nothing in the articles addresses that either.

    Cheryl Tarbox
    Macintosh Support Specialst
    Binghamton University
    20" 2.4 GHz Alum iMacs, Mac OS X (10.5.5), 2 Netboot Xserves to manage ~100 clients in public computing labs
  • entriken Calculating status...
    Currently Being Moderated
    Nov 3, 2008 2:30 PM (in response to tpacooper)
    This issue has been a problem for me since installing Leopard 10.5 upon its release. The fix for me was realizing that the feature settings of the various printers were reset. I had to go into each of the information panels of the print queues and enable Duplex printing, for instance. I do not know why this is not occurring through an automatic query process between the Printer Setup and the Printer itself.

    A serious non-feature I noticed is that a lack of one feature in the Default Printer causes the Preset to lose that feature within an application context. That is, having the Default Printer without Duplex, while having selected a saved Duplex preset will cause the checkbox to be unset and the duplex feature to become unavailable in that preset and application, even after selecting an alternate printer with the Duplex feature designated available. Setting the default printer to the alternate having Duplex and restarting the application (like Preview) causes the Print dialog with Duplex preset to have the checkbox set.

    I checked to see if the preset plist is being overwritten when selecting alternate printers, and it is not.

    It seems that this could be a behavior exhibited by in the Apple Print dialog. It seems to read the Preset one time, perhaps at the first Print command. From there it seems to alter the Preset information, based on the default printer feature set, losing Preset features forever more within that application context. If this is the case, I suggest that Apple maintain a original copy of the Preset plist within the application and merge that upon each alternate printer selection.

    For me, the workaround is to manually designate all of my printers to have Duplex capability.

    I hope you find this useful.

    Sincerely,

    Robert Entriken
    HP and Tektronix Printers with MacBook Pro, Mac OS X (10.5.5)
  • Stephen Goodman Calculating status...
    Currently Being Moderated
    Dec 14, 2008 1:17 PM (in response to Cheryl Tarbox)
    I'm anxiously awaiting a fix for this problem... is it still the case that there is no fix? To restate (for people seeking this problem out), preview and other apps which use OS X's print api are unable to use print presets since OS X won't remember print presets / forgets print presets.

    One thing I have confirmed is that in ~/Library/Preferences/com.apple.print.custompresets.plist the preset is actually being saved, and the correct details are therein. The problem is that Preview won't load the preset. I suspect that, as per the article cited in the above post, when preview vets the preset settings, if one of them is not on the approved list, the entire batch gets rejected. Weak!

    BTW, I'm using a HP Photosmart D7360 connected to a new iMac w/ 10.5. The only difference between "Standard" preset and my new preset is a change to 4x6 paper instead of 8.5x11, and to use paper from the photo tray instead of the main tray. As in, a photo preset. Imagine...
    iMac, Mac OS X (10.5.5)
  • jdlaw6067 Calculating status...
    Currently Being Moderated
    Feb 13, 2009 8:44 AM (in response to tpacooper)
    This still continues to be an issue. I just tried using the preset functionality to save Paper Size, Orientation, Center Image and Scale To Fit. After I close the image and select the custom preset, none of the above setting are changed to what I had saved. Does anyone have any suggestions on how to resolve the issue? BTW I am running OS 10.5.6 with the latest patches and updates.
    MacBookPro, Mac OS X (10.5.6)
  • John Blanchard1 Level 5 Level 5 (4,735 points)
    Currently Being Moderated
    Feb 14, 2009 9:42 AM (in response to jdlaw6067)
    There isn't a fix yet, or a workaround, that will have to come from Apple…
  • Dare2Dream Calculating status...
    Currently Being Moderated
    Mar 9, 2009 7:00 AM (in response to John Blanchard1)
    The custom preset issue is not yet fixed.
    Is there any alternate way to get the same settings that provided in com.apple.print.custompresets.plist like after re-installing the printer driver or re-imaging the machine etc.

    Thanks,
    Suhas
    Mac OS X (10.5.6)
  • John Blanchard1 Level 5 Level 5 (4,735 points)
    Currently Being Moderated
    Mar 9, 2009 10:01 AM (in response to Dare2Dream)
    I am sorry, I don't understand our question.
  • AaronN Calculating status...
    Currently Being Moderated
    Mar 11, 2009 2:38 AM (in response to jdlaw6067)
    Wanted to chime in and say that this bug is still unfixed. Is it going on, what, almost a year now? The saving of presets worked perfectly fine with 10.4.x, in fact this is the one reason why my wife hasn't updated to 10.5.x and is getting more frustrated with her computer since something with Safari 3.2.1 keeps crashing out in 10.4; "keeps crashing" is a bit of a misnomer, however she experiences crashes far, far more frequently than any 10.5 machine I've seen that uses Safari as its main browser.

    We've tried printing from different printers, erasing settings, preferences, reinstalling drivers, searching for third party solutions to this mundane problem and it all trails back to Apple not responding. I could see if for some reason in 2008 and 2009 I suddenly stopped printing multiple files that were exactly the same format and size and always had to change the format setting, I really could appreciate the fact then that my computer can't understand that, yes, I really do want to print 10 different-sized images on 4"x6" pieces of paper consecutively. Unfortunately I guess I'm a bit too predictable and want to print consistently using a format that's not even offered under the Print & Fax preferences...yes, I'm looking at YOU Mr. 4"x6" Borderless.

    I'm wondering if this has been swept under the table and filed as "hopefully they forget and keep upgrading their systems" folder, it seems like an awful long time to not do anything about it, more so when we actually had this functionality working -fine- in 10.4.x. It's like Apple's taken the ball all the way to the 1 yard line and just can't get it to the goal or something. Sad, really sad, and I'm disappointed that there are still a lot of others like me out there who have this exact problem that's persisted for far too long.
    MacBook Pro 2.16GHz, Mac OS X (10.5.6)
  • James Reid1 Level 1 Level 1 (5 points)
    Currently Being Moderated
    Mar 23, 2009 12:52 AM (in response to AaronN)
    Aaaaaah aaaah aaaaah aaah aaaaaaaaahaaaaaah men! (Supply melody).
    G4 1.25 mhz. dual MDD (FW); Pismo G3/500 PB, Mac OS X (10.4.8), Palm T3 PDA
  • greg sahli Level 7 Level 7 (23,470 points)
    Currently Being Moderated
    Mar 23, 2009 4:45 AM (in response to James Reid1)
    Nobody at Apple gets paid to read these user-to-user discussions. If this has been going on for a year, I hope you can at least tell me you have posted this on Apple Feedback once each month in that time!
    Apple Feedback is the one somebody reads!!!!
    http://www.apple.com/feedback
    G4-867-DP
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.