Skip navigation
This discussion is archived

"Your network settings have been changed by another application"

72546 Views 64 Replies Latest reply: Nov 22, 2009 3:15 AM by roger Symons RSS
  • EJ\'s tech support Calculating status...
    Ever since 15 September when I accepted Software Update suggestion to update QuickTime (7.5.5), iTunes (8.0), and Security Update 2008-006 on my iBook operating OS 10.4.11: (1) the internet connection to my local Airport network was not remembered across logouts or activation of a screen saver (e.g., by closing the laptop lid) that is set up to require a password; and (2) whenever System Preferences - Network was run without being locked to prevent changes (such as to set the Airport connection options), "Your network settings have been changed by another application" repeated appeared.

    My temporary workaround for the first problem was the use of Internet Connect - Other to enter the name of the Airport network and its password each time I log back in. My temporary workaround for the second problem was a variation of the "two-handed" maneuver (return key for OK and click) in order to change the setting of System Preferences - Network to prevent changes, and to produce and select a Force Quit choice for System Preferences on the Dock - and never again try to make Network changes.

    I had run Disk Utility to repair disk permissions, and discarded preference files in my Home folder for System Preferences, internet, and internet connect to no avail. The Network pane from previous version (2.1) of System Preferences has the same problem as described above.

    My latest, apparently successful, attempt follows the suggestion of Dan C... posted on Sept 17. I can not be sure which steps are critical, but they included:
    * Running System Preferences - Network and clicking the lock to allow changes
    * Using the Location pull-down Edit Locations selection and deleting all locations but one (for me it was one that used only FireWire)
    * Using the Location pull-down Edit Locations selection to create a new location that used Airport - using a different name for that location than the one that I used previously
    * Using the Show Airport choice and Edit action to specify my own Airport network, and only that network
    * Highlighting that network selection and selecting Edit - at which point I observed (after checking Show password) that the password had been corrupted - and entering the correct password - somewhere around this step, the correct internet connection may have been made
    * Using the Location - Edit Locations to Rename the Location to be the same as I used previously (I recall that this solved an earlier unsuccessful attempt to use the previous Location name without deleting it first).

    If I encounter further related problems, I will try the solution posed on the thread "'Your network settings have been changed by another app' - THE SOLUTION" at - which involves preference files in the Macintosh HD \ Library \ Preferences \ SystemConfiguration folder.
    iBook (900 MHz PowerPC G3), Mac OS X (10.4.11)
  • Thomas Sattelmayer Calculating status...
    I read somewhere that this message is due to the new way of saving the PPP connection password after the security update is applied. It will occur, only if you have one or more, saved network configurations that includes PPP connection setup.

    This is how I got rid of the problem without deleting any of my network locations or any preference files:

    1. Log in using an admin account.
    2. Open the Security Preference Window
    3. Check "Require Password to unlock each secure system preference" to get temporarily rid of the annoying message (at the expense of typing in the admin password whenever settings are changed).
    4. Open the PPP network connection (Network Window)
    5. Uncheck "Save Password" in the PPP-Pane
    6. Type your password into the approriate field
    7. Recheck "Save Password" in the PPP-Pane
    8. Repeat this for all your PPP network connections
    9. Open the Security Preference Pane and uncheck "Require Password to unlock each secure system preference"
    PB G$, Mac OS X (10.4.10)
  • edrixc Calculating status...
    HEY! This one worked.

    Although I don't really understand the PPP network connection (network Window)

    Im using 10.4.11 and then I just clicked the "Click the lock to prevent further changes"... and entered my password, then went back to security preference window and unchecked "require password..."

    I don't really get the uncheck save password in the PPP-Pane.. is that for the PPPOE? In this case, if it is right, then this is for the people that use automatic configuration and not PPPOE

    But either way, the suggestion by Thomas Sattelmayer worked. Thanks
    Mac Book Pro 2.4Ghz Core 2 Duo (MacOS X 10.4.11)/ Imac 24 inch 2.8Ghz Core 2 Duo, Mac OS X (10.5)
  • edrixc Level 1 Level 1 (50 points)
    Never mind. Went back..
    Mac Book Pro 2.4Ghz Core 2 Duo (MacOS X 10.4.11)/ Imac 24 inch 2.8Ghz Core 2 Duo, Mac OS X (10.5)
  • edrixc Level 1 Level 1 (50 points)
    FROM THE POST EJ was referring to: (For those people who have clicked on endless links to NO avail, and are tired of opening another one)

    From Jona:

    "This currently reported problem, which manifests after applying Security Update 2008-06, can be fixed permanently by removing the following preferences files:

    Go to Library/Preferences/SystemConfiguration and delete the following (suggest make copies to the desktop first if in doubt):

    All these files will regenerate as necessary when the associated system features are accessed. If you're using Airport or Internet Sharing you'll have to reestablish the appropriate settings, because these will have been lost when the preferences files are removed. Small price to pay, however for a permanent, and very simple solution to this irritating problem."

    IT WORKS. I did it and its working.

    Although Try to write down on textedit or on a piece of paper your network preferences. Because everything will be erased. this is the unfortunate consequence of THE SOLUTION.

    I have five locations, so I needed to write it down, plus I had bluetooth settings for my nokia e90 to connect to the internet if wifi wasn't available. I also had ethernet settings for my PPPoe internet service, I had automatic wireless settings for my router.. etc.etc..

    So you gotta write it down


    Message was edited by: edrixc
    Mac Book Pro 2.4Ghz Core 2 Duo (MacOS X 10.4.11)/ Imac 24 inch 2.8Ghz Core 2 Duo, Mac OS X (10.5)
  • Mike Bass Calculating status...
    I had this same problem on a user's machine. I think it was caused by a Firefox update but it's hard to know. There may have been a Mac OS X security update as well. Regardless, the fix was rather easy if you only have a few locations.

    Simply use the "two-handed" technique described elsewhere to get into the Locations list from the Network preference pane. Then duplicate each of the Locations you need and delete all your old Locations, so that the only ones left are the duplicates you just made.

    Problem solved, at least in my case.
    Powerbook G4, still, Mac OS X (10.5.5)
  • LMPogoda Calculating status...

    It works... but not for standard users, only for Admin. I got the same issue, fixed it as listed and I can use Safari again under my admin account, but my wife, who cannot administer machine still have the same problem.

    So, this is solved only in half

    PS. I got the same problems at work (where I also work on Macs) -- admin is fixed, my standard user account -- not.
    Intel iMac / PowerPC iBook, Mac OS X (10.4.11)
  • Michael Neely Calculating status...
    I used the following solution and have had a positive result. BTW, I'm using my Airport to connect to the network. Open your Network prefs panel, and using the "two handed approach" in under the Airport tab, click the Options button. This brings up a dialog box for Airport settings. Now click the Restore Defaults. Problem goes away.
    1.5 Ghz, Mac OS X (10.4.1)
  • cthornton Calculating status...
    I'm having the same problems with my mother's iMac, running 10.4.11. Removing the items in SystemConfiguration and restarting was successful in re-enabling internet access (it had cut out), but the same annoying looping message in Network remains.

    Hoping that Apple issues some sort of fix for this bug.
    iMac 17", Mac OS X (10.4.11)
  • Greg Alexander1 Level 1 Level 1 (40 points)
    I just experience the same problem on an iMac PPC 10.4.11 machine with all the latest updates, using wired/ethernet.

    It works perfectly until I plug my MBP (10.5.5 machine with all the latest updates) into the ethernet network. If I connect my MBP wirelessly, the iMac works fine.

    Very odd... so for now I'm connecting wirelessly and copying some large files very slowly
    MBP 2.2, Mac OS X (10.5.4), I have a few....
  • akseeker Calculating status...
    This one worked for me, so far. I haven't connected up to all the wireless networks I usually habitate (airport (for flying out of), work, etc.), but fixed the problem at home, anyway.
    17" Powerbook 1 GHz G4, Mac OS X (10.4.11)
  • Jason Hirsh Level 1 Level 1 (10 points)
    Like the rest,all of a sudden (well who knows how long since i just had a network hiccup, I got the infinite loop. EricXC solution, while draconian, solved the problem so that I could get back to other fun issues.. THANK!!!!

    maybe some company should be less $$ on advertising and more on issuing good patches
  • Gary Robinson2 Calculating status...
    I thought deleting the preference settings files was a bit drastic, so I used the 'Return and click' method to get to the location editing stage and then duplicated every location and deleted the originals. So far so good....

    PS: Must remember to NOT install new upgrades until the dust has settled and any new bugs introduced have been found and ironed out!
    PowerBook G4, Mac OS X (10.4.11)
  • Slywy Level 2 Level 2 (220 points)
    I have had the same problem, although I'm not sure when it began (recently). I also discovered the Apple Firewall had been turned off and can't be turned on again because supposedly another firewall is in use (not that I know of). My connection keeps dropping, although, oddly, e-mail will work while the browser won't, or IM will and e-mail won't. Help . . .
    14.1-inch iBook (June 2005), Mac OS X (10.4.11), Second computer: 2001 Titanium with OS 9.2.2
  • davecw Level 1 Level 1 (0 points)
    I was having the same problem with the looping pop-up message "Your network settings have been changed by another application" until I just hit the enter button for "OK" and then immediately afterward clicked the padlock shut with a mouse click before the pop-up message could appear again. Everything working fine now
    PowerBook G4, Mac OS X (10.4.11), Airport Express, D-Link DSL-300T, Zen


More Like This

  • Retrieving data ...

Bookmarked By (0)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.