7 Replies Latest reply: Nov 6, 2008 10:24 AM by firstlaunch
wburtis Level 1 Level 1 (0 points)
Every time I attempt to create a vault I get the following error message:

"Aperture has detected a problem with the vault “Untitled Vault”. You need to remove this vault and create a new one."

I proceed to remove and create a new one but to no avail. I have also held down the command/option to rebuild the library. Now what? What do I have to do to aperture to reset it from scratch again. I have already moved my library manually to an external disk and created a new library with only a couple of images to check the vault.

Macbook, Mac OS X (10.5.4)
  • 1. Re: Cannot Create Any Vault
    tidysteve Level 4 Level 4 (2,975 points)
    what type of disk are you trying to create it on ??? how is it formatted ???
  • 2. Re: Cannot Create Any Vault
    MarkTarran Level 1 Level 1 (0 points)
    I've had the same problem. My vault worked fine with Aperture 1, but since moving to Aperture 2 the vault didn't work and I got the same message. So I deleted the vault and tried to create a new one. It creates a new vault but it's empty, and when I try and update it, I get that message again, telling me there are about 200 errors, all telling me to remove the vault and start again.

    Originally I was using an external drive formatted with FAT32. I am now using a new IOMEGA Ultramax drive which was factory-formatted HFS. No difference. Same problem.

    If anyone resolves this, I'd be grateful to know the answer!
  • 3. Re: Cannot Create Any Vault
    wburtis Level 1 Level 1 (0 points)
    I am using an external Maxtor disk that I am also using Time Machine with...I have a couple of external drives that I am using but they are formatted with for the mac. I am aware of the fat32 problems.
  • 4. Re: Cannot Create Any Vault
    -V-O-Y-A-G-E-R- Level 1 Level 1 (0 points)
    I got the same error these days.

    What helped me was to move all Edit plugins

    from ~/Library/Application Support/Aperture/Plug-ins/
    to /Library/Application Support/Aperture/Plug-ins/

    In Edit folder I have Dfx v2.ApertureEdit and NoiseNinja.ApertureEdit plugins. One of those two was a troublemaker
  • 5. Re: Cannot Create Any Vault
    Jorgen Gustafson Level 1 Level 1 (20 points)
    I have the same plugs - for me this fix didn't do the trick. Still have the issue - with or without the plugs installed.
  • 6. Re: Cannot Create Any Vault
    John Williams6 Level 1 Level 1 (0 points)
    were you able to resolve this problem? I went as far as to buy an entirely new (WDC) external drive, and I am still getting the same errors. Any help is appreciated.
  • 7. Re: Cannot Create Any Vault
    firstlaunch Level 3 Level 3 (610 points)
    Did you remove all of your Plugins? This seems to be the resolution in many of these Vault issues.