Skip navigation
This discussion is archived

Firewall keeps asking for permission (allow incoming connections)?!

11831 Views 15 Replies Latest reply: May 20, 2009 9:43 AM by GerryConway RSS
1 2 Previous Next
Wolfgang Ty Calculating status...
Currently Being Moderated
Oct 26, 2008 7:05 AM
Hi there,

I am using OS X 10.5.5 and have set my firewall to ask if applications should accept incoming connections. However the firewall forgets my choises and keeps asking again and again (after each reboot). It keeps asking although the respective applications are listed in the firewall settings window.

So essentially the firewall seems to forget what I have chosen before.

It there any way to fix that?

Thanks!

Wolfgang
MacBook Pro, Mac OS X (10.5.5)
  • Ferd II Level 7 Level 7 (23,205 points)
    Wolfgang,

    Read this thread for a possible solution.

    ;~)

    IMac 24"/2.4GHZ/320GB/SD/AP/BT; iMac G4 17 80 GB 1.25GHZ, Mac OS X (10.5.5), 20GB iPod Color, iPod shuffle, iPhone
  • Tornado23 Calculating status...
    I have the same problem.... it used to only always ask for transmission... but now is asking on itunes too :S... it's really annoying and makes no sense!

    Compliments,

    Tornado
    MacBook Pro 15", Mac OS X (10.5.4), 2.5Ghz 4Gb DDR2 250Gb HDD
  • Ferd II Level 7 Level 7 (23,205 points)
    IMac 24"/2.4GHZ/320GB/SD/AP/BT; iMac G4 17 80 GB 1.25GHZ, Mac OS X (10.5.5), 20GB iPod Color, iPod shuffle, iPhone
  • Tornado23 Level 1 Level 1 (10 points)
    It didn't help here either :s

    Compliments,

    tornado
    MacBook Pro 15", Mac OS X (10.5.5), 2.5Ghz 4Gb DDR2 250Gb HDD
  • Hunter S Calculating status...
    Nor here - I've got the same problem.
    sigh
    (there was a time when Apple software was famed for not being as buggy as Microshite)

    Any ideas?
    Powerbook G4, Mac OS X (10.5.5)
  • davelong9050 Calculating status...
    I am with you guys now......same problem, no fix found so far.

    What is the best way to request a fix?
    iMac 24" 2.8 GHz, Mac OS X (10.5.5)
  • Scott Radloff Level 6 Level 6 (14,490 points)
    davelong (et al),

    When an application that is already included in the "Allow" list is updated, this problem can occur. Specifically, it happens when the application is removed, then replaced by a same-named "package," during the update.

    The solution is to remove what is essentially the old application from the "Allow" list, then to grant permission for the new one to accept connections.

    Doing so has worked perfectly well for me. However, there may be a specific sequence of actions that will work. Mine was:

    1) Wait for the dialogue to appear, then deny access. Quit the application in question.

    2) Open System Preferences>Security>Firewall, and remove the application in question from the list entirely.

    3) Wait for the dialogue to appear again, then grant access. This should be the last time you see the dialogue.

    Scott
    17" Macbook Pro (Hi-Res, Muuuulti-touch), Mac OS X (10.5.5)
  • Michael Johnson6 Level 1 Level 1 (10 points)
    Tried this and it didn't work for me. Followed your steps exactly. iTunes and Safari ask all time no matter how I remove/re-add them to the list. Very frustrating that this keeps happening. I wonder if it's a PowerPC problem, since it doesn't happen on my MBP, but does on my older G4 tower.
  • billytkid Level 1 Level 1 (0 points)
    I had this problem for ages on Azureus, and after reading through here deleted the app, then reinstalled it, and it worked fine.

    I think this is something to do with when you download apps now the first time you run them it asks if you're sure..i think the issue is when the OS got updated some apps are stuck in a semi limbo.

    I guess if itunes/safari is one of these your screwed unless you reinstall the OS.

    good luck
    Mac OS X (10.5.1), Mac mini 2Ghz
  • StephenM Level 1 Level 1 (110 points)
    This is kind of funny.

    I have this problem with the Logitech Harmony Remote Software.

    I followed your directions while having the Firewall portion of the Security System Preferences open. When I deny access to Logitech Harmony Remote Software, I see the denial get added to the list. I then delete the denial, fire off Logitech Harmony Remote Software again, this time allowing the connection, and the Firewall list doesn't get updated.

    I tried to reinstall Logitech Harmony Remote Software to see if that could make a difference. It does. Now it doesn't show in the firewall list either way!
    various, Mac OS X (10.5.6)
  • Jimmy P. Level 1 Level 1 (0 points)
    I had the same problem for iTunes, Connect360 and Transmission. After reading many forum post and trying many things to no end this is what worked for me.

    NOTE THIS WORKED FOR ME, IT MAY NOT WORK FOR YOU, DON'T BLAME ME.

    1. Log into an Admin account

    2. Go to the Firewall under the Security Pane in System Preferences and remove ALL programs listed under "Set access for specific services and applications." (you can try removing just the troublesome apps)

    3. Still in the Firewall tab, change setting to "Allow all incoming connections."

    4. In the Finder go to your Applications Folder and drag iTunes (or any other offending apps) to the trash and delete from the dock. *This SHOULD NOT delete your music, playlists, ratings or anything else, it did not on mine. But BACKUP if you want to be 100% sure*

    5. In the System Preferences, go to Accounts > Login Items and remove ItunesHelper.

    6. Restart your mac and log in as the Admin again.

    7. Download any apps you deleted, i.e. iTunes. Link: http://www.apple.com/itunes/download/

    8. Install the apps (don't open them after install)

    9. Go back into the firewall settings and change it back to "Set access for specific services and applications."

    10. Open iTunes and any other apps you reinstalled.

    11. Add iTunes back to the Dock.

    This should have fixed the problem, and iTunes should act like nothing ever happened...

    We still need to add iTunesHelper back to the Login Items.

    12. In the finder go to Applications, and right-click on iTunes, select "Show Package Contents.

    13.Open the System Preferences and go to Login Items under Accounts.

    14. Back in the finder (the iTunes Package Contents) go to Contents>Resources>iTunesHelper

    15. Drag iTunesHelper into the Login Items list.


    This worked for me. I don't think it ever asked for permission for iTunes. And I have only been asked once for the other programs that used to ask me everytime.

    Hope this helps you and everyone else with this problem.
    MBP Fall '07, Mac OS X (10.5.6)
  • Jon Davenport Calculating status...
    i think i have a similar problem with itunes as well, plus my screensharing will not work plus i cannot get access to jungledisk to work with the firewall on, even if i add the app to allow incoming. Is there a prefs than can be deleted to start afresh?
    macbook pro 17" 2.16 GHz Core Duo, Mac OS X (10.5.6)
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.