Skip navigation
This discussion is archived

iTunes 8.0.1 quits unexpectedly immediately after it's opened

1555 Views 11 Replies Latest reply: Jan 20, 2009 7:26 PM by Andrew564354 RSS
Steveo Edwards Calculating status...
Currently Being Moderated
Oct 18, 2008 9:52 PM
I recently updated to iTunes 8.0.1. I had to reboot, as I had also updated QuickTime at the same time. As soon as I attempt to open iTunes, I get an error saying iTunes unexpectedly quit.

I've attempted rebooting my system, reinstalling iTunes manually, deleting iTunes and then reinstalling it manually, recreating my iTunes library file, and checking my add-ons folder (I had no add-ons installed).

Sometimes when I attempt to open it, it won't show the error dialog, it will just immediately quit.

Quicktime, however, works fine.
MacBook, Mac OS X (10.5.2)
  • Ranger Ric Calculating status...
    Same problem here. Worked fine until update to 8.0.1. Now iTunes quits unexpectedly every time. I tried moving iTunes prefs (three of them) from my home folder to the trash, but iTunes did not even try to re-create them in my prefs folder, it just quits. Any ideas out there?
    iMac 24", Mac OS X (10.5.4)
  • Ranger Ric Level 2 Level 2 (360 points)
    An update on my recent post. It turns out that after today's Software Update (which updated a number of applications, plus a security update) a number of applications are crashing. For example, Quicktime now crashes, and mail crashes when I try to open an email or compose a new one. Word seems stable so far. The error log states:
    Exception Type: EXCBADACCESS (SIGBUS)
    Exception Codes: KERNPROTECTIONFAILURE at 0x0000000000000000
    Any ideas?
    iMac 24", Mac OS X (10.5.5)
  • Ranger Ric Level 2 Level 2 (360 points)
    Repaired permissions but did not help. I noticed in the error log that there was a lot of stuff related to Quicktime also.
    iMac 24", Mac OS X (10.5.5)
  • Ranger Ric Level 2 Level 2 (360 points)
    In case anyone is reading this thread, I downloaded Quicktime 7.5.5 and reinstalled it. That resolved all problems. Apparently QT got corrupted somehow during the last software update.
    iMac 24", Mac OS X (10.5.5)
  • rimacuser Level 1 Level 1 (10 points)
    I'm having the same problem. Following the above suggestion, I downloaded Quicktime and reinstalled it but that did not solve my problem. Whenever I launch ITunes, the iTunes window opens and then it crashes. This started today, 11/15.

    Interestingly, iTunes stays open when I have my iPhone attached, everything syncs properly and then iTunes stays open (even if I remove the iPhone). That will work for me for a while until Apple or I figure this out.
    2.4 GHz intel Core 2 Duo MacBook, Mac OS X (10.5.5)
  • Ranger Ric Level 2 Level 2 (360 points)
    In cases like this, the first two things I always try are 1. delete the iTunes pref file (quit iTunes, move it to the desktop, then re-launch iTunes), and 2. repair permissions.
    iMac 24", Mac OS X (10.5.5)
  • BOOMERTOM Calculating status...
    When I attemp to open Itunes, I get a blue windows box that pops up with an X and a message that reads "Quicktime was not found. Error-2096. Quicktime is required to run Itunes Please reinstall Itunes." Thats funny Quicktime is there I have re-installed both Itunes & Quicktime. Anybody with simular problems?
    DELL, Windows XP
  • Bobufarr Calculating status...
    Ranger Ric - thanks for the solution, at least in my case. I had reinstalled iTunes, but it still didn't work, even after repairing permissions and trashing the preference file. I reinstalled Quicktime and it seems to be working fine now.

    One other variable for me. I had updated Perian the other day and the install was a bit wonky. Before I restarted after the Quicktime reinstall, I deleted the Perian preference pane as well. I don't know if that's related.

    Thanks again!
    MBP 2.2, Mac OS X (10.5.4)
  • Andrew564354 Calculating status...
    POSSIBLE SOLUTION:

    I had this same exact problem with iTunes unexpectedly crashing on Thread 0. It started shortly after the 10.5.6 update. I noticed that it worked for another user on my machine, so it must be a problem within my user folder. I put my Library folder on the desktop, fired up iTunes, the machine recreated a library folder and the nessisary iTunes files and - TaaDaaa...it opened. So I looked at the files that it recreated to track down which one could be the culprit, and sure enough I found it. I was close on my first troubleshooting attempt, and I'm sure many others came close too. I trashed all the iTunes preferences but not the ByHost folder.

    The file is in the User/Library/Preferences/ByHost folder. Mine was called: "com.apple.iTunes.000d93500db6"

    Trash it and iTunes will open and ask you to "Accept" and then you're in. Such a simple fix and Apple still hasn't given anyone the answer. Meanwhile they make people attached by the hip to iTunes through their products, and don't rush to the users aid when it goes down (especially after one of their updates). Shame.

    I hope this helps someone.
    G4, yep
  • Andrew564354 Level 1 Level 1 (0 points)
    Looks like it only works once. You delete the "com.apple.iTunes.000d93500db6" file and you can get in one time. Each time I have to delete the file.

    At least I can get in, but come on give me a break.
    G4, yep

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.