1 2 Previous Next 20 Replies Latest reply: Nov 29, 2008 11:59 AM by Jeremy Riga
Jeremy Riga Level 1 Level 1 (30 points)
I would like to be able to use my trackpad for pinching, rotating, zooming, etc while using my mouse for mousing around the screen.

Is this possible?? Can't seem to find any setting for this in Sys Prefs or other.

Thanks!

2.4GHz MacBook, 4GB, 320GB 7200RPM, Mac OS X (10.5.5), 24" LED Cinema Display (Soon?)
  • 1. Re: Way to use both trackpad and mouse at the same time?
    Douglas McLaughlin Level 9 Level 9 (63,735 points)
    What's preventing you from doing this now? Do you see an error message of some kind? Plugging in a mouse to my MacBook doesn't prevent any kind if trackpad options...

    -Doug
  • 2. Re: Way to use both trackpad and mouse at the same time?
    Jeremy Riga Level 1 Level 1 (30 points)
    Really?! No, there are no error messages - it just doesn't function. The second I plug in my Logitech Wireless USB Receiver in to my MacBook the trackpad ceases to register any inputs from me. Once unplugged the trackpad resumes normal operation.

    I'm not using any Logitech drivers, just the Mac OS ones. The only thing I have running is SteerMouse - and there are no options regarding trackpad or mousing, I use it just to correct the Mac acceleration curve of the mouse.
  • 3. Re: Way to use both trackpad and mouse at the same time?
    deltatux Level 2 Level 2 (485 points)
    try the logitech drivers ... i have a Logitech Bluetooth mouse attached to mine and there are no problems using both. I have installed the Logitech drivers.

    deltatux
  • 4. Re: Way to use both trackpad and mouse at the same time?
    Douglas McLaughlin Level 9 Level 9 (63,735 points)
    Really?! No, there are no error messages - it just doesn't function.


    Thanks for that. It was not clear from your original post that it wasn't functioning or what you'd tried to do already to fix the issue.

    I think you have a problem with Logitech or SteerMouse then, not Mac OS X. My Apple Mighty Mouse (USB) allows me to use the trackpad as well a the Bluetooth version. There's nothing built-in to Mac OS X to prevent you from using a mouse and trackpad at the same time.

    -Doug
  • 5. Re: Way to use both trackpad and mouse at the same time?
    Jeremy Riga Level 1 Level 1 (30 points)
    Finally had some time today to mess with this... uninstalled SteerMouse, made sure Logitech was fully uninstalled, repaired permissions, restarted.

    No luck... even plugged in my MightyMouse (wired) and tried it with that. The trackpad just will not register any inputs with any mouse plugged in.

    Also created a fresh user account and switched over to that thinking it was something in my user Library causing it. But, no luck again.

    I seem to remember somewhere in the Sys Prefs seeing a 'When mouse is plugged in ignore input from trackpad' but honestly can't remember where or if it was on OS X.

    Any other thoughts?
  • 6. Re: Way to use both trackpad and mouse at the same time?
    Glorfindeal Level 6 Level 6 (9,330 points)
    I don't have my mba on me, but isn't there an option under the mouse/track pad system preference to disable the trackpad when a mouse is attached? If so, uncheck this option if it is checked.

    Glor
  • 7. Re: Way to use both trackpad and mouse at the same time?
    Jeremy Riga Level 1 Level 1 (30 points)
    Yes, exactly! I remember that too!! But it's definitely not an option in the 'Mouse/Keyboard' or 'Trackpad' control panels in 10.5.5 Leopard. I searched for it in Help, on Google, etc...

    I just can't seem to find anything!
  • 8. Re: Way to use both trackpad and mouse at the same time?
    Glorfindeal Level 6 Level 6 (9,330 points)
    it looks like that macbooks/pros that have the gesture trackpad no longer has this option available. It should be enabled by default. You may have a problem with the driver of your mouse. If you can find someone with an apple mouse, check it with that. If it works, the it is your 3rd party mouse.

    Glor
  • 9. Re: Way to use both trackpad and mouse at the same time?
    Jeremy Riga Level 1 Level 1 (30 points)
    Per my previous post, I tried an Apple Mighty Mouse and the trackpad was still unable to be used while it was plugged in. Very strange.

    I've always done clean installs when I get new Macs, and then transfer my files via Migration Assistant. So I would assume if something was enabled by default it would be intact on this mac. It's a MacBook and is only 1 week old.

    Wish I could get this figured out!
  • 10. Re: Way to use both trackpad and mouse at the same time?
    Douglas McLaughlin Level 9 Level 9 (63,735 points)
    Use the Accounts System Preferences to create a brand new user. Log out and log in as the new user. Does the new user have the same trouble? If so, then you have a system-wide or hardware problem. If not, then your user has a preference or setting that's interfering. Let us know what you find out from this troubleshooting step.

    -Doug
  • 11. Re: Way to use both trackpad and mouse at the same time?
    JCC123 Level 1 Level 1 (30 points)
    I'm having the same issue. I used the migration assistant when I transferred my girlfriend’s old white MacBook to her new Alum MacBook. On her old White one the configuration was set so that if the mighty mouse was connected then the trackpad won’t work. I assumed erroneously I guess that the same toggle would be available to the new OS. Well, to my surprise, it isn’t. So now the mouse will disable the trackpad when it’s connected and there’s no way to toggle it!!!

    I tried connecting the mouse to my new Alum MacBook Pro just to see if it defaults to enable or disable and it defaults to enable so I’m able to use BOTH the mouse AND the trackpad on my new MacBook Pro.
  • 12. Re: Way to use both trackpad and mouse at the same time?
    Jeremy Riga Level 1 Level 1 (30 points)
    Creating a new user account and then plugging in my mouse allows me to continue using the trackpad. So, it's a user-specific issue. I'm positive this is something that could be corrected in terminal or similar, but I wouldn't have any idea where to find it.
  • 13. Re: Way to use both trackpad and mouse at the same time?
    Douglas McLaughlin Level 9 Level 9 (63,735 points)
    This is good, at least we've determined that it's not a hardware conflict or system/software conflict. It's fairly straightforward to troubleshoot this and you may even be able to determine exactly which preference file of yours is causing the trouble. (This won't involve the Terminal!) I would drag your entire user's "Preferences" folder to the Desktop, log out and log back, then check to see if the problem is gone. You can find the folder in this path:

    <Macintosh HD>/Users/<YourUsersShortName>/Library/Preferences

    A brand new "Preferences" folder will automatically be created. If that did fix the issue, you have two options. One, go on about your business and reset all your preferences as needed from inside each application. (This might be the simplest thing to do, as your pictures in iPhoto and music in iTunes should not be affected.) Two, drag a few preference files from the folder on your Desktop into the newly created Preferences folder in your Library folder, log out and log back in and see if it's still working. By doing this, you may be able to determine exactly which preference file is blocking the use of both the trackpad and mouse at the same time. Personally, I think it's easier to manually reset all the preferences from each application.

    -Doug
  • 14. Re: Way to use both trackpad and mouse at the same time?
    Kurnalbert Level 1 Level 1 (0 points)
    I am having the exact same issue on my brand new Macbook. I transferred my user account from my old White Macbook to this new one and now the trackpad disables itself when a mouse is plugged in.

    Does anybody have any idea what preference file to delete to fix this? I tried deleting com.apple.driver.AppleHIDMouse.plist which reset some of my mouse settings but didn't fix the trackpad issue. Anyone else have any ideas?

    Any help would be greatly appreciated as this is starting to annoy me now.
1 2 Previous Next