5 Replies Latest reply: Jan 19, 2009 6:45 AM by midtoad@shaw.ca
Kris Jones Level 1 Level 1 (55 points)
I've attempted several times to update Boot Camp to version 2.1. Each time I try to run the update I get the following message:

"The installer encountered errors before Boot Camp could be configured. To retry these operations at a later time. please run the installer again".

I've deleted and downloaded the installer on several occasions only to be confronted with the same message. I've also run the "repair installation" program on the existing version of Boot Camp to see if there is an error that prevents the update working. I've also followed the advice in the following Support Article:

http://support.apple.com/kb/HT1845

Running msiexec /update from the Command Line in XP results in the same error message I quoted above.

Has anyone got any idea how I can resolve this? I'd be grateful for any help offered.

iMac Core 2 Duo 1.83 Ghz, Mac OS X (10.5.5), Boot Camp 2.0. Windows XP Pro SP2
  • 1. Re: Unable to install Boot Camp 2.1 Updater
    iBay14 Level 1 Level 1 (5 points)
    There are lots of things that cause the installer not to cycle through. The two major are 1) a conflict of some kind with a display driver. 2) a conflict with the language of your cuurently running Boot Camp 2.0.

    If its your Display driver you need to go to -> Control Panel -> System -> Hardware Tab -> Device Manager -> Display Adaptors.
    Look at how many Display adaptors you have. You really only need one(which sometimes is there twice). If you have more than one then you probably have a program like "GoToMyPc" or LogMeIn" which has put it's display adaptor there. If that is the case then you need to first unistall the program and then in the Display Adaptors section -> del the driver.

    Test if this is the source of your prblem by running the installer again.

    (P.S) there are a few PC video games and other programs that install Display drivers so if you dont have either of the Remote Access Programs I mentions be aware that that the conflicting Display Driver could be comming from another program.


    If your problem is a conflict in the language of your running version of Boot Camp then you'll need to do the following
    in Windows goto Start ->Run -> type "regedit" click OK -> in the new window go to EDIT -> Find -> type "Boot Camp Services.
    The Boot Camp setting should come up if they did not come up try another search with Boot-Camp Services. Look at the language settings. If you run in English it should have a Value of 0X00000409 (1033). If it does not then modify the info to match. This only works if your set to English. If not then you will need to investigate the values for your language.

    I Hope this helps.
  • 2. Re: Unable to install Boot Camp 2.1 Updater
    Kris Jones Level 1 Level 1 (55 points)
    Thank you iBay. I did indeed have LogMeIn installed. Following your instructions to remove the LogMeIn display adaptor, I have now successfully applied the Boot Camp Updater.

    I'm most grateful for your help.
  • 3. Re: Unable to install Boot Camp 2.1 Updater
    Mortiz Level 1 Level 1 (0 points)
    iBay14:
    Thanks ! I have been struggling for several months with an installation error of BootCamp 2.1 on XP and your language tip solvd my problem ! Very grateful to you !

    I'm an Engineer, fairly savvy on windows and Mac and lost a lot of time. I can't conceive how come Apple does not provide nearly adequate support and makes its customers loose so much time :((.

    Regards, Mortiz
  • 4. Re: Unable to install Boot Camp 2.1 Updater
    paulotex Level 1 Level 1 (0 points)
    Hi. The suggestion worked, but with some modifications. My problem as the language settings, but I couldn't find the string "Boot Camp Services", because the string was in the foreigner language. In my case, it was in the language of my keyboard settings, portuguese: "Serviços Boot Camp". So I had to search for "Boot Camp" and select the match that allowed my to change the language settings. After doing that, the installer worked fine Here is another forum post about this language issue:
    <http://discussions.apple.com/thread.jspa?messageID=8693592&#8693592>
  • 5. Re: Unable to install Boot Camp 2.1 Updater
    midtoad@shaw.ca Level 1 Level 1 (25 points)
    Just adding onto this thread with some additional information...

    The suggestion about multiple display adapters was useful to me. In my case, I discovered that the Mirror Driver installed by UltraVNC was the problem. Now, disabling that display in Device Manager was not sufficient; I actually had to stop the VNC service then completely uninstall the application. After that, Boot Camp updated successfully.

    Thanks for the suggestion!