Skip navigation
This discussion is archived

dmnotifyd, FileSyncAgent, dotmacsyncclient + proxy

3294 Views 14 Replies Latest reply: Dec 16, 2008 2:51 AM by nrhnrh RSS
Rooey Calculating status...
Currently Being Moderated
Sep 19, 2008 2:50 AM
Ok so already we're at 5.5 and still running OS X behind a proxy turns your mac into a cheese greater - don't even think about enabling your idisk, once it's switched on these three puppies fire up and gobble 100% of both cores.

To actually get any work done you need to manually kill the processes (which works for about 10 minutes before they realise and re-start.

Don't think about accessing the mobile me preferences pane to turn it back off - you won't be able to... accessing it causes the processes to re-initialise and wait for ever... crashing system preferences in the process.

Come on apple - this issue was reported as soon as you "fixed" the memory issue in 10.5.1

I don't want to get to work and feel like throwing my mac out of a window. (although it would probably glide nicely...)

Surely i'm not alone in this suffering? I've read a load of locked threads, old articles with suggested solutions and as-yet nothing has worked.

*pulls hair out in frustration*
Pick One..., Mac OS X (10.5)
  • タケル 光子郎 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Sep 19, 2008 5:10 AM (in response to Rooey)
    I've got exactly the same problem.

    MobileMe sync is unusable and eats 100% cpu per core for each sync process when using a proxy (PAC autoconfiguration). I've read several threads on this and found no acceptable solution (I cannot switch off proxy use).
    At least, I managed to get iDisk sync disabled after manually editing the preferences file. Since I do not use my iDisk much, it's not a big loss. But disabling .Mac sync would render my complete subscription useless.

    Why doesn't anyone seem to care, since according to this forum this problem is at least as old as Leopard is?
    MacBook Pro, Mac OS X (10.5.5)
  • Kim Kwan Calculating status...
    Currently Being Moderated
    Sep 26, 2008 1:05 PM (in response to Rooey)
    Same here (auto proxy configuration is enabled).

    I am disappointed (an emotion I've never experienced while using an Apple product), and very surprised to hear that this is a very old problem. 10.5.6 had better fix it.
    MacBook 2.16GHz, Mac OS X (10.5.5), iPhone (2007) 16GB with software version 2.1
  • Michael Prewitt Level 1 Level 1 (15 points)
    Currently Being Moderated
    Oct 3, 2008 6:43 PM (in response to Rooey)
    Same problem here. FileSyncAgent using 99-100% CPU, after starting to use PAC. In my case I can turn PAC off, although my internet speed could take a hit. Seems like an obvious bug!
    MacBook Pro 2.4 GHz Intel Core 2 Duo, Mac OS X (10.5.5)
  • dialectician Level 1 Level 1 (95 points)
    Same problem here. dmnotify and dotmacsyncclient are at 99%+ of CPU usage. I run the activity monitor and kill the processes every now and again, but it's a real pain, and I don't understand why I should be paying for such a lousy sync-service from Mobileme. Also using proxy.pac
    Macbook 2.0GHz, Mac OS X (10.5.5), 2GB RAM, 120 GB HD
  • bobbyrufener Level 1 Level 1 (0 points)
    Currently Being Moderated
    Oct 22, 2008 2:08 PM (in response to Rooey)
    Throwing my hat in with you all in this. I have had the same issue with this and with iTunes not working with the proxy auto-config (PAC) file. It also does not work on manual proxy configuration. I hope there is a solution forthcoming because having to disable these processes can not be the permanent solution.
    Macbook Pro (Late 2007), Mac OS X (10.5.5), 2.2gHz, 4GB DDR2 PC6400; iPod Touch 8GB (2nd Gen)
  • cal6n Level 2 Level 2 (265 points)
    Currently Being Moderated
    Nov 6, 2008 9:35 AM (in response to Rooey)
    Count me in too.

    I've got dotmacsyncclient squatting on one of my cores when i use a proxy whether I use a .pac file or manual configuration.
    Mac Pro 2.66 Octo, 15" 2.0 MBP, 15" 1.67 G4 PB, 1.4 G4 Cube (tri-boot), Mac OS X (10.5.2)
  • Kim Kwan Level 1 Level 1 (5 points)
    Currently Being Moderated
    Nov 13, 2008 2:15 PM (in response to Rooey)
    Here's something. I recently migrated over to the new MacBook Pro, and for some reason my MobileMe sync schedule setting didn't get transferred over. Right now it's on "every hour" rather than "automatically", and somehow the agents don't take up the CPU anymore. Changing the setting back to auto hangs System Preferences though.

    It's not ideal (and basically devolves MobileMe back to .Mac), but at least it stops the fan from running 24/7.

    Message was edited by: Kim Kwan
    MacBook Pro (Late 2008) 2.8GHz, Mac OS X (10.5.5), iPhone 3G 16GB
  • タケル 光子郎 Level 1 Level 1 (0 points)
    Currently Being Moderated
    Nov 13, 2008 11:04 PM (in response to Kim Kwan)
    Setting sync schedule to "every hour" doesn't make a difference for me. The sync completes (manually started for a test), but then the dotmacsyncclient application hangs again eating 99% CPU.

    So looks like some other (internal?) setting on your partly migrated machine differs from ours.
    MacBook Pro 2,2, Mac OS X (10.5.5)
  • Bodo_von_Greif Calculating status...
    Currently Being Moderated
    Nov 24, 2008 7:31 AM (in response to Rooey)
    Hi,

    same for me.

    No problems with proxy set by hand. pac -> dmnotifyd eats up 100% CPU of one core,

    kind regards,

    Toni
    iMac24, Mac OS X (10.5.5)
  • dchatt Calculating status...
    I'm having the same problem too - PAC file or without. Luckily I'm on a trial of this MobileMe nonsense and so I'll be cancelling my subscription if I don't get a fix soon.
    Macbook Pro, Mac OS X (10.5.5)
  • John Shoemaker Calculating status...
    Currently Being Moderated
    Dec 13, 2008 4:40 AM (in response to Rooey)
    I am at the same problem. dotmacsyncclient gobbles everything. Every 10/15 minutes my computer fan is full blast, temp is over 190. I am behind a proxy. I have to keep activity monitor open at all time. Hopefully the new patch will fix it because I'm expecting my computer to overheat or something soon.
    MacBook, Mac OS X (10.5.5)
  • iNik Calculating status...
    I had some success by logging out of Mobile Me (which also required sending a few "sudo killall -KILL FileSyncAgent" in order for the system preference to not just beachball out on me) and then logging back in. We'll see if it's just mystic juju, but it seems to have helped for now.
    AiBook G4 12 1ghz, Mac OS X (10.4)
  • Kim Kwan Level 1 Level 1 (5 points)
    Currently Being Moderated
    Dec 15, 2008 4:05 PM (in response to Rooey)
    Anybody know if the 10.5.6 update fixes this? I'm currently on Christmas break, so I don't have to put up with the university's proxies and thus won't be able to test it until mid-January.
    MacBook Pro (Late 2008) 2.8GHz, Mac OS X (10.5.6), iPhone 3G 16GB
  • nrhnrh Calculating status...
    Currently Being Moderated
    Dec 16, 2008 2:51 AM (in response to Kim Kwan)
    10.5.6 seems to fix it for me on several computers. so far so good!
    Macbook Air, Mac OS X (10.5.6)

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.