Skip navigation
This discussion is archived

Software Update Keeps Installing the Same Update

2522 Views 12 Replies Latest reply: Feb 8, 2009 7:29 PM by Jeff Zacharias RSS
Jeff Zacharias Level 1 Level 1 (105 points)
Currently Being Moderated
Nov 25, 2008 7:13 PM
This past week Software Update installed Pro Applications Update 2008-04. Every day since then it tells me that the same update is available. I must have installed it 3 times by now but Software Update still says it needs to be installed. I even downloaded and installed it. The receipts look like they get created fine (ProAppsEffects.pkg and PluginManager.pkg). I don't want to "ignore" this update because I want this update and all future updates. How can I make Software Update stop trying to reinstall this update ?
iMac Aluminum, Mac OS X (10.5.5)
  • Jane Knox Level 3 Level 3 (690 points)
    Basic trouble shooting...

    Have you shut down and restarted the computer?

    Run Disk Utility Repair Permissions?

    Run Disk Utility Verify Disk?
    MacBook Pro - MacBook - MacBook Air SSD, Mac OS X (10.5.5), AEBS 802.11(n)
  • rtakayasu Level 1 Level 1 (45 points)
    Hi Zacharias-san,

    Can you tell me little more of you configurations? For example, what Apple softwares have you installed? Is there anything particular about your configuration?

    Have you performed any Migration or Archive and Install?

    Can you also provide the content of the Software Update log (/Library/Logs/Software Update.log?

    Perhaps, these information may provide a clue to your problem.


    Arigatou gozaimasu,
    Ryu
  • Christopher B Calculating status...
    Hi there. I'd like to take a look at a log from install-time and see why you're getting offered the update over and over again. With Console open, could you do the following for me:

    First, select the logfile /var/log install.log, then hit the Clear Display button (see http://skitch.com/cbowns/7pfd/install.log).

    Next, launch Software Update and install the ProApps Update 2008-04. Once it's done, copy and paste the whole (rather long) log from Console and post it up here.
    MacBook Pro (4,1), Mac OS X (10.5.5)
  • Christopher B Level 1 Level 1 (5 points)
    Great, this is a big help.

    Next, could I get the version numbers for the following seven bundles?

    The best way to get the version numbers: in Finder, hit command-shift-g to open the "Go To Folder…" window, copy and paste one of the paths in, and hit enter. Then double-click the Resources folder, and drag and drop version.plist onto TextEdit. The lines you want look like:

    <key>CFBundleShortVersionString</key>
    <string>1.2.3</string>


    The list of frameworks:

    /Library/Application Support/ProApps/Internal Plug-ins/FxPlug/SmoothCam.fxplug
    /Library/Application Support/ProApps/Internal Plug-ins/FxPlug/Filters.bundle
    /Library/Frameworks/PluginManager.framework
    /Library/Frameworks/FxPlug.framework
    /Library/Frameworks/ProFX.framework
    /Library/Application Support/ProApps/Internal Plug-Ins/FXMetaPlug/ImageUnit.fxmetaplug
    /Library/Application Support/ProApps/Internal Plug-Ins/ProFX/FXPlugWrapper.plugin
    MacBook Pro (4,1), Mac OS X (10.5.5)
  • rtakayasu Level 1 Level 1 (45 points)
    Thank you for the information Zacharias-san,

    Before I suggest any course of action, I recommend checking the following version numbers. These are the expected version numbers (that I'm aware of currently) after updating Pro Applications 2008-04. Inside each version.plist, there is a version number for the key "CFBundleShortVersionString". This is a painful process; if you're (or someone else) is shell script guru, I recommend writing a shell script.

    Since you mention that you have Final Cut Studio and Aperture, my guess is that either ImageUnit.fxmetaplug, FxPlugWrapper.plugin, PluginManager.framework, FxPlug.framework or ProFX.framework are not getting updated for some reason.

    Hopefully, we can get to the bottom of this issue,
    Ryu

    3.0.5 /Applications/Apple Qmaster.app/Contents/version.plist
    3.0.5 /Applications/Utilities/Batch Monitor.app/Contents/version.plist
    3.0.5 /Applications/Compressor.app/Contents/version.plist
    6.0.5 /Applications/Final Cut Pro.app/Contents/version.plist
    1.0.3 /Applications/Color.app/Contents/version.plist
    3.0.5 /Library/Frameworks/Compressor.framework/Versions/A/Resources/version.plist
    3.0.5 /Library/Frameworks/Qmaster.framework/Versions/A/Resources/version.plist
    3.0.5 /Library/Frameworks/MediaServerAPI.framework/Versions/A/Resources/version.plist
    3.0.5 /Library/Frameworks/AECore.framework/Versions/A/Resources/version.plist
    1.4.1 /Library/QuickTime/AppleHDVCodec.component/Contents/version.plist
    1.0.2 /Library/QuickTime/AppleProRes422.component/Contents/version.plist
    2.1.2 /System/Library/PrivateFrameworks/Helium.framework/Versions/A/Resources/version .plist
    1.3.1 /Library/QuickTime/IMXCodec.component/Contents/version.plist
    1.7.3 /Library/Frameworks/PluginManager.framework/Versions/B/Resources/version.plist
    1.2.3 /Library/Frameworks/FxPlug.framework/Versions/A/Resources/version.plist
    1.2.3 /Library/Frameworks/ProFX.framework/Versions/A/Resources/version.plist
    1.2.3 /Library/Application Support/ProApps/Internal Plug-Ins/ProFX/FxPlugWrapper.plugin/Contents/version.plist
    3.0.2 /Library/Application Support/ProApps/Internal Plug-Ins/FxPlug/Filters.bundle/Contents/version.plist
    7.5.5 /Library/Application Support/ProApps/MIO/RAD/Components/QuickTimeH264.component/Contents/version.pli st
    1.5 /Library/QuickTime/FCP Uncompressed 422.component/Contents/version.plist
    3.0.5 /Applications/Apple Qadministrator.app/Contents/version.plist
    2.1.3 /Library/QuickTime/LiveType.component/Contents/version.plist
    2.1.3 /System/Library/PrivateFrameworks/LiveType.framework/Versions/A/Resources/versi on.plist
    3.0.2 /Library/Application Support/ProApps/Bundles/Motion.bundle/Contents/version.plist
    1.0 /Library/Application Support/ProApps/Internal Plug-Ins/ProFX/QCMotionPatch.plugin/Contents/version.plist
    1.2.2 /Library/Application Support/ProApps/Internal Plug-Ins/FxMetaPlug/ImageUnit.fxmetaplug/Contents/version.plist
    1.0.1 /Library/Frameworks/PluginManager.framework/Versions/A/Resources/version.plist
    1.0.1 /Library/Application Support/ProApps/Internal Plug-Ins/FxPlug/SmoothCam.fxplug/Contents/version.plist
    0.5 /Library/Frameworks/ProMetadataSupport.framework/Versions/A/Resources/version.p list
    2.0.2 /Library/Application Support/ProApps/Bundles/Soundtrack Pro Integration.bundle/Contents/version.plist
    Macintosh 128K, Mac OS 8.6 or Earlier
  • rtakayasu Level 1 Level 1 (45 points)
    Thank you Zacharias-san,

    From what I can see from your information that your provided, Pro Application Update 2008-04 should not show up. There must be some other piece that's causing it to show up.

    Perhaps another way to approach this problem is to download and run the manual updater, and look at the installer log. This may tell us what was installed and what was not.


    -Ryu
    Macintosh 128K, Mac OS 8.6 or Earlier

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.